Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Przełączanie się pomiędzy kartami graficznymi (Intel/NVIDIA)
#1
0
Witajcie, mam laptopa, który posiada dwie karty zintegrowane Intela oraz dedykowaną NVIDIA Geforce GT 340M. Mam zainstalowane sterowniki NVIDIA 340.108 patch-owane dla tej karty. Nie mogę poradzić sobie z zainstalowaniem Optimus-manager i optimus-manager-qt, aby móc się przełączać pomiędzy kartami w zależności od potrzeb. 

Poniżej przedstawiam wyniki dla polecenia:
Kod:
inxi --admin --verbosity=7 --filter --no-host --width
*Dedito. Co to wyżej ma wspólnego z kodem PHP? Poprawiłem.
Jaki to ma sens jeśli poniżej podajesz to samo?

Kod:
[[email protected] ~]$ inxi --admin --verbosity=7 --filter --no-host --width
System:
  Kernel: 5.18.10-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.18-x86_64
    root=UUID=59a0007c-1f75-4ba1-8006-232fa170e177 rw quiet
    resume=UUID=3464b826-623e-412f-bd2a-504365f5cff9 udev.log_priority=3
  Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 7 dm: LightDM v: 1.30.0 Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: SAMSUNG product: R580/R590 v: N/A
    serial: <superuser required> Chassis: type: 9 serial: <superuser required>
  Mobo: SAMSUNG model: R580/R590 serial: <superuser required> BIOS: Phoenix
    v: 08JB.M032.20100331.hkk date: 03/31/2010
Battery:
  ID-1: BAT1 charge: 33.3 Wh (78.9%) condition: 42.2/48.8 Wh (86.4%)
    volts: 11.1 min: 11.1 model: SAMSUNG Electronics type: Li-ion serial: N/A
    status: N/A
  Device-1: hidpp_battery_0 model: Logitech M215 serial: <filter>
    charge: 55% (should be ignored) rechargeable: yes status: discharging
Memory:
  RAM: total: 7.63 GiB used: 1.6 GiB (21.0%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: model: Intel Core i3 M 330 bits: 64 type: MT MCP arch: Westmere
    gen: core 1 built: 2010-11 process: Intel 32nm family: 6 model-id: 0x25 (37)
    stepping: 2 microcode: 0x11
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1415 high: 1463 min/max: 933/2133 scaling:
    driver: acpi-cpufreq governor: schedutil cores: 1: 1274 2: 1463 3: 1463
    4: 1463 bogomips: 17030
  Flags: acpi aperfmperf apic arat arch_perfmon bts clflush cmov
    constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts ept est flexpriority
    flush_l1d fpu fxsr ht ibpb ibrs lahf_lm lm mca mce mmx monitor msr mtrr
    nonstop_tsc nopl nx pae pat pbe pdcm pebs pge pni popcnt pse pse36 pti
    rdtscp rep_good sep ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2
    tpr_shadow tsc vme vmx vnmi vpid xtopology xtpr
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds
    status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GT216M [GeForce GT 330M] vendor: Samsung Co driver: nvidia
    v: 340.108 alternate: nouveau non-free: 340.xx
    status: legacy (EOL, try --gpu) arch: Tesla process: 40-80nm
    built: 2006-13 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 2
    speed: 5 GT/s bus-ID: 02:00.0 chip-ID: 10de:0a29 class-ID: 0300
  Device-2: Z-Star Micro WebCam SCB-1900N type: USB driver: uvcvideo
    bus-ID: 1-1.1:3 chip-ID: 0ac8:c342 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.3 compositor: xfwm v: 4.16.1 driver: X:
    loaded: nvidia gpu: nvidia display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 102 s-size: 340x191mm (13.39x7.52")
    s-diag: 390mm (15.35")
  Monitor-1: LVDS-0 res: 1366x768 hz: 60 dpi: 101
    size: 344x194mm (13.54x7.64") diag: 395mm (15.55") modes: N/A
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: Intel 5 Series/3400 Series High Definition Audio
    vendor: Samsung Co R730 Laptop driver: snd_hda_intel v: kernel
    bus-ID: 00:1b.0 chip-ID: 8086:3b56 class-ID: 0403
  Device-2: NVIDIA GT216 HDMI Audio vendor: Samsung Co driver: snd_hda_intel
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 2
    speed: 5 GT/s bus-ID: 02:00.1 chip-ID: 10de:0be2 class-ID: 0403
  Sound Server-1: ALSA v: k5.18.10-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
Network:
  Device-1: Qualcomm Atheros AR9285 Wireless Network Adapter
    vendor: Foxconn T77H121.05 802.11bgn driver: ath9k v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 168c:002b class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Marvell Yukon Optima 88E8059 [PCIe Gigabit Ethernet with AVB]
    vendor: Samsung Co driver: sky2 v: 1.30 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 5000 bus-ID: 07:00.0 chip-ID: 11ab:4381 class-ID: 0200
  IF: enp7s0 state: down mac: <filter>
  WAN IP: <filter>
Bluetooth:
  Device-1: Broadcom Bluetooth 2.1 Device type: USB driver: btusb v: 0.8
    bus-ID: 1-1.3:4 chip-ID: 0a5c:219b class-ID: fe01 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 111.79 GiB used: 8.21 GiB (7.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SHSS37A120G
    size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: SSD serial: <filter> rev: 00.r scheme: MBR
  Optical-1: /dev/sr0 vendor: TSSTcorp model: CDDVDW TS-L633C rev: SC01
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
Partition:
  ID-1: / raw-size: 102.99 GiB size: 100.81 GiB (97.89%) used: 8.21 GiB (8.1%)
    fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: 59a0007c-1f75-4ba1-8006-232fa170e177
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda2 maj-min: 8:2 label: swap
    uuid: 3464b826-623e-412f-bd2a-504365f5cff9
Unmounted:
  Message: No unmounted partitions found.
USB:
  Hub-1: 1-0:1 info: Full speed or root hub ports: 3 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0020 class-ID: 0900
  Device-1: 1-1.1:3 info: Z-Star Micro WebCam SCB-1900N type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 320mA
    chip-ID: 0ac8:c342 class-ID: 0e02
  Device-2: 1-1.3:4 info: Broadcom Bluetooth 2.1 Device type: Bluetooth
    driver: btusb interfaces: 4 rev: 2.0 speed: 12 Mb/s chip-ID: 0a5c:219b
    class-ID: fe01 serial: <filter>
  Hub-3: 2-0:1 info: Full speed or root hub ports: 3 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0020 class-ID: 0900
  Device-1: 2-1.2:3 info: Logitech Unifying Receiver type: Mouse,HID
    driver: logitech-djreceiver,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
    power: 98mA chip-ID: 046d:c52f class-ID: 0300
Sensors:
  System Temperatures: cpu: 54.0 C mobo: N/A gpu: nvidia temp: 59 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 181 Uptime: 3m wakeups: 5 Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6 Packages: pacman: 936
  lib: 287 Shell: Bash v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.19
[[email protected] ~]$

Jeśli dla mojej konfiguracji sprzętowej nie jest możliwe wykonanie przełączania pomiędzy kartami to jak ustawić, aby każda sesja odbywała się na karcie dedykowanej Geforce, a nie zintegrowanej.
Odpowiedz
#2
0
(17-07-2022, 18:22)brzezin89 napisał(a): Witajcie, mam laptopa, który posiada dwie karty zintegrowane Intela oraz dedykowaną NVIDIA Geforce GT 340M. Mam zainstalowane sterowniki NVIDIA 340.108 patch-owane dla tej karty. Nie mogę poradzić sobie z zainstalowaniem Optimus-manager i optimus-manager-qt, aby móc się przełączać pomiędzy kartami w zależności od potrzeb. 

Poniżej przedstawiam wyniki dla polecenia:
Kod:
inxi --admin --verbosity=7 --filter --no-host --width
*Dedito. Co to wyżej ma wspólnego z kodem PHP? Poprawiłem.
Jaki to ma sens jeśli poniżej podajesz to samo?

Kod:
[[email protected] ~]$ inxi --admin --verbosity=7 --filter --no-host --width
System:
  Kernel: 5.18.10-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.18-x86_64
    root=UUID=59a0007c-1f75-4ba1-8006-232fa170e177 rw quiet
    resume=UUID=3464b826-623e-412f-bd2a-504365f5cff9 udev.log_priority=3
  Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 7 dm: LightDM v: 1.30.0 Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: SAMSUNG product: R580/R590 v: N/A
    serial: <superuser required> Chassis: type: 9 serial: <superuser required>
  Mobo: SAMSUNG model: R580/R590 serial: <superuser required> BIOS: Phoenix
    v: 08JB.M032.20100331.hkk date: 03/31/2010
Battery:
  ID-1: BAT1 charge: 33.3 Wh (78.9%) condition: 42.2/48.8 Wh (86.4%)
    volts: 11.1 min: 11.1 model: SAMSUNG Electronics type: Li-ion serial: N/A
    status: N/A
  Device-1: hidpp_battery_0 model: Logitech M215 serial: <filter>
    charge: 55% (should be ignored) rechargeable: yes status: discharging
Memory:
  RAM: total: 7.63 GiB used: 1.6 GiB (21.0%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: model: Intel Core i3 M 330 bits: 64 type: MT MCP arch: Westmere
    gen: core 1 built: 2010-11 process: Intel 32nm family: 6 model-id: 0x25 (37)
    stepping: 2 microcode: 0x11
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1415 high: 1463 min/max: 933/2133 scaling:
    driver: acpi-cpufreq governor: schedutil cores: 1: 1274 2: 1463 3: 1463
    4: 1463 bogomips: 17030
  Flags: acpi aperfmperf apic arat arch_perfmon bts clflush cmov
    constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts ept est flexpriority
    flush_l1d fpu fxsr ht ibpb ibrs lahf_lm lm mca mce mmx monitor msr mtrr
    nonstop_tsc nopl nx pae pat pbe pdcm pebs pge pni popcnt pse pse36 pti
    rdtscp rep_good sep ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2
    tpr_shadow tsc vme vmx vnmi vpid xtopology xtpr
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds
    status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GT216M [GeForce GT 330M] vendor: Samsung Co driver: nvidia
    v: 340.108 alternate: nouveau non-free: 340.xx
    status: legacy (EOL, try --gpu) arch: Tesla process: 40-80nm
    built: 2006-13 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 2
    speed: 5 GT/s bus-ID: 02:00.0 chip-ID: 10de:0a29 class-ID: 0300
  Device-2: Z-Star Micro WebCam SCB-1900N type: USB driver: uvcvideo
    bus-ID: 1-1.1:3 chip-ID: 0ac8:c342 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.3 compositor: xfwm v: 4.16.1 driver: X:
    loaded: nvidia gpu: nvidia display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 102 s-size: 340x191mm (13.39x7.52")
    s-diag: 390mm (15.35")
  Monitor-1: LVDS-0 res: 1366x768 hz: 60 dpi: 101
    size: 344x194mm (13.54x7.64") diag: 395mm (15.55") modes: N/A
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: Intel 5 Series/3400 Series High Definition Audio
    vendor: Samsung Co R730 Laptop driver: snd_hda_intel v: kernel
    bus-ID: 00:1b.0 chip-ID: 8086:3b56 class-ID: 0403
  Device-2: NVIDIA GT216 HDMI Audio vendor: Samsung Co driver: snd_hda_intel
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 2
    speed: 5 GT/s bus-ID: 02:00.1 chip-ID: 10de:0be2 class-ID: 0403
  Sound Server-1: ALSA v: k5.18.10-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
Network:
  Device-1: Qualcomm Atheros AR9285 Wireless Network Adapter
    vendor: Foxconn T77H121.05 802.11bgn driver: ath9k v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 168c:002b class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Marvell Yukon Optima 88E8059 [PCIe Gigabit Ethernet with AVB]
    vendor: Samsung Co driver: sky2 v: 1.30 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 5000 bus-ID: 07:00.0 chip-ID: 11ab:4381 class-ID: 0200
  IF: enp7s0 state: down mac: <filter>
  WAN IP: <filter>
Bluetooth:
  Device-1: Broadcom Bluetooth 2.1 Device type: USB driver: btusb v: 0.8
    bus-ID: 1-1.3:4 chip-ID: 0a5c:219b class-ID: fe01 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 111.79 GiB used: 8.21 GiB (7.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SHSS37A120G
    size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: SSD serial: <filter> rev: 00.r scheme: MBR
  Optical-1: /dev/sr0 vendor: TSSTcorp model: CDDVDW TS-L633C rev: SC01
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
Partition:
  ID-1: / raw-size: 102.99 GiB size: 100.81 GiB (97.89%) used: 8.21 GiB (8.1%)
    fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: 59a0007c-1f75-4ba1-8006-232fa170e177
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda2 maj-min: 8:2 label: swap
    uuid: 3464b826-623e-412f-bd2a-504365f5cff9
Unmounted:
  Message: No unmounted partitions found.
USB:
  Hub-1: 1-0:1 info: Full speed or root hub ports: 3 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0020 class-ID: 0900
  Device-1: 1-1.1:3 info: Z-Star Micro WebCam SCB-1900N type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 320mA
    chip-ID: 0ac8:c342 class-ID: 0e02
  Device-2: 1-1.3:4 info: Broadcom Bluetooth 2.1 Device type: Bluetooth
    driver: btusb interfaces: 4 rev: 2.0 speed: 12 Mb/s chip-ID: 0a5c:219b
    class-ID: fe01 serial: <filter>
  Hub-3: 2-0:1 info: Full speed or root hub ports: 3 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0020 class-ID: 0900
  Device-1: 2-1.2:3 info: Logitech Unifying Receiver type: Mouse,HID
    driver: logitech-djreceiver,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
    power: 98mA chip-ID: 046d:c52f class-ID: 0300
Sensors:
  System Temperatures: cpu: 54.0 C mobo: N/A gpu: nvidia temp: 59 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 181 Uptime: 3m wakeups: 5 Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6 Packages: pacman: 936
  lib: 287 Shell: Bash v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.19
[[email protected] ~]$

Jeśli dla mojej konfiguracji sprzętowej nie jest możliwe wykonanie przełączania pomiędzy kartami to jak ustawić, aby każda sesja odbywała się na karcie dedykowanej Geforce, a nie zintegrowanej.
Mam też taka konfigurację. Z tego co słyszałem aby przełączanie między kartami działało musi być sterownik który się nazywa "bumblebee" niestety nie próbowałem tego u siebie bo jestem cały czas na GeForce bo i tak ta karta ma nie wiele lepsza wydajność niż Intel integrowany. Wystarczy że w biosie wybierzesz ustawienie chyba graphic Device i dasz na Optimus. Opcja UMA to integrowany Intel.
Odpowiedz
#3
0
Pytać o Manjaro na forum Minta... masz kolego fantazję Smile

https://wiki.manjaro.org/index.php/Confi...idia-prime
Odpowiedz


Skocz do:




Użytkownicy przeglądający ten wątek: 1 gości