Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Blueman - komunikat: Rfkill wymaga uprawnień
#1
0
Witam

Jak wyłaczyć ten komunikat aby nie pokazywał się po zalogowaniu

[Obrazek: IR3weZPl.jpg]

Dzięki
Odpowiedz
#2
0
Wywal go z autostartu.
Rozwiń też szczegóły.
Odpowiedz
#3
0
[Obrazek: cA4Ud30l.jpg]

A gdzie to?
Odpowiedz
#4
0
Rozwiń też szczegóły w okienku, które wyskakuje przy starcie.
Odpowiedz
#5
0
To ten drugi na liście
Ale wyłączenie to nie jest najlepszy sposób, co prawda działa, tylko tak naprawdę nie rozwiązuje problemu. Funkcja czemuś służy.
Odpowiedz
#6
0
Najwyraźniej jest to jakiś błąd polityki bezpieczeństwa blueman.
Spróbuj dodać się do grupy wheel
Literatura:
https://wiki.archlinux.org/title/Blueman#Permissions
Zerknij też do /etc/polkit-1/rules.d/ i /usr/share/polkit-1/rules.d czy są tam jakieś regułki dla blueman.
Ewentualnie pokaż zawartości:
Kod:
/usr/share/polkit-1/actions/org.blueman.policy
/usr/share/polkit-1/rules.d/blueman.rules
/var/lib/polkit-1/localauthority/10-vendor.d/org.blueman.pkla
Odpowiedz
#7
0
Daję zawartość

Kod:
/usr/share/polkit-1/actions/org.blueman.policy

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE policyconfig PUBLIC
"-//freedesktop//DTD PolicyKit Policy Configuration 1.0//EN"
"http://www.freedesktop.org/standards/PolicyKit/1/policyconfig.dtd">
<policyconfig>

  <action id="org.bleachbit">
    <message>Authentication is required to run Bleachbit</message>
    <icon_name>bleachbit</icon_name>
    <defaults>
      <allow_any>auth_admin</allow_any>
      <allow_inactive>auth_admin</allow_inactive>
      <allow_active>auth_admin</allow_active>
    </defaults>
    <annotate key="org.freedesktop.policykit.exec.path">/usr/bin/bleachbit</annotate>
    <annotate key="org.freedesktop.policykit.exec.allow_gui">true</annotate>
  </action>

</policyconfig>

/usr/share/polkit-1/rules.d/blueman.rules

// Allow users in sudo or netdev group to use blueman feature requiring root without authentication
polkit.addRule(function(action, subject) {
    if ((action.id == "org.blueman.network.setup" ||
        action.id == "org.blueman.dhcp.client" ||
        action.id == "org.blueman.rfkill.setstate" ||
        action.id == "org.blueman.pppd.pppconnect") &&
        subject.local && subject.active &&
        (subject.isInGroup("sudo") || subject.isInGroup("netdev"))) {
        return polkit.Result.YES;
    }
});


/var/lib/polkit-1/localauthority/10-vendor.d/org.blueman.pkla

[Changing system-wide settings through blueman]
Identity=unix-group:netdev;unix-group:sudo
Action=org.blueman.network.setup;org.blueman.dhcp.client;org.blueman.rfkill.setstate;org.blueman.pppd.pppconnect
ResultAny=no
ResultInactive=no
ResultActive=yes
Odpowiedz


Skocz do:




Użytkownicy przeglądający ten wątek: 1 gości