Autor Wątek: Wyłączenie automatycznego podświetlania klawiatury przy starcie systemu  (Przeczytany 252 razy)

Offline MaćQ

  • Miętowe nasionko
  • *
  • Wiadomości: 3
  • Punkty: 0
Witam i pozdrawiam użytkowników forum!

Ja z małym problemem, mianowicie posiadam laptop Asus S510U, na którym dopiero co zainstalowałem Linux Mint 19 ze środowiskiem Mate oraz aktualizacje.

Za każdym razem, podczas startu systemu automatycznie włącza mi się podświetlanie klawiatury, tak samo dzieje się, gdy podczas braku działań na laptopie przyciemni mi się ekran, a ja poruszę myszką, żeby z powrotem się wybudził. Teraz pytanie do Was, co mam zrobić, żeby wyłączyć samoistne uruchamianie się tego podświetlenia zarówno przy starcie systemu jak i po wybudzeniu laptopa z uśpienia.

Po wydaniu polecenia w terminalu: find /sys -name brightness wyświetla mi się taki oto zapis:

find: ?/sys/kernel/debug?: Brak dostępu
/sys/devices/platform/i8042/serio0/input/input4/input4::capslock/brightness
/sys/devices/platform/i8042/serio0/input/input4/input4::scrolllock/brightness
/sys/devices/platform/i8042/serio0/input/input4/input4::numlock/brightness
/sys/devices/platform/asus-nb-wmi/leds/asus::lightbar/brightness
/sys/devices/platform/asus-nb-wmi/leds/asus::kbd_backlight/brightness
/sys/devices/pci0000:00/0000:00:1c.5/0000:02:00.0/leds/phy0-led/brightness
/sys/devices/pci0000:00/0000:00:02.0/drm/card0/card0-eDP-1/intel_backlight/brightness
/sys/devices/LNXSYSTM:00/LNXSYBUS:00/ATK4002:00/leds/asus-wireless::airplane/brightness
find: ?/sys/fs/pstore?: Brak dostępu
find: ?/sys/fs/fuse/connections/8388609?: Brak dostępu

Z moją mizerną wiedzą zastosowałem komendę echo 0 > /sys/devices/platform/asus-nb-wmi/leds/asus::kbd_backlight/brightness jednak pomaga ona tylko jednorazowo no i dalej nie wiem już co mam robić.

Będę wdzięczny za pomoc!

Offline dedito

  • Urząd Porządkowy
  • Miętowy krzew
  • *******
  • Wiadomości: 435
  • Punkty: 181
Odp: Wyłączenie automatycznego podświetlania klawiatury przy starcie systemu
« Odpowiedź #1 dnia: Grudzień 17, 2018, 10:14:56 am »
Możesz to dopisać do skryptu startowego /etc/rc.local
Być może trzeba będzie go uaktywnić w systemd.
Plik musi mieć atrybut wykonywalności.
Wszystkie operacje robisz jako root.

Offline MaćQ

  • Miętowe nasionko
  • *
  • Wiadomości: 3
  • Punkty: 0
Odp: Wyłączenie automatycznego podświetlania klawiatury przy starcie systemu
« Odpowiedź #2 dnia: Grudzień 17, 2018, 11:28:48 am »
Dziękuję Ci za szybką odpowiedź :)

Niestety w katalogu /etc nie mam pliku rc.local. Powinienem go utworzyć z wpisem echo 0 oraz atrybutem wykonywalności poprzez chmod?

Czy istnieje ewentualność, że znajduje się on gdzieś indziej? W katalogu /lib/systemd/system znalazłem plik rc-local.service z zawartością:

#  SPDX-License-Identifier: LGPL-2.1+
#
#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.

# This unit gets pulled automatically into multi-user.target by
# systemd-rc-local-generator if /etc/rc.local is executable.
[Unit]
Description=/etc/rc.local Compatibility
Documentation=man:systemd-rc-local-generator(8)
ConditionFileIsExecutable=/etc/rc.local
After=network.target

[Service]
Type=forking
ExecStart=/etc/rc.local start
TimeoutSec=0
RemainAfterExit=yes
GuessMainPID=no

Może to o niego chodzi?

Offline yahoob3

  • Grupa Trzymająca Władzę
  • Wielki miętus
  • *****
  • Wiadomości: 912
  • Punkty: 191
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Wyłączenie automatycznego podświetlania klawiatury przy starcie systemu
« Odpowiedź #3 dnia: Grudzień 17, 2018, 12:24:28 pm »
Na próbę otwórz: preferencje, programy startowe, dodaj nowy - polecenie użytkownika i wklej to:
echo 0 > /sys/devices/platform/asus-nb-wmi/leds/asus::kbd_backlight/brightnessw pole "polecenie", nadaj jakąś nazwę, zapisz i zrestartuj komputer.
Co do rc.local to trochę dziwne, że go nie masz, bo rc...service odnosi się właśnie do niego, np. bo jest kilka odniesień:
ExecStart=/etc/rc.local start
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

Offline dedito

  • Urząd Porządkowy
  • Miętowy krzew
  • *******
  • Wiadomości: 435
  • Punkty: 181
Odp: Wyłączenie automatycznego podświetlania klawiatury przy starcie systemu
« Odpowiedź #4 dnia: Grudzień 17, 2018, 12:57:47 pm »
Może tak być, że brak tego pliku, trzeba go utworzyć ręcznie bo dla systemd to przeżytek lub skorzystać z metod przewidzianych dla systemd do globalnego autouruchamiania programów.
Można też skorzystać z crona.

W samym wyniku jest informacja:
Cytuj
# This unit gets pulled automatically into multi-user.target by
# systemd-rc-local-generator if /etc/rc.local is executable.

Offline kris777

  • Miętowy krzew
  • ****
  • Wiadomości: 367
  • Punkty: 55
Odp: Wyłączenie automatycznego podświetlania klawiatury przy starcie systemu
« Odpowiedź #5 dnia: Grudzień 17, 2018, 16:59:41 pm »
pliku /etc/rc.local nie ma na LinuxMint 19 tara / Mate  sprawdziłem ! :-)
co dziwne nie ma go też na Debian-ie 9 stretch  / Xubuntu ....może to jakiś regres ?. Na platformie ARM / orangePi z przystosowaną wersją Ubuntu często korzysta się właśnie z pliku rc.local .... a tu NIET  :P
może dodać:
https://www.itechlounge.net/2017/10/linux-how-to-add-rc-local-in-debian-9/
https://www.linuxbabe.com/linux-server/how-to-enable-etcrc-local-with-systemd
« Ostatnia zmiana: Grudzień 17, 2018, 17:14:08 pm wysłana przez kris777 »

Offline dedito

  • Urząd Porządkowy
  • Miętowy krzew
  • *******
  • Wiadomości: 435
  • Punkty: 181
Odp: Wyłączenie automatycznego podświetlania klawiatury przy starcie systemu
« Odpowiedź #6 dnia: Grudzień 17, 2018, 17:14:41 pm »
To progres, mamy teraz systemd (niektórzy nie uważają systemd za progres, ale to temat na inny wątek) i to jest po prostu plik, który był wykorzystywany w starszym rozwiązaniu, ale wciąż można z niego korzystać jeśli tego chcemy.
Można bawić się w ten rc.local lub po prostu dopisać zadanie do crona lub jak chcemy iść z duchem czasu to zrobić usługę systemd, sposobów na to znalazłoby się pewnie jeszcze kilka.
« Ostatnia zmiana: Grudzień 17, 2018, 17:20:13 pm wysłana przez dedito »

Offline kris777

  • Miętowy krzew
  • ****
  • Wiadomości: 367
  • Punkty: 55
Odp: Wyłączenie automatycznego podświetlania klawiatury przy starcie systemu
« Odpowiedź #7 dnia: Grudzień 17, 2018, 17:22:41 pm »
Dzięki za info ! .... więc to przestarzała metoda i tyle

Offline yahoob3

  • Grupa Trzymająca Władzę
  • Wielki miętus
  • *****
  • Wiadomości: 912
  • Punkty: 191
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Wyłączenie automatycznego podświetlania klawiatury przy starcie systemu
« Odpowiedź #8 dnia: Grudzień 17, 2018, 19:05:00 pm »
Proszę mi tu krzyży na starych sprawdzonych metodach nie stawiać ;D
Często ratują 4 litery :)
Niech się MaćQ się wypowie, co zdziałał.

PS... coście się tej 19stki czepili? ;-P
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

Offline MaćQ

  • Miętowe nasionko
  • *
  • Wiadomości: 3
  • Punkty: 0
Odp: Wyłączenie automatycznego podświetlania klawiatury przy starcie systemu
« Odpowiedź #9 dnia: Grudzień 18, 2018, 06:12:22 am »
Dzięki wszystkim za zainteresowanie  ;D

To może najpierw od końca, wypróbowałem pomysł yahoob3 z wpisem w preferencjach , ale niestety nie przyniósł on żadnych efektów.

Postanowiłem stworzyć usługę w systemd według poradnika znalezionego na tej stronie:
https://better-coding.com/autostart-uruchamianie-wlasnej-uslugi-podczas-startu-systemu-linux-przy-uzyciu-systemd/

Ale jako że jestem użytkownikiem linuxa od 1,5 dnia i dopiero przyswajam rzeczy o których piszecie, to zapewne coś sknociłem. Jakbyście mogli zweryfikować ten twór.
Stworzyłem plik /etc/systemd/system/keyboard-brightness.service z zawartością:

[Unit]
Description=My keyboard-brightness
Requires=keyboard-brightness.service
After=keyboard-brightness.service

[Service]
Restart=always
ExecStart=/etc/rc.local start -a keyboard-brightness
ExecStop=/etc/rc.local stop -t 10 keyboard-brightness

[Install]
WantedBy=default.target

Plik rc.local, do którego odnoszę się we wpisie stworzyłem sam z zawartością:
echo 0 > /sys/devices/platform/asus-nb-wmi/leds/asus::kbd_backlight/brightness

Offline dedito

  • Urząd Porządkowy
  • Miętowy krzew
  • *******
  • Wiadomości: 435
  • Punkty: 181
Odp: Wyłączenie automatycznego podświetlania klawiatury przy starcie systemu
« Odpowiedź #10 dnia: Grudzień 18, 2018, 10:28:46 am »
W przypadku rc.local powinno wystarczyć stworzenie tego pliku z atrybutem wykonywalności, sama usługa systemd powinna już być i nie ma potrzeby tworzenia nowej.
Powtórzę się:
Cytuj
# This unit gets pulled automatically into multi-user.target by
# systemd-rc-local-generator if /etc/rc.local is executable.
Żeby nie przeciągąć, sprawdź czy usługa jest aktywna:
sudo systemctl status rc-locali ewentualnie ją włącz:
sudo systemctl enable rc-localPotem stwórz plik /etc/rc.local z atrybutem wykonywalności:
sudo touch /etc/rc.local
sudo chmod +x /etc/rc.local
i do pliku /etc/rc.local wrzuć poniższe:
#!/bin/sh -e
echo 0 > /sys/devices/platform/asus-nb-wmi/leds/asus::kbd_backlight/brightness
exit 0

Inna metoda o której pisałem to uruchamianie z cron'a:
sudo crontab -ei dopisujemy linijkę:
@reboot echo 0 > /sys/devices/platform/asus-nb-wmi/leds/asus::kbd_backlight/brightness
« Ostatnia zmiana: Grudzień 18, 2018, 10:44:47 am wysłana przez dedito »