Forum Linux Mint Polska

Autor Wątek: Kłopot z uruchomieniem skanera Canon LiDe 220  (Przeczytany 978 razy)

Offline ciastek1981

  • Linux User #621498
  • Wielki miętus
  • *******
  • Wiadomości: 819
  • Punkty: 114
  • Płeć: Mężczyzna
  • Deepin && Voyager 9 (Debian)
  • Środowisko graficzne: Inne
  • Wersja systemu: Inny
Odp: Kłopot z uruchomieniem skanera Canon LiDe 220
« Odpowiedź #45 dnia: Luty 11, 2018, 12:18:43 pm »
kris777 Czerwony i zielony kolor jest dla moderacji i administracji, zmień to szybko  8)

Tak mi się napisało, nie szukaj drugiego dna. Zobaczymy jak będzie.

Do LMDE 2 potrzeba doinstalować sane-backends w wersji 1.0.25, a podstawa - Jessie ma 1.0.24 https://packages.debian.org/source/jessie/sane-backends.

Offline kris777

  • Dorodna miętowa sadzonka
  • ***
  • Wiadomości: 116
  • Punkty: 10
  • Środowisko graficzne: Mate
  • Wersja systemu: 18
Odp: Kłopot z uruchomieniem skanera Canon LiDe 220
« Odpowiedź #46 dnia: Luty 11, 2018, 12:34:34 pm »
Szybko to można uciekać przed nadjeżdżającym samochodem :-) ...a tak na serio to nie szukaj dziury w całym ( lub jak wspomniałeś drugiego dna ) .... na pierwszej stronie tego wątku jakoś nie zauważyłeś koloru zielonego uwidaczniającego usera: @Ulvhedin :-)  .....szukajmy rozwiązania a nie czepiajmy się bzdur ....

Offline ciastek1981

  • Linux User #621498
  • Wielki miętus
  • *******
  • Wiadomości: 819
  • Punkty: 114
  • Płeć: Mężczyzna
  • Deepin && Voyager 9 (Debian)
  • Środowisko graficzne: Inne
  • Wersja systemu: Inny
Odp: Kłopot z uruchomieniem skanera Canon LiDe 220
« Odpowiedź #47 dnia: Luty 11, 2018, 12:36:41 pm »
Jeżeli odwołujesz się do administracji i moderacji forum i wpiszesz nick takiego użytkownika to kolor zmienia się automatycznie.

Offline kris777

  • Dorodna miętowa sadzonka
  • ***
  • Wiadomości: 116
  • Punkty: 10
  • Środowisko graficzne: Mate
  • Wersja systemu: 18
Odp: Kłopot z uruchomieniem skanera Canon LiDe 220
« Odpowiedź #48 dnia: Luty 11, 2018, 12:39:21 pm »
Cytuj
Jeżeli odwołujesz się do administracji i moderacji forum i wpiszesz nick to kolor takiego użytkownika to kolor zmienia się automatycznie.
Do niczego się nie odwołuje ....w przeciwieństwie do Ciebie ... proszę tylko o trochę zdrowego rozsądku
Dzięki za wyjaśnienie !


Ps.  Troszkę kombinowałem i powiem wam że u mnie na virtualbox / LMDE 2 xsane ze skanerem Canon LIDE 220 działa OK ....tylko teraz jak do tego doszedłem to będzie zagwozdka :-)
Wykonywałem sporo chaotycznych "ruchów" instalacji , reinstalacji  kompilacji sane-backend itd :-)
Obecnie wiem tyle iż w systemie nie mam programu  simple-scan tylko xsane :-) ...Choć jednym z ruchów było właśnie wywalenie simple-scan restart systemu i próba uruchomienia xsane. Oczywiście nieudana ... potem zainstalowałem ponownie simple-scan i dokonałem kompilacji ( opcje standardowe : ./configure / make / make install ) dwóch paczek pierwszą była:sane-backends-1.0.27 i potem : sane-backends-1.0.25.......Uruchomienie xsane / simple-scan ( oczywiście lipa )  potem z menedżera synaptic usunąłem : sane / libsane .... potem z linii komend terminala zainstalowałem ponownie program : xsane
Po tym wszystkim xsane uruchamia się poprawnie ze skanerem Canon LiDE 220 ...a co dziwne simple-scan nie działa i pisze że w systemie go nie ma :-) .... Jedynym edytowanym plikiem w którym dokonałem znaczących zmian był wspomniany na forum : /etc/sane.d/genesys.conf
# Canon LiDE 220
usb 0x04a9 0x190f
edytowałem też plik : /etc/sane.d/dll.conf ...ale w nim posostawiłem tylko znak # przy nazwie :test
https://www.dropbox.com/s/w5nr7vcg72za7ia/Zaznaczenie_032.jpg?dl=0
Pierwszy kompilowana paczka była z tąd: http://www.linuxfromscratch.org/blfs/view/svn/pst/sane.html
druga sane-backends : sane-backends_1.0.25.orig.tar.gz : https://packages.debian.org/source/stretch/sane-backends
Jeśli ktoś potrzebuje jakiś info lub plików z systemu ...pisać ( nie jestem zbyt zaawansowanym userem w linux-ie więc sory za ewentualne problemy)

Zainstalowałem dla sprawdzenia ponownie simple-scan ... program rozpoznał skaner i ...... przy próbie skanowania zawiesił system :-( . Po reboot-cie zeskanował poprawnie ale jakby miał tendencję do zawieszania się w połowie lub części skanu ...potem trudno ruszyć Canona bo listwa skanowania zawiesz się w połowie i na Lubuntu nie mogłem zeskanować niczego ! więc uwaga .... na szczęście w LMDE 2 simple-scan ruszył skaner i wszystko jest OK. Jednak wywaliłem z systemu simple-scan i pracuję na xsane ktory również w porównaniu do Lubuntu troszkę dłużej się rozpędza i ma na początku jakby tzw. czkawkę :-)  z 3 X  i na końcu 2x...na Lubuntu jest to płynniej 2X na początku i potem OK. Wynika iż lepiej zrezygnować z simple-scan-a na LMDE2 ... xsane działa wolniej ale pewniej.
« Ostatnia zmiana: Luty 12, 2018, 15:54:41 pm wysłana przez kris777 »

Offline ciastek1981

  • Linux User #621498
  • Wielki miętus
  • *******
  • Wiadomości: 819
  • Punkty: 114
  • Płeć: Mężczyzna
  • Deepin && Voyager 9 (Debian)
  • Środowisko graficzne: Inne
  • Wersja systemu: Inny
Odp: Kłopot z uruchomieniem skanera Canon LiDe 220
« Odpowiedź #49 dnia: Luty 11, 2018, 21:18:10 pm »
No i dobrze, moim zdaniem poszło o to sane-backends_1.0.25.orig.tar.gz , czegoś w tych pozostałych może brakować. Debianowcom postaw tylko [ + ] chociaż, jak czytają ten temat to mają niezłą polewę  8)

Offline kris777

  • Dorodna miętowa sadzonka
  • ***
  • Wiadomości: 116
  • Punkty: 10
  • Środowisko graficzne: Mate
  • Wersja systemu: 18
Odp: Kłopot z uruchomieniem skanera Canon LiDe 220
« Odpowiedź #50 dnia: Luty 11, 2018, 21:44:31 pm »
Też tak mi się wydaje iż kompilacja paczki sane-backends_1.0.25.orig.tar.gz + odinstalowanie i ponowne zainstalowanie niektórych programów załatwiło sprawę ...może naprawiło jakieś dowiązania do programów itp.... jednak wszystko to chyba wymaga potwierdzenia innego użytkownika i można temat zamknąć napisem solved
pozdro!

Offline ciastek1981

  • Linux User #621498
  • Wielki miętus
  • *******
  • Wiadomości: 819
  • Punkty: 114
  • Płeć: Mężczyzna
  • Deepin && Voyager 9 (Debian)
  • Środowisko graficzne: Inne
  • Wersja systemu: Inny
Odp: Kłopot z uruchomieniem skanera Canon LiDe 220
« Odpowiedź #51 dnia: Luty 11, 2018, 22:02:36 pm »
oktet, sprawdzaj czy działa i kończmy tą komedię  :)

Dla potomnych pod LMDE 2 zróbcie alienem .deb'a bo jak przeczytają kompilacja to słabo się co poniektórym zrobi.

Offline kris777

  • Dorodna miętowa sadzonka
  • ***
  • Wiadomości: 116
  • Punkty: 10
  • Środowisko graficzne: Mate
  • Wersja systemu: 18
Odp: Kłopot z uruchomieniem skanera Canon LiDe 220
« Odpowiedź #52 dnia: Luty 12, 2018, 15:48:02 pm »
To fakt niekiedy kompilacja przysparza wiele problemów ...czasem nie do przejścia jeśli nie jest się programistą. Jednak kompilacja tej paczki przebiega bezproblemowo.
Ściągamy paczkę : http://http.debian.net/debian/pool/main/s/sane-backends/sane-backends_1.0.25.orig.tar.gz
Rozpakowujemy przechodzimy ( w terminalu )  do rozpakowanego folderu : sane-backends_1.0.25
i wykonujemy po kolei polecenia:
./configure
make
make install
chyba nawet początkujący powinien sobie poradzić :-)
Ale jak wspomniałem po kompilacji trzeba usunąć pewne programy i zainstalować ponownie kolejność nie do końca zapisana prze zemnie więc wymaga to potwierdzenia ( czytaj wyżej )
« Ostatnia zmiana: Luty 12, 2018, 15:53:45 pm wysłana przez kris777 »

Offline oktet

  • Miętowa sadzonka
  • **
  • Wiadomości: 58
  • Punkty: 14
  • Płeć: Mężczyzna
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: LMDE 2
Odp: Kłopot z uruchomieniem skanera Canon LiDe 220
« Odpowiedź #53 dnia: Luty 13, 2018, 16:29:03 pm »
Witam wszystkich serdecznie.

@kris777  ja temat z "sane-beckends" już przerabiałem, bo gdzieś w Necie już się na to natknąłem. Nic to jednak nie pomogło - widać nie tędy droga.

Piszecie "można temat zamknąć napisem solved"; piszecie też "oktet, sprawdzaj czy działa i kończmy tą komedię" - oczywiście z uśmiechem.
Tyle że te nasze zmagania nijak mają się do komedii, a według mnie to prędzej kompromitacja, blamaż; zaś pod hasłem solved zamyka się tematy/problemy rozwiązane, a ten w żaden sposób za taki uznać chyba nie można.
Oczywiście temat można zamknąć, bo problem wydaje sie być trudny (myślę że może wymagać nieco więcej pracy kogoś o dużej wiedzy) i nawet nie liczę na rychłe rozwiązanie.
Kombinowanie o którym wspomina kris777, to taka ćwierć-metoda która czasami może dać pozytywny skutek (czasem tylko częściowy), ale nie jest to przecież wiarygodna recepta na rozwiązanie problemu, którą możemy wszystkim polecić.
« Ostatnia zmiana: Luty 13, 2018, 16:38:22 pm wysłana przez oktet »
Jako że "Linuksy" są niestabilne, zawodne i źle zabezpieczone, to serwery Microsoft chodzą na Debianie...  ;D

Offline kris777

  • Dorodna miętowa sadzonka
  • ***
  • Wiadomości: 116
  • Punkty: 10
  • Środowisko graficzne: Mate
  • Wersja systemu: 18
Odp: Kłopot z uruchomieniem skanera Canon LiDe 220
« Odpowiedź #54 dnia: Luty 13, 2018, 17:39:06 pm »
Nie obrażaj się :-) .... nikt nie chce zamknąć tematu bez ostatecznego sprawdzenia / potwierdzenia o którym wspominaliśmy .... np. przez Ciebie. OK ...wynika z tego iż wszelkie próby z twojej strony nie przyniosły rozwiązania ...a moje dość mgliste objaśnienia są tylko naprowadzeniem a nie profesjonalnym rozwiązaniem. Jak znajdę trochę czasu to spróbuje od nowa zweryfikować te moje dość nieprecyzyjne podpowiedzi :-) ...Ale wiadomo trzeba postawić LMDE2 ( na nowo ) na czysto i precyzyjnie zapisać poszczególne "ruchy" w systemie aż do osiągnięcia celu czyli poprawnego uruchomienia się programu skanującego ze skanerem Canon Lide 220 .... ale jak widzisz jest to możliwe więc to już połowa sukcesu :-)
pozdro!

Offline oktet

  • Miętowa sadzonka
  • **
  • Wiadomości: 58
  • Punkty: 14
  • Płeć: Mężczyzna
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: LMDE 2
Odp: Kłopot z uruchomieniem skanera Canon LiDe 220
« Odpowiedź #55 dnia: Luty 13, 2018, 23:05:02 pm »
Nie obrażaj się :-) .... nikt nie chce zamknąć tematu bez ostatecznego sprawdzenia...

Spoko kris777, ja się tak szybko nie obrażam, nie ma takiej opcji. Zwyczajnie, na luzie wyraziłem swoje zdanie.
Przecież ciastek1981 na końcu wypowiedzi umieścił nawet swoją uśmiechniętą facjatę. - To jak tu się można obrazić??   ;D
Nota bene, ciastek1981 wcześniej napisał
Cytuj
Debianowcom postaw tylko [ + ] chociaż, jak czytają ten temat to mają niezłą polewę

Oczywiście że polewę to może sobie robić każdy, nawet największy matoł. Tylko gdy takiego zapytasz o rozwiązanie, to natychmiast mina mu rzednie i ma za mało czasu.
Takich mądrali to my dobrze znamy, jest ich na pęczki.
Jest taka reguła ciastek1981, że ci co naprawdę dużo wiedzą - nigdy nie robią sobie polewy.
Jako że "Linuksy" są niestabilne, zawodne i źle zabezpieczone, to serwery Microsoft chodzą na Debianie...  ;D

Offline ciastek1981

  • Linux User #621498
  • Wielki miętus
  • *******
  • Wiadomości: 819
  • Punkty: 114
  • Płeć: Mężczyzna
  • Deepin && Voyager 9 (Debian)
  • Środowisko graficzne: Inne
  • Wersja systemu: Inny
Odp: Kłopot z uruchomieniem skanera Canon LiDe 220
« Odpowiedź #56 dnia: Luty 13, 2018, 23:23:49 pm »
Z chęcią bym wam to prosto rozpisał, co i jak, ale nie mam tego skanera i nie jestem w stanie niczego sprawdzić w rzeczywistości.

Mnie (pomoc tutaj) nic nie kosztuje, a przy okazji to jakiś kolejny problem, który nauczę się rozwiązywać, chociaż pewnie do jutra zapomnę, ale linki w ściądze zostaną.

Ten wątek to taka szkoła rodzenia, czegoś nie wiedziałem, sprawdziłem/doczytałem i napisałem, a potem znowu. Takie rzeczy powinno się jak najkrócej rozwiązywać, ale teorię trzeba weryfikować w praktyce.

Offline kris777

  • Dorodna miętowa sadzonka
  • ***
  • Wiadomości: 116
  • Punkty: 10
  • Środowisko graficzne: Mate
  • Wersja systemu: 18
Odp: Kłopot z uruchomieniem skanera Canon LiDe 220
« Odpowiedź #57 dnia: Luty 14, 2018, 22:40:09 pm »
OK udało mi się po raz drugi zainstalować skaner Canon LiDE 220 na virtualbox-ie / LMDE 2... nie wiem czy pomogę na 100% bo z tym systemem jest coś nie tak. Moje postępowanie :
 instalacja systemu LMDE2 Mate 64bit
update / upgrade do : Linux 3.16.0-5-amd64 #1 SMP Debian 3.16.51-3+deb8u1 (2018-01-08) x86_64 GNU/Linux
instalacja paczek:
apt-get install gocr libusb-dev libsane-dev libsane-extras xsane-common xsanemodyfikacja plików:
nano /etc/sane.d/genesys.confdodanie wpisów:
# Canon LiDE 220
usb 0x04a9 0x190f
ctrl x ... t ..... enter
nano /lib/udev/rules.d/60-libsane.rulesdodanie wpisu:
# Canon CanoScan LiDE 220
ATTRS{idVendor}=="04a9", ATTRS{idProduct}=="190f", ENV{libsane_matched}="yes"
reboot systemu
ściągnięcie i kompilacja paczki sane-backends:
wget http://http.debian.net/debian/pool/main/s/sane-backends/sane-backends_1.0.25.orig.tar.gz
tar -xvzf sane-backends_1.0.25.orig.tar.gz
chmod +x sane-backends-1.0.25
cd sane-backends-1.0.25
./configure
make
make install
następnie:
apt-get purge libsane
apt-get autoremove libsane
apt-get install xsane
Po tym skaner Cannon-a uruchomił się poprawnie z programem xsane.
Można także dodać wpis w terminalu:
sudo usermod -a -G scanner nazwa użytkownika
i sprawdzić w terminalu czy  program xsane nie uruchamia się tylko jako root ( sudo su ).... jeśli tak to nadać odpowiednie uprawnienia:
chmod a+w /dev/bus/usb/001/003w moim przypadku jeśli skaner jest wykrywany jako:
lsusb:
Bus 001 Device 003: ID 04a9:190f Canon, Inc.


« Ostatnia zmiana: Luty 21, 2018, 17:50:03 pm wysłana przez kris777 »

Offline oktet

  • Miętowa sadzonka
  • **
  • Wiadomości: 58
  • Punkty: 14
  • Płeć: Mężczyzna
  • Środowisko graficzne: Cinnamon
  • Wersja systemu: LMDE 2
Odp: Kłopot z uruchomieniem skanera Canon LiDe 220
« Odpowiedź #58 dnia: Luty 15, 2018, 00:45:21 am »
Dzięki kris777
Na pewno to sprawdzę na świerzym systemie, bo tylko tak będzie to wiarygodne. Niestety nie dzisiaj i nie jutro.
Ale się zawziąłeś. Szacun.  :)
Jako że "Linuksy" są niestabilne, zawodne i źle zabezpieczone, to serwery Microsoft chodzą na Debianie...  ;D

Offline kris777

  • Dorodna miętowa sadzonka
  • ***
  • Wiadomości: 116
  • Punkty: 10
  • Środowisko graficzne: Mate
  • Wersja systemu: 18
Odp: Kłopot z uruchomieniem skanera Canon LiDe 220
« Odpowiedź #59 dnia: Luty 15, 2018, 19:20:37 pm »
Chyba nie powinno to mieć znaczenia żeby instalować system od nowa ( a nawet nie powinno mieć !)....ale gdzie jest zagwozdka ? że czasem skaner Canona LiDE 220 nie chce "zaskoczyć" w systemie LMDE2 ? na zdrowy rozum  powinno się wykonać choćby wpisy od pozycji: ściągnięcie i kompilacja paczki sane-backends: i skaner powinien zaskoczyć ...choćby działał tylko z pozycji root-a... a właśnie tak miałem na dość "zaśmieconym"  systemie licznymi próbami instalacji paczek i kompilacji.... i miałem się już poddać gdy zrozumiałem że xsane / skaner Canon działa ale tylko z pozycji root-a. Znalazłem rozwiązanie podane wyżej i było OK. Potem zainstalowałem system na nowo ... i opisałem wypociny :-) wyżej.... skaner też pracuje ale pozostaje jakieś niedopowiedzenie czy to na pewno jest poprawny fix na zainstalowanie Canona LiDe 220 w systemie LMDE 2
Ps. Czasami do odinstalowania libsane i innych powiązanych paczek używałem Menedżera Pakietów Synaptic i z opcji odinstaluj wybieralem kwadracik na czerwono ( zupełne odinstalowanie pakietu i powiązanych wpisów ) to chyba coś w rodzaju opcji : apt-get purge (jakiś pakiet)
Może ktoś jeszcze bardziej doświadczony coś podpowie bo to trochę dziwne i denerwujące ża są takie problemy z głupim skanerem na LMDE2 :-)
pozdro!
« Ostatnia zmiana: Luty 15, 2018, 20:31:50 pm wysłana przez kris777 »