Autor Wątek: Brak dżwieku w Kodi 17  (Przeczytany 1010 razy)

Offline Wiskoler

  • Miętowe nasionko
  • *
  • Wiadomości: 2
  • Punkty: 0
  • Płeć: Mężczyzna
Brak dżwieku w Kodi 17
« dnia: Lipiec 03, 2017, 20:50:18 pm »
Witam po raz pierwszy.
Posiadam Minta 18.1 a na nim zainstalowałem i skonfigurowałem wstępnie Kodi.
Wtyczki działają, brakuje mi tylko odtwarzania dźwięki zarówno w odtwarzaczu plików MP3 jak i wtyczce do filmów.
Dźwięk w systemie działa, z innych odtwarzaczy można bez problemów korzystać.
W kodi-system-ustawienia-odtwarzanie dźwięku: mam do wyboru = Default, Default Output Device (PULSE AUDIO) lub CA0106 Soundblaster (SB0570[SB Audigy SE).
Na żadnym z nich dźwięk nie działa.
Jak w trakcie działania Kodi otworzę kontrolę głośności to na zakładce Odtwarzanie mam Dźwięki systemowe oraz Kodi. Z tym że Kodi ma suwak całkowicie na lewo przesunięty na Wycisz. Nie skutkuje przesunięcie go w prawo - dzwięku nadal nie ma. Zatrzymanie i powtórne uruchomienie Kodi powoduje iż pasek wraca do poprzednich ustawień.
Nie znalazłem niczego więcej do regulacji dźwięku w Kodi ani w systemie.
Ktos mam jakiś pomysł gdzie grzebnąć by to poprawić?

Offline Wiskoler

  • Miętowe nasionko
  • *
  • Wiadomości: 2
  • Punkty: 0
  • Płeć: Mężczyzna
Odp: Brak dżwieku w Kodi 17
« Odpowiedź #1 dnia: Lipiec 04, 2017, 18:00:37 pm »
Witam ponownie.
Jestem na tropie...
Otóż po próbie uruchomienia Kodi z terminala otrzymałem odpowiedź iż
"Fatal Phyton error: ceval: orphan tstate
 Abort (core dumped)
find: '/home/user/.cache/dconf': Brak dostępu
find: '/home/user/.dbus': Brak dostępu
crash report at /home/user//kodi_crashlog_mnóstwo_cyferek.log
Czyli problemem jest dostęp Kodi do jego plików konfiguracyjnych.
No i teraz jak mogę nadać prawa do zaglądania do katalogów .cache i .dbus oraz odczytu plików konfiguracyjnych dla Kodi?
Albo jak przenieść w/w pliki i poinformować Kodi że one leżą sobie gdzieś indziej?
Kodi uruchomione z uprawnieniami su powiodło sie i był dźwięk...
EDIT:
Był dźwięk, to dobrze napisane. Był i się zmył. Teraz nie ma, i komunikatu żadnego też nie ma.
Za to po uruchomieniu Kodi z terminala, jako użyszkodnik, uruchamia się bez dźwięku a po zamknięciu w terminalu mam komunikat
"Exeption SystemExit in <function_remove at 0x7fe270cce050> ignored - i nic więcej.
Teraz już nie mam koncepcji co z tym wykombinować
/EDIT
EDIT 2
Na dodatkowym dysku zainstalowałem sobie Debiana najbiedniejszą wersję i tam Kodi chodzi z dźwiękiem. Zastanowiło mnie że po zainstalowaniu w Mincie nazwa Kodi dotyczyła właśnie Debiana, tak jakby twórca pod właśnie Debiana robił. No i działa.
/EDIT
« Ostatnia zmiana: Lipiec 09, 2017, 14:57:31 pm wysłana przez Wiskoler »