jak zainstalowac/zupgradowac libfontconfig do najnowszej???

  • 0 replies
  • 211 views
*

Offline tlb

  • *
  • 1
  • 0
jak zainstalowac/zupgradowac libfontconfig do najnowszej???
« dnia: Marzec 23, 2018, 19:10:25 pm »
WItam mam problem z instalacją programu GrafX2 2.4.
Moj system posiada biblioteki libfontconfig1 i fontconfig-config w wersji 2.11.94ubuntu1.1
W synaptic widnieje ze najnowsza jest wlasnie taka jak mam zainstalowana.
A Program juz wymaga >= 2.12 bo zaleznosc niemoze byc spelniona z libfontconfig1.

Sciagnalem najnowszą wersje z netu fontconfig 2.12.6ubuntu1_all.deb
Ale gdy to odpalam to wyskakuje komunikat
"Psuje istniejacy pakiet "libfontconfig1" żależnosc fontconfig-config (=2.11.94-0ubuntu1.1)"

Jak to mam upgradowac do tej wersji którą sciągnałem z sieci???
Bo klikaniem w ikone sie nieda bo wyskakuje komunikat.

A gdy chce odinstalowac z synaptic starą wersje, i zainstalować nową. To skolei pisze ze jakies dodatkowe programy mam do usuniecia.
Więc chyba te wszystkie programy odinstaluje?

To jak zrobic z tego upgrade jak mam plik .deb na dysku???


EDIT1:

Dobra juz poradziłem sobie z tym.
Wpisując do Zasoby Oprogramowania dodatkowy repozytorium: "deb http://archive.ubuntu.com/ubuntu/ bionic main restricted universe multiverse"
gdzie ta wersja już istniała, i łatwo zupgradowało poprzez synaptic.
« Ostatnia zmiana: Marzec 23, 2018, 21:50:30 pm wysłana przez tlb »