Czas włączania laptopa

  • 16 replies
  • 498 views
Czas włączania laptopa
« dnia: Lipiec 19, 2018, 17:57:42 pm »
Witam wszystkich serdecznie.Jestem tu nowy,Linuxa mam od dwóch tygodni,więc proszę o wyrozumiałość,jestem zupełnie zielony.Mój problem,a raczej ciekawość dlaczego tak się dzieje,polega na ,moim zdaniem,długim czasie włączania laptopa.Od włączenia do załadowania systemu mija 1.5 min.Czy taki czas jest normalny,a jeśli nie co może być przyczyną?
Mój laptop to Asus M50
Linux Mint  19 Cinnamon 3.8.8
Intel Core2 Duo T5800 2,00GHz x 2
4 giga ramu
Dysk 500GB

Może dorzucę takie informacje:   

System:    Host: piotr-Laptopik Kernel: 4.15.0-24-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.8 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: ASUSTeK product: M50Vc v: 1.0 serial: N/A
           Mobo: ASUSTeK model: M50Vc v: 1.0 serial: N/A
           BIOS: American Megatrends v: 212 date: 10/14/2009
Battery    BAT0: charge: 2.4 Wh 100.5% condition: 2.4/51.3 Wh (5%)
           model: ASUSTEK M50--24 status: Full
CPU:       Dual core Intel Core2 Duo T5800 (-MCP-)
           arch: Conroe rev.13 cache: 2048 KB
           flags: (lm nx sse sse2 sse3 ssse3) bmips: 7981
           clock speeds: max: 2000 MHz 1: 1644 MHz 2: 1508 MHz
Graphics:  Card: NVIDIA G98M [GeForce 9300M GS] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: nvidia (unloaded: modesetting,fbdev,vesa,nouveau)
           Resolution: 1280x800@60.02hz
           OpenGL: renderer: GeForce 9300M GS/PCIe/SSE2
           version: 3.3.0 NVIDIA 340.106 Direct Render: Yes
Audio:     Card Intel 82801I (ICH9 Family) HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-24-generic
Network:   Card-1: Intel WiFi Link 5100 driver: iwlwifi bus-ID: 03:00.0
           IF: wlp3s0 state: down mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e800 bus-ID: 08:00.0
           IF: enp8s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 500.1GB (17.0% used)
           ID-1: /dev/sda model: TOSHIBA_MQ01ABF0 size: 500.1GB
Partition: ID-1: / size: 458G used: 80G (19%) fs: ext4 dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 54.0C mobo: N/A gpu: 0.0:52C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 180 Uptime: 37 min Memory: 1073.4/3944.9MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56

Dziękuję z góry za podpowiedzi.Pozdrawiam
« Ostatnia zmiana: Lipiec 20, 2018, 22:17:47 pm wysłana przez szymon1978 »

*

Offline yahoob3

  • *****
  • 683
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Czas włączania laptopa
« Odpowiedź #1 dnia: Lipiec 19, 2018, 22:11:49 pm »
Dziewiętnastka cierpi jeszcze na dolegliwości wieku niemowlęcego ;)
Lepiej wgraj 18.3.
Albo... w czasie uruchamiania systemu kiedy pojawi się logo z kropkami wciśnij F2 i zobacz na czym system się zatrzymuje (zrób np. zdjęcie, wrzuć na jakiś serwis, a tu daj linka).
Zobaczymy, pomyślimy, może się pomoże ;)
« Ostatnia zmiana: Lipiec 19, 2018, 22:14:58 pm wysłana przez yahoob3 »
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

Odp: Czas włączania laptopa
« Odpowiedź #2 dnia: Lipiec 19, 2018, 23:24:08 pm »
Zakładamy,że wgram wcześniejszą wersję,czy stracę wszystkie dane z dysku?Druga sprawa ,przy uruchamianiu systemu kiedy wcisnę F2,przelatuje dużo danych i nie sposób tego sfotografować,nie bardzo wiem jak to zapisać.Dziwne ,dla mnie oczywiście,jest to że mija dużo czasu zanim pojawi się samo logo z kropkami.Czy to normalne?

*

Offline yahoob3

  • *****
  • 683
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Czas włączania laptopa
« Odpowiedź #3 dnia: Lipiec 20, 2018, 07:44:56 am »
Zakładamy,że wgram wcześniejszą wersję,czy stracę wszystkie dane z dysku?
Jeśli /home masz na osobnej partycji to nie, nawet ustawienia programów będziesz miał zachowane, np. dodatki czy zakładki z przeglądarce... o ile oczywiście nie sformatujesz /home :)

Cytuj
Druga sprawa ,przy uruchamianiu systemu kiedy wcisnę F2,przelatuje dużo danych i nie sposób tego sfotografować,nie bardzo wiem jak to zapisać.Dziwne ,dla mnie oczywiście,jest to że mija dużo czasu zanim pojawi się samo logo z kropkami.Czy to normalne?
Może masz ustawione w GRUB oczekiwanie?
Pokaż zawartość tego:
sudo xed /etc/default/grubskopiuj z xed i wklej na forum pomiędzy znaczniki code (jak to zrobić?).
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

Odp: Czas włączania laptopa
« Odpowiedź #4 dnia: Lipiec 20, 2018, 17:57:50 pm »
Witam,po wpisaniu komendy otwiera mi się drugie okienko z tekstem:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Po zamknięciu dodatkowego okna w terminalu pojawia mi się taki napis:
piotr@piotr-Laptopik:~$ sudo xed /etc/default/grub
[sudo] hasło użytkownika piotr:

** (xed:8204): WARNING **: 17:27:11.893: Set document metadata failed: Ustawianie atrybutu metadata::xed-position nie jest obsługiwane
piotr@piotr-Laptopik:~$

Tu to dopiero czarna magia dla mnie. :-\
Pozdrawiam ;D

Piotruś,używaj znaczników CODE proszę
« Ostatnia zmiana: Lipiec 20, 2018, 22:16:38 pm wysłana przez szymon1978 »

*

Offline yahoob3

  • *****
  • 683
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Czas włączania laptopa
« Odpowiedź #5 dnia: Lipiec 20, 2018, 22:06:04 pm »
Witam,po wpisaniu komendy otwiera mi się drugie okienko z tekstem:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Czyli standard. Nie masz może jakiegoś opóźnienia ustawionego w BIOSie?

Cytuj
Po zamknięciu dodatkowego okna w terminalu pojawia mi się taki napis:piotr@piotr-Laptopik:~$ sudo xed /etc/default/grub[sudo] hasło użytkownika piotr:

** (xed:8204): WARNING **: 17:27:11.893: Set document metadata failed: Ustawianie atrybutu metadata::xed-position nie jest obsługiwane
piotr@piotr-Laptopik:~$
Wszystko ok, w zasadzie w komendzie, którą podałem powinno być zamiast "sudo"  - "gksu" :)
Cytuj
Tu to dopiero czarna magia dla mnie. :-\
Przypomnij sobie swoje początki z Windows :) Też pewnie była czarna magia ;D
A jak uruchamiasz system z płyty/pendriva też tak długo się uruchamia? Zasadniczo system zaczyna się ładować, kiedy pojawia się logo z kropkami. Wcześniej startuje BIOS i GRUB, czyli "program rozruchowy". Możesz zmierzyć czas od pojawienia się logo, bo jeśli piszesz, że tekst (po F2) przelatuje, to znak, że system ładuje się piorunem. Kwestia startu komputera.

 PS Używaj tagów CODE (# - nad okienkiem edycji posta).
« Ostatnia zmiana: Lipiec 20, 2018, 22:07:39 pm wysłana przez yahoob3 »
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

*

Offline ciastek1981

  • *******
  • 1134
  • 150
  • Płeć: Mężczyzna
  • Sprzątam forum, usuwam reklamy oraz daję bany ;)
Odp: Czas włączania laptopa
« Odpowiedź #6 dnia: Lipiec 21, 2018, 09:39:58 am »
Problem rozwiązany czy szukamy dalej? Prawa kolumna na górze

https://sites.google.com/site/easylinuxtipsproject/bugs#TOC-Booting-takes-a-very-long-time

Odp: Czas włączania laptopa
« Odpowiedź #7 dnia: Lipiec 23, 2018, 14:00:35 pm »
piotr@piotr-Laptopik:~$ systemd-analyze blame
         17.877s systemd-journal-flush.service
         16.371s ufw.service
         15.345s dev-sda1.device
         12.562s lvm2-monitor.service
         12.544s keyboard-setup.service
         10.707s swapfile.swap
         10.680s systemd-udevd.service
          4.428s networkd-dispatcher.service
          4.300s ubuntu-system-adjustments.service
          3.943s NetworkManager.service
          2.936s udisks2.service
          2.617s grub-common.service
          2.309s dns-clean.service
          1.760s systemd-remount-fs.service
          1.715s sys-kernel-debug.mount
          1.712s dev-mqueue.mount
          1.699s dev-hugepages.mount
          1.620s accounts-daemon.service
          1.517s lightdm.service
          1.500s plymouth-quit-wait.service
          1.464s ModemManager.service
          1.264s systemd-modules-load.service
          1.095s avahi-daemon.service
          1.056s wpa_supplicant.service
           935ms rsyslog.service
           893ms systemd-tmpfiles-setup-dev.service
           868ms apparmor.service
           841ms gpu-manager.service
           676ms hddtemp.service
           653ms blk-availability.service
           598ms systemd-resolved.service
           573ms networking.service
           544ms systemd-journald.service
           530ms apport.service
           528ms speech-dispatcher.service
           481ms systemd-random-seed.service
           442ms sys-kernel-config.mount
           440ms sys-fs-fuse-connections.mount
           385ms upower.service
           381ms bluetooth.service
           364ms packagekit.service
           361ms systemd-sysctl.service
           301ms polkit.service
           299ms alsa-restore.service
           297ms systemd-logind.service
           272ms systemd-timesyncd.service
           249ms systemd-rfkill.service
           247ms kmod-static-nodes.service
           239ms lm-sensors.service
           220ms thermald.service
           186ms systemd-tmpfiles-setup.service
           145ms setvtrgb.service
           145ms systemd-udev-trigger.service
           122ms pppd-dns.service
           112ms colord.service
            99ms user@1000.service
            94ms plymouth-start.service
            47ms systemd-update-utmp.service
            29ms plymouth-read-write.service
            21ms kerneloops.service
            20ms systemd-user-sessions.service
            18ms systemd-tmpfiles-clean.service
            15ms console-setup.service
            15ms openvpn.service
            14ms systemd-backlight@backlight:acpi_video0.service
            13ms systemd-update-utmp-runlevel.service
            13ms ureadahead-stop.service
             8ms rtkit-daemon.service
lines 46-68/68 (END)
Witam ponownie,wygląda to tak.
System z pendraka ładuje się w prawie identycznym czasie,więc może po prostu ten typ tak ma.Dziękuje wszystkim za odpowiedzi.
P.S. Powiedzcie mi jeszcze proszę, o co chodzi z tymi znacznikami code,bo nie mogę załapać.

Brak znaczników - # code.
« Ostatnia zmiana: Lipiec 23, 2018, 16:29:56 pm wysłana przez ciastek1981 »

*

Offline yahoob3

  • *****
  • 683
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Czas włączania laptopa
« Odpowiedź #8 dnia: Lipiec 23, 2018, 15:20:45 pm »
[...] Chodziło wtedy o taki obrazek :) https://forum.linuxmint.pl/index.php?topic=6937.msg64458#msg64458

Sprawdź BIOS... długo wyświetla się logo producenta laptopa?

EDIT: coś mi się wydaje, że tu może być rozwiązanie, ale dobrze byłoby gdyby jakiś poweruser zerknął. : https://bbs.archlinux.org/viewtopic.php?id=189775
« Ostatnia zmiana: Lipiec 23, 2018, 15:42:05 pm wysłana przez yahoob3 »
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

*

Offline ciastek1981

  • *******
  • 1134
  • 150
  • Płeć: Mężczyzna
  • Sprzątam forum, usuwam reklamy oraz daję bany ;)
Odp: Czas włączania laptopa
« Odpowiedź #9 dnia: Lipiec 23, 2018, 16:31:39 pm »
Zanim Ulv wpadnie tutej cały na biało  8)

sudo apt-get install pastebinit
potem, wynik - link

dmesg|pastebinit
@yb3

Możesz mieć nawet rację, w moim linku sugerowali problem z ntp.service

https://wiki.archlinux.org/index.php/systemd#Journal_size_limit
« Ostatnia zmiana: Lipiec 23, 2018, 16:34:22 pm wysłana przez ciastek1981 »

*

Offline mariusz_sz

  • **
  • 69
  • 0
  • Płeć: Mężczyzna
Odp: Czas włączania laptopa
« Odpowiedź #10 dnia: Lipiec 24, 2018, 08:20:17 am »
Ze strony Linux Mint:

PROBLEM ZNAJĄ - póki co nie ma na niego rozwiązania

https://blog.linuxmint.com/?p=3620

cytuje: "Uważaj na Kernel 4.15.0-24. Krytyczny problem powoduje, że niektóre komputery, uruchamiają się naprawdę powoli, nie nie uruchomiają. Ubuntu zdaje sobie z tego sprawę i pracuje nad poprawką. Otrzymaliśmy również negatywną opinię z serii jądra 4.15 w Mint 18.x (w oparciu o Ubuntu Xenial). Mimo że Ubuntu zdecydowało się na zmianę serii HWE, seria 4.15 nie obsługuje jeszcze niektórych zastrzeżonych sterowników (nvidia-3.04 i nvidia-340 wśród nich)"

Ważne info jeszcze ze strony Mięty - podczas czystej instalacji najlepiej odłączyć Internet i instalować OFFLINE

Zainstaluj jeszcze raz bez włączonego Internetu podczas instalacji i wrzuć kernel: https://liquorix.net/

I daj znać

« Ostatnia zmiana: Lipiec 24, 2018, 08:25:32 am wysłana przez mariusz_sz »
Mariusz :)

*

Offline mariusz_sz

  • **
  • 69
  • 0
  • Płeć: Mężczyzna
Odp: Czas włączania laptopa
« Odpowiedź #11 dnia: Lipiec 24, 2018, 08:26:57 am »
POWODZENIA :)
« Ostatnia zmiana: Lipiec 24, 2018, 08:29:11 am wysłana przez mariusz_sz »
Mariusz :)

*

Offline Wiechu_LMC

  • *
  • 12
  • 0
  • Płeć: Mężczyzna
Odp: Czas włączania laptopa
« Odpowiedź #12 dnia: Lipiec 25, 2018, 21:13:02 pm »
Ze strony Linux Mint:

PROBLEM ZNAJĄ - póki co nie ma na niego rozwiązania

https://blog.linuxmint.com/?p=3620

cytuje: "Uważaj na Kernel 4.15.0-24. Krytyczny problem powoduje, że niektóre komputery, uruchamiają się naprawdę powoli, nie nie uruchomiają. Ubuntu zdaje sobie z tego sprawę i pracuje nad poprawką. Otrzymaliśmy również negatywną opinię z serii jądra 4.15 w Mint 18.x (w oparciu o Ubuntu Xenial). Mimo że Ubuntu zdecydowało się na zmianę serii HWE, seria 4.15 nie obsługuje jeszcze niektórych zastrzeżonych sterowników (nvidia-3.04 i nvidia-340 wśród nich)"

Ważne info jeszcze ze strony Mięty - podczas czystej instalacji najlepiej odłączyć Internet i instalować OFFLINE

Zainstaluj jeszcze raz bez włączonego Internetu podczas instalacji i wrzuć kernel: https://liquorix.net/

I daj znać


Ja uporałem się z wolnym uruchamianien linuxa 19 natomiast nie mogę poradzić z tym że linux nie widzi pendriva ani na fat32 ani na ntfs ani malych ani duzych roże firmy itp, po prostu po włożeniu w gnd USB nie ma w systemie, dopiero po jakichś 10 min się pojawia, miał ktos taki przypadek czy to przypadłość "wieku niemowlęcego" tary?

*

Offline yahoob3

  • *****
  • 683
  • 121
  • Płeć: Mężczyzna
  • Zgryźliwy tetryk
    • Organy Hammonda
Odp: Czas włączania laptopa
« Odpowiedź #13 dnia: Lipiec 25, 2018, 21:21:02 pm »
Podepnij pendriva do komputera i zrób to, o czym ciastek1981 pisał tu: https://forum.linuxmint.pl/index.php?topic=9877.msg66549#msg66549
czyli podaj linki do tego, co pastebinit wrzuci z dmesg.
Dobrze byłoby podać osobno dwa wyniki: zanim się pen się zamontuje jak i po zamontowaniu.
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742

*

Offline ciastek1981

  • *******
  • 1134
  • 150
  • Płeć: Mężczyzna
  • Sprzątam forum, usuwam reklamy oraz daję bany ;)
Odp: Czas włączania laptopa
« Odpowiedź #14 dnia: Lipiec 25, 2018, 21:38:00 pm »
Można spróbować z opcją -w,

     
Cytuj
-w, --follow
              Wait for new messages.  This feature is supported only on
              systems with a readable /dev/kmsg (since kernel 3.5.0).

a więc

dmesg -w