Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Rendering error 0x00000000: FailedToCreateDevice. (2)
#1
0
Siemka!

Od niedawna bawię się trochę na linuxie a dokładnie na Mincie 64bit i problem w tym że nie będę próbować tu odpalać bóg wie czego bo znając życie każdy napisze że linux nie jest do gier i tak dalej ale jednak Steam ma tego Protona i na ich stronie oficjalnej pisze że większość gier można już odpalić, dokładnie chodzi mi o gre World Of Tanks Blitz i tylko o tą grę reszta mnie nie obchodzi, po odpaleniu gry wyskakuje mi ten błąd:
"Rendering error 0x00000000: FailedToCreateDevice. Program will terminate."
Gre opaliłem na Protonie 3.16.9 tak jak było zalecane przez większość osób na stronie Protona.

W razie czego mój komputer:
Pentium Dual-Core E5200 2.50GHz
4 GB RAM
GeForce GT610 2 GB

No i systemy które mam na kompie to Windows 10 PRO (na jednym dysku) i Linux Mint 19.3 Tricia 64bit (na drugim dysku)

Wie ktoś może jak to naprawić? Z góry dzięki za wszystkie odpowiedzi i miłego dnia Big Grin
Odpowiedz
#2
0
Proszę podać informacje o konfiguracji sprzętowej/programowej w postaci wyniku polecenia inxi -Fxz (więcej szczegółów uzyskasz klikając w link)

Podając wyniki komend bądź logi należy używać znaczników - CODE (więcej szczegółów uzyskasz klikając w link)

Więcej zasad, które należy stosować znajdziesz w Zasadach forum

Stosowanie zasad forum, pomaga w szybszej i sprawniejszej pomocy.

EDIT:
Z tego, co widzę nie tylko na Linuksie jest ten problem.
Może ktoś obeznany z grami wyciągnie stąd jakieś pomocne informacje.
https://www.protondb.com/app/444200
https://github.com/ValveSoftware/Proton/...quirements
Odpowiedz
#3
Wink 
0
Dobra to od nowa

Wszystko co wyszło z kodu
Kod:
inxi -Fxz
Kod:
System:
  Host: thecookiemonster-ThinkCentre-A58 Kernel: 5.0.0-32-generic x86_64
  bits: 64 compiler: gcc v: 7.4.0 Desktop: Cinnamon 4.4.5
  Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic
Machine:
  Type: Desktop System: LENOVO product: 751579G v: ThinkCentre A58
  serial: <filter>
  Mobo: LENOVO model: N/A serial: <filter> BIOS: LENOVO v: 5HKT45AUS
  date: 10/22/2009
CPU:
  Topology: Dual Core model: Pentium E5200 bits: 64 type: MCP arch: Penryn
  rev: A L2 cache: 2048 KiB
  flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 9975
  Speed: 2494 MHz min/max: 1203/2500 MHz Core speeds (MHz): 1: 2494 2: 2494
Graphics:
  Device-1: NVIDIA GF119 [GeForce GT 610] vendor: ASUSTeK driver: nvidia
  v: 390.132 bus ID: 01:00.0
  Display: x11 server: X.Org 1.20.4 driver: nvidia
  unloaded: fbdev,modesetting,nouveau,vesa resolution: 1440x900~60Hz
  OpenGL: renderer: N/A v: N/A direct render: N/A
Audio:
  Device-1: Intel NM10/ICH7 Family High Definition Audio vendor: Lenovo
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0
  Device-2: NVIDIA GF119 HDMI Audio vendor: ASUSTeK driver: snd_hda_intel
  v: kernel bus ID: 01:00.1
  Sound Server: ALSA v: k5.0.0-32-generic
Network:
  Device-1: Marvell 88E8057 PCI-E Gigabit Ethernet vendor: Lenovo
  driver: sky2 v: 1.30 port: e800 bus ID: 03:00.0
  IF: ens33 state: down mac: <filter>
  Device-2: Realtek type: USB driver: rtl8xxxu bus ID: 1-5.2:27
  IF: wlx00e04c1dd9b6 state: up mac: <filter>
Drives:
  Local Storage: total: 447.14 GiB used: 66.43 GiB (14.9%)
  ID-1: /dev/sda vendor: Seagate model: ST9320325AS size: 298.09 GiB
  ID-2: /dev/sdb vendor: Western Digital model: WD1600AAJS-60M0A0
  size: 149.05 GiB
Partition:
  ID-1: / size: 51.13 GiB used: 18.21 GiB (35.6%) fs: ext4 dev: /dev/sdb5
Sensors:
  System Temperatures: cpu: 54.0 C mobo: N/A gpu: nvidia temp: 42 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 200 Uptime: 4h 01m Memory: 3.85 GiB used: 3.05 GiB (79.2%)
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20
  inxi: 3.0.32
A teraz mój problem brzmi tak po włączeniu gry wyskakuje mi coś takiego:
"Rendering error 0x00000000: FailedToCreateDevice."

Wersja Protona to 3.16 tak jak kazali mi włączyć na stronie ProtonDB

Pozdrawiam

Dodano po pewnym czasie:
Dobra dzięki wam za pomoc sam sobie jakoś dam rade XD

Forum do pomocy chyba żadne forum chyba tak nie działa a szczególnie to gdzie na odpowiedź nawet się doczekać nie można

Żegnam i forum nie polecam całkowicie.
Odpowiedz
#4
0
Wiesz, jeśli ktoś nie miał podobnego problemu bo, np. nie gra, to niekoniecznie może nie tyle chcieć, co móc pomóc.
OK, pokazałeś... piaskownica nie pasuje... dobranoc.
Odpowiedz


Skocz do:




Użytkownicy przeglądający ten wątek: 1 gości