Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Rozwiązane Jak uruchomić zainstalowany progrem?
#1
0
Witam,
pewnie kolejne głupie pytanie... Zainstalowałem program i8kutils, który służy do kontroli pracy wentylatorów w laptopach Dell. Najpierw zainstalowałem go z repozytorium, potem ściągnąłem ze strony i zainstalowałem ponownie. Teraz nie mogę go uruchomić. Nie ma go w menu, a po wpisaniu "i8kutils" do terminala otrzymuję komunikat "i8kutils: nie znaleziono polecenia". Coś można z tym zrobić?
#2
1
Better response on post RE: Jak uruchomić zainstalowany progrem?Wystarczy przeczytać co autor napisał na stronie:
Cytat:The i8kutils package includes the following utilities:

* i8kctl - command-line interface to the kernel module

* i8kmon - temperature monitor with fan control capability

* i8kfan - utility to set state (speed) of fans
#3
0
Szukałem, ale mój angielski nie jest rewelacyjny. Teraz znalazłem, alle to dla mnie za trudne. Będę szukał innych programów, bo można oszaleć przez te wentylatory. Dzięki za pomoc.
#4
0
Może najprościej będzie, jak napiszesz jaki jest rzeczywisty problem?
Podejrzewam, że brakuje automatycznej regulacji prędkości wentylatorów, przez co pracują non-stop na pełnej prędkości.
Na wszelkie języki, nie tylko angielski, są translatory. Żyjemy w 21 wieku.
#5
0
Wentylatory nie pracują w sposób ciągły. Pracują dorywczo w wybitnie wkurzający sposób. Cisza, cisza, a tu nagle wskakują na wysokie obroty, wyją 3 sekundy, przerwa2 sekundy, wyją 3 sekundy, przerwa i tak w kółko. Albo przeglądarka otwarta, ale żadnego ruchu, wentylatory wyją, otwieram nową kartę - cisza. A mistrzostwo świata to jak czasami przeglądam stronę... czytam, jest cisza, przewijam kółkiem - i na tą sekundę zawyją, przestanę ruszać kółkiem - cisza - i tak na okrągło... Mówię Ci, w nocy szału można dostać. W BIOS nie ma żadnej pozycji do sterowania wentylatorami.

Dodano po pewnym czasie:
Co ciekawe, wentylator karty graficznej zachowuje się tak samo.
#6
0
Może BIOS reaguje na zbyt niskie temperatury podczas regulacji prędkości wentylatorów.
Możesz spróbować uruchomienia programu i8kutils ale to nie zawsze się udaje.
Zacznij od wykonania po kolei tych poleceń:

sudo su

echo "dell-smm-hwmon" >> /etc/modules

echo "options dell-smm-hwmon restricted=0 force=1" > /etc/modprobe.d/dell-smm-hwmon.conf

update-initramfs -u

Następnie zrestartuj komputer i podaj wyniki tych poleceń:

inxi -Fxz

sensors

i8kctl fan
#7
0
Kod:
[email protected]:~$ inxi -Fxz
System:
  Host: mpal-Precision-M4600 Kernel: 5.4.0-40-generic x86_64 bits: 64
  compiler: gcc v: 7.5.0 Desktop: Cinnamon 4.4.8
  Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic
Machine:
  Type: Laptop System: Dell product: Precision M4600 v: 01 serial: <filter>
  Mobo: Dell model: 08V9YG v: A00 serial: <filter> BIOS: Dell v: A19
  date: 09/14/2018
Battery:
  ID-1: BAT0 charge: 13.0 Wh condition: 20.0/48.8 Wh (41%)
  model: Samsung SDI DELL P8TC727 status: Discharging
CPU:
  Topology: Quad Core model: Intel Core i7-2860QM bits: 64 type: MT MCP
  arch: Sandy Bridge rev: 7 L2 cache: 8192 KiB
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 39908
  Speed: 1104 MHz min/max: 800/2500 MHz Core speeds (MHz): 1: 1047 2: 988
  3: 924 4: 1076 5: 976 6: 905 7: 930 8: 1056
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
  vendor: Dell driver: i915 v: kernel bus ID: 00:02.0
  Device-2: NVIDIA GF106GLM [Quadro 2000M] vendor: Dell driver: nvidia
  v: 390.138 bus ID: 01:00.0
  Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia
  unloaded: fbdev,nouveau,vesa resolution: 1368x768~60Hz
  OpenGL: renderer: Quadro 2000M/PCIe/SSE2 v: 4.6.0 NVIDIA 390.138
  direct render: Yes
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
  vendor: Dell Precision M4600 driver: snd_hda_intel v: kernel
  bus ID: 00:1b.0
  Device-2: NVIDIA GF106 High Definition Audio vendor: Dell
  driver: snd_hda_intel v: kernel bus ID: 01:00.1
  Sound Server: ALSA v: k5.4.0-40-generic
Network:
  Device-1: Intel 82579LM Gigabit Network vendor: Dell Precision M4600
  driver: e1000e v: 3.2.6-k port: 8080 bus ID: 00:19.0
  IF: eno1 state: down mac: <filter>
  Device-2: Intel Centrino Ultimate-N 6300 driver: iwlwifi v: kernel
  port: 7000 bus ID: 03:00.0
  IF: wlp3s0 state: up mac: <filter>
Drives:
  Local Storage: total: 238.47 GiB used: 137.20 GiB (57.5%)
  ID-1: /dev/sda vendor: Patriot model: P200 256GB size: 238.47 GiB
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
  v: 3.0 bus ID: 00:1f.2
Partition:
  ID-1: / size: 27.37 GiB used: 13.27 GiB (48.5%) fs: ext4 dev: /dev/sda1
  ID-2: /home size: 198.90 GiB used: 123.92 GiB (62.3%) fs: ext4
  dev: /dev/sda6
  ID-3: swap-1 size: 7.45 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda5
Sensors:
  System Temperatures: cpu: 64.0 C mobo: 45.0 C sodimm: 40.0 C gpu: nvidia
  temp: 58 C
  Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 0%
Info:
  Processes: 272 Uptime: 3m Memory: 15.52 GiB used: 1.07 GiB (6.9%)
  Init: systemd runlevel: 5 Compilers: gcc: 7.5.0 Shell: bash v: 4.4.20
  inxi: 3.0.32
[email protected]:~$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +60.0°C  (high = +86.0°C, crit = +100.0°C)
Core 0:        +57.0°C  (high = +86.0°C, crit = +100.0°C)
Core 1:        +61.0°C  (high = +86.0°C, crit = +100.0°C)
Core 2:        +59.0°C  (high = +86.0°C, crit = +100.0°C)
Core 3:        +59.0°C  (high = +86.0°C, crit = +100.0°C)

dell_smm-virtual-0
Adapter: Virtual device
Processor Fan:    0 RPM
Video Fan:        0 RPM
CPU:            +60.0°C 
Ambient:        +46.0°C 
SODIMM:        +45.0°C 
SODIMM:        +45.0°C 
SODIMM:        +41.0°C 
GPU:            +58.0°C 

[email protected]:~$ i8kctl fan
0 0

Dodano po pewnym czasie:
Magnus, skąd wiesz, że mam Della? Już opisywałem ten problem wcześniej, zajrzałeś do innego wątka?
#8
0
Piszesz o tym w pierwszej wiadomości.
#9
0
Jeżeli masz przeciętne temperatury procesora około 60 stopni to wentylatory będą pracować.
Popróbuj innych wersji, środowisk graficznych i jąder linuksa to może procesor nie będzie się tak rozgrzewał.


Uruchomienie programu i8kutils.
Utwórz plik konfiguracyjny:

Kod:
sudo touch /etc/i8kmon.conf

Otwórz go:

Kod:
xed admin:///etc/i8kmon.conf

Wklej tam ten profil:

Kod:
set config(i8kfan)  /usr/bin/i8kfan
set config(auto) 1
set config(nouserconfig) 1
set status(leftspeed) "0 1000 2000 3000"
set status(rightspeed) "0 1000 2000 3000"
set config(0) {{0 0}  -1  60  -1  65}
set config(1) {{1 1}  50  70  55  75}
set config(2) {{1 1}  60  80  65  85}
set config(3) {{2 2}  70 128  75 128}

Zrestartuj komputer i użyj to polecenie żeby uruchomić program czasowo :

Kod:
i8kmon -v

Bez zamykania terminalu sprawdź jak pracują wentylatory. Jeżeli będzie lepiej to uruchomimy program na stałe.
#10
0
To jest mój plik konfiguracyjny:

Kod:
# Sample i8kmon configuration file (/etc/i8kmon.conf, ~/.i8kmon).

# External program to control the fans
set config(i8kfan) /usr/bin/i8kfan

# Report status on stdout, override with --verbose option
set config(verbose) 0

# Status check timeout (seconds), override with --timeout option
set config(timeout) 2

# Temperature threshold at which the temperature is displayed in red
set config(t_high) 80

# Temperature thresholds: {fan_speeds low_ac high_ac low_batt high_batt}
# These were tested on the I8000. If you have a different Dell laptop model
# you should check the BIOS temperature monitoring and set the appropriate
# thresholds here. In doubt start with low values and gradually rise them
# until the fans are not always on when the cpu is idle.
set config(0)  {{0 0}  -1  55  -1  60}
set config(1)  {{1 1}  50  65  55  70}
set config(2)  {{2 2}  60  75  65  80}
set config(3)  {{2 2}  70 128  75 128}

# Speed values are set here to avoid i8kmon probe them at every time it starts.
set status(leftspeed) "0 1000 2000 3000"
set status(rightspeed) "0 1000 2000 3000"

# end of file
Podmienię w nim wartości zgodnie z twoimi wskazówkami.
Nawiasem mówiąc, nie mam pretensji o to, że wentylatory pracują Smile Niech sobie pracują, ale nie tak falująco, impulsowo rzekłbym nawet. Wkurzające jest to, że one nie potrafią sobie uśrednić tych obrotów i pracować nawet i ciągle, ale spokojnie.

Dodano po pewnym czasie:
Trudno na razie powiedzieć. Wentylatory nadal są nerwowe, ale jest jakby trochę lepiej. Muszę się wgłębić w ustawienia tego programu, może uda się jeszcze je dopieścić. Trzeba jednak stwierdzić, że wentylatory w tym sprzęcie raczej są głośne. Denerwujący jest zwłaszcza moment, w którym się rozpędzają - nie ma tego łagodnego startu, od razu wchodzą na obroty.
Możesz mi jeszcze podpowiedzieć, jak włączyć ten program na stałe? Smile
Bardzo dziękuję za pomoc.


Skocz do:




Użytkownicy przeglądający ten wątek: 1 gości