Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Rozwiązane Długie uruchamianie Minta po zmianie dysku błąd ACPI
#1
0
Witam, mam problem z uruchamianiem Minta po zmianie dysku twardego HDD na pojemniejszy. Problem pojawił się po usunięciu starego dysku na którym były inne systemy. Odpiąłem dyski HDD, został tylko dysk SSD na którym jest postawiony system. Sądziłem, że update gruba zaaktualizuje konfigurację. Przedtem wyświetlał się bootmenu i uruchamiał sie szybko system. Po zmianie jest czarny ekran i logo minta, system uruchamia się około 2 minut.

Według dziennika wychodzą jakieś błędy ACPI, wrzucam kawałek. 


Kod:
[    1.791054] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[    1.791091] ata6: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[    1.791316] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.SAT0.SPT0._GTF.DSSP], AE_NOT_FOUND (20190816/psargs-330)
[    1.791327] No Local Variables are initialized for Method [_GTF]
[    1.791328] No Arguments are initialized for method [_GTF]
[    1.791330] ACPI Error: Aborting method \_SB.PCI0.SAT0.SPT0._GTF due to previous error (AE_NOT_FOUND) (20190816/psparse-531)
[    1.791339] ata1.00: ATAPI: ASUS    DRW-1814BLT, 1.13, max UDMA/66
[    1.791385] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.SAT0.SPT5._GTF.DSSP], AE_NOT_FOUND (20190816/psargs-330)
[    1.791393] No Local Variables are initialized for Method [_GTF]
[    1.791395] No Arguments are initialized for method [_GTF]
[    1.791396] ACPI Error: Aborting method \_SB.PCI0.SAT0.SPT5._GTF due to previous error (AE_NOT_FOUND) (20190816/psparse-531)
[    1.791749] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.SAT0.SPT0._GTF.DSSP], AE_NOT_FOUND (20190816/psargs-330)
[    1.791758] No Local Variables are initialized for Method [_GTF]
[    1.791759] No Arguments are initialized for method [_GTF]
[    1.791761] ACPI Error: Aborting method \_SB.PCI0.SAT0.SPT0._GTF due to previous error (AE_NOT_FOUND) (20190816/psparse-531)
[    1.791771] ata1.00: configured for UDMA/66
[    1.792718] ata6.00: ATA-9: SanDisk SDSSDA120G, U21010RL, max UDMA/133
[    1.792720] ata6.00: 234441648 sectors, multi 1: LBA48 NCQ (depth 32), AA
[    1.792943] scsi 0:0:0:0: CD-ROM            ASUS     DRW-1814BLT      1.13 PQ: 0 ANSI: 5
[    1.796808] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.SAT0.SPT5._GTF.DSSP], AE_NOT_FOUND (20190816/psargs-330)
[    1.796817] No Local Variables are initialized for Method [_GTF]
[    1.796818] No Arguments are initialized for method [_GTF]
[    1.796820] ACPI Error: Aborting method \_SB.PCI0.SAT0.SPT5._GTF due to previous error (AE_NOT_FOUND) (20190816/psparse-531)
[    1.801267] ata6.00: configured for UDMA/133
[    1.850814] sr 0:0:0:0: [sr0] scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray
[    1.850816] cdrom: Uniform CD-ROM driver Revision: 3.20
[    1.864937] sr 0:0:0:0: Attached scsi CD-ROM sr0
[    1.864997] sr 0:0:0:0: Attached scsi generic sg0 type 5
[    1.865150] scsi 5:0:0:0: Direct-Access     ATA      SanDisk SDSSDA12 10RL PQ: 0 ANSI: 5
[    1.865321] sd 5:0:0:0: Attached scsi generic sg1 type 0
[    1.865337] sd 5:0:0:0: [sda] 234441648 512-byte logical blocks: (120 GB/112 GiB)
[    1.865348] sd 5:0:0:0: [sda] Write Protect is off
[    1.865349] sd 5:0:0:0: [sda] Mode Sense: 00 3a 00 00
[    1.865365] sd 5:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    1.888152]  sda: sda1 sda2 sda3
[    1.888552] sd 5:0:0:0: [sda] Attached SCSI disk
[    1.968897] random: fast init done
[    2.008696] usb 1-1.1: new low-speed USB device number 3 using ehci-pci
[    2.020693] usb 2-1.6: new high-speed USB device number 3 using ehci-pci
[    2.036299] random: systemd-udevd: uninitialized urandom read (16 bytes read)
[    2.036314] random: systemd-udevd: uninitialized urandom read (16 bytes read)
[    2.036333] random: systemd-udevd: uninitialized urandom read (16 bytes read)
[    2.122519] usb 1-1.1: New USB device found, idVendor=09da, idProduct=c10a, bcdDevice=10.32
[    2.122521] usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    2.122522] usb 1-1.1: Product: USB Mouse
[    2.122523] usb 1-1.1: Manufacturer: A4Tech
[    2.125797] hidraw: raw HID events driver (C) Jiri Kosina
[    2.129310] usb 2-1.6: New USB device found, idVendor=1a40, idProduct=0101, bcdDevice= 1.11
[    2.129312] usb 2-1.6: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[    2.129314] usb 2-1.6: Product: USB 2.0 Hub
[    2.129606] hub 2-1.6:1.0: USB hub found
[    2.129679] hub 2-1.6:1.0: 4 ports detected
[    2.130327] usbcore: registered new interface driver usbhid
[    2.130328] usbhid: USB HID core driver
[    2.133499] input: A4Tech USB Mouse as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.1/1-1.1:1.0/0003:09DA:C10A.0001/input/input4
[    2.133581] input: A4Tech USB Mouse as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.1/1-1.1:1.0/0003:09DA:C10A.0001/input/input5
[    2.133656] hid-generic 0003:09DA:C10A.0001: input,hiddev0,hidraw0: USB HID v1.10 Mouse [A4Tech USB Mouse] on usb-0000:00:1a.0-1.1/input0
[    2.188698] tsc: Refined TSC clocksource calibration: 2594.107 MHz
[    2.188705] clocksource: tsc: mask: 0xffffffffffffffff max_cycles: 0x25647d583cf, max_idle_ns: 440795304232 ns
[    2.188749] clocksource: Switched to clocksource tsc
[    2.636671] raid6: sse2x4   gen() 10950 MB/s
[    2.684669] raid6: sse2x4   xor()  7503 MB/s
[    2.732672] raid6: sse2x2   gen()  9177 MB/s
[    2.780673] raid6: sse2x2   xor()  6169 MB/s
[    2.828673] raid6: sse2x1   gen()  7725 MB/s
[    2.876674] raid6: sse2x1   xor()  5536 MB/s
[    2.876675] raid6: using algorithm sse2x4 gen() 10950 MB/s
[    2.876675] raid6: .... xor() 7503 MB/s, rmw enabled
[    2.876676] raid6: using ssse3x2 recovery algorithm
[    2.879906] xor: measuring software checksum speed
[    2.916671]    prefetch64-sse: 16484.000 MB/sec
[    2.956671]    generic_sse: 14998.000 MB/sec
[    2.956671] xor: using function: prefetch64-sse (16484.000 MB/sec)
[    2.976009] Btrfs loaded, crc32c=crc32c-intel
[    3.161771] EXT4-fs (sda2): mounted filesystem with ordered data mode. Opts: (null)
[    3.407279] systemd[1]: systemd 237 running in system mode. (+PAM +AUDIT +SELINUX +IMA +APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD -IDN2 +IDN -PCRE2 default-hierarchy=hybrid)
[    3.424805] systemd[1]: Detected architecture x86-64.
[    3.442071] systemd[1]: Set hostname to <mintcomputer>.
[    3.596887] systemd[1]: Created slice System Slice.
[    3.596971] systemd[1]: Reached target System Time Synchronized.
[    3.597111] systemd[1]: Listening on Journal Audit Socket.
[    3.597178] systemd[1]: Listening on Device-mapper event daemon FIFOs.
[    3.597241] systemd[1]: Listening on LVM2 poll daemon socket.
[    3.597301] systemd[1]: Listening on Syslog Socket.
[    3.597316] systemd[1]: Reached target Remote File Systems.
[    3.645738] EXT4-fs (sda2): re-mounted. Opts: errors=remount-ro
[    3.678054] lp: driver loaded but no devices found
[    3.698804] ppdev: user-space parallel port driver
[    3.700863] parport_pc 00:07: reported by Plug and Play ACPI
[    3.700938] parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE]
[    3.722439] systemd-journald[393]: Received request to flush runtime journal from PID 1
[    3.800967] lp0: using parport0 (interrupt-driven).
[    4.189694] ACPI Warning: SystemIO range 0x0000000000000428-0x000000000000042F conflicts with OpRegion 0x0000000000000400-0x000000000000047F (\PMIO) (20190816/utaddress-213)
[    4.189700] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    4.189702] ACPI Warning: SystemIO range 0x0000000000000540-0x000000000000054F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20190816/utaddress-213)
[    4.189705] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    4.189706] ACPI Warning: SystemIO range 0x0000000000000530-0x000000000000053F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20190816/utaddress-213)
[    4.189708] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    4.189709] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052F conflicts with OpRegion 0x0000000000000500-0x000000000000051F (\LED) (20190816/utaddress-213)
[    4.189711] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20190816/utaddress-213)
[    4.189714] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    4.189714] lpc_ich: Resource conflict(s) found affecting gpio_ich

Po tym system jakby przywracał. Jak mam to naprawić?

Kod:
[email protected]:~$ inxi -Fxz
System:
  Host: mintcomputer Kernel: 5.4.0-42-generic x86_64 bits: 64 compiler: gcc
  v: 7.5.0 Desktop: Xfce 4.14.1 Distro: Linux Mint 19.3 Tricia
  base: Ubuntu 18.04 bionic
Machine:
  Type: Desktop System: Gigabyte product: N/A v: N/A serial: <filter>
  Mobo: Gigabyte model: H61M-DS2 3.0 v: x.x serial: <filter>
  UEFI: American Megatrends v: F1 date: 10/12/2012
CPU:
  Topology: Dual Core model: Intel Celeron G1610 bits: 64 type: MCP
  arch: Ivy Bridge rev: 9 L2 cache: 2048 KiB
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 10376
  Speed: 1596 MHz min/max: 1600/2600 MHz Core speeds (MHz): 1: 1596 2: 1596
Graphics:
  Device-1: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics
  vendor: Gigabyte driver: i915 v: kernel bus ID: 00:02.0
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa
  resolution: 1680x1050~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics 2500 (IVB GT1)
  v: 4.2 Mesa 20.0.8 direct render: Yes
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
  vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 00:1b.0
  Sound Server: ALSA v: k5.4.0-42-generic
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: Gigabyte driver: r8169 v: kernel port: e000 bus ID: 02:00.0
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 5.57 TiB used: 918.49 GiB (16.1%)
  ID-1: /dev/sda vendor: Toshiba model: HDWD240 size: 3.64 TiB
  ID-2: /dev/sdb vendor: Western Digital model: WD20EZRX-00D8PB0
  size: 1.82 TiB
  ID-3: /dev/sdc vendor: SanDisk model: SDSSDA120G size: 111.79 GiB
Partition:
  ID-1: / size: 36.42 GiB used: 22.42 GiB (61.6%) fs: ext4 dev: /dev/sdc2
  ID-2: /home size: 68.28 GiB used: 14.89 GiB (21.8%) fs: ext4
  dev: /dev/sdc3
Sensors:
  System Temperatures: cpu: 38.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 181 Uptime: 3h 38m Memory: 7.67 GiB used: 1.67 GiB (21.8%)
  Init: systemd runlevel: 5 Compilers: gcc: 7.5.0 Shell: bash v: 4.4.20
  inxi: 3.0.32
Kod:
[email protected]:~$ systemd-analyze
Startup finished in 4.108s (kernel) + 3min 692ms (userspace) = 3min 4.801s
graphical.target reached after 1min 32.075s in userspace

Kod:
[email protected]:~$ systemd-analyze blame
          3.588s apt-daily-upgrade.service
          1.533s udisks2.service
           918ms dev-sdc2.device
           628ms networkd-dispatcher.service
           496ms ubuntu-system-adjustments.service
           307ms NetworkManager.service
           286ms systemd-journal-flush.service
           256ms ModemManager.service
           231ms thermald.service
           219ms accounts-daemon.service
           203ms systemd-modules-load.service
           201ms wpa_supplicant.service
           199ms avahi-daemon.service
           197ms systemd-logind.service
           195ms keyboard-setup.service
           192ms systemd-udev-trigger.service
           191ms systemd-udevd.service
           184ms systemd-resolved.service
           177ms [email protected]\x2duuid-2904\x2d7833.service
           176ms alsa-restore.service
           174ms lm-sensors.service
           173ms apparmor.service
           157ms systemd-timesyncd.service
           146ms systemd-journald.service
           142ms hddtemp.service
           127ms speech-dispatcher.service
           125ms kerneloops.service
           124ms rsyslog.service
           123ms grub-common.service
           107ms lvm2-monitor.service
            86ms networking.service
            82ms lightdm.service
            72ms [email protected]\x2duuid-073c0310\x2def4d\x2d4a7d\x2db8
            71ms systemd-tmpfiles-setup-dev.service
            68ms pppd-dns.service
            65ms plymouth-quit-wait.service
            64ms packagekit.service
            63ms dns-clean.service
            58ms upower.service
            58ms colord.service
            54ms [email protected]
            54ms ntp.service
            52ms gpu-manager.service
            45ms systemd-sysctl.service
            43ms sys-kernel-debug.mount
            43ms systemd-remount-fs.service
            42ms polkit.service
            37ms dev-mqueue.mount
            37ms blk-availability.service
            36ms kmod-static-nodes.service
            32ms systemd-update-utmp.service
            29ms systemd-random-seed.service
            28ms ufw.service
            27ms dev-hugepages.mount
            24ms systemd-tmpfiles-clean.service
            22ms systemd-tmpfiles-setup.service
            16ms plymouth-start.service
            14ms home.mount
            14ms plymouth-read-write.service
            14ms console-setup.service
            13ms systemd-update-utmp-runlevel.service
            12ms boot-efi.mount
            12ms systemd-user-sessions.service
            10ms finalrd.service
             9ms ureadahead-stop.service
             8ms sys-kernel-config.mount
             7ms rtkit-daemon.service
             5ms openvpn.service
             3ms sys-fs-fuse-connections.mount
             3ms setvtrgb.service
#2
0
Wrzuć obrazek wygenerowany z systemd-analyze plot > plot
#3
0
W załączeniu.


Załączone pliki
.tar   plot.svg.tar (Rozmiar: 240 KB / Pobrań: 1)
#4
0
I jeszcze systemd-analyze critical-chain
#5
0
Kod:
[email protected]:~$ systemd-analyze critical-chain
The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @1min 32.075s
└─udisks2.service @1min 30.541s +1.533s
  └─basic.target @1min 30.537s
    └─sockets.target @1min 30.537s
      └─acpid.socket @1min 30.537s
        └─sysinit.target @1min 30.442s
          └─systemd-timesyncd.service @1.403s +157ms
            └─systemd-tmpfiles-setup.service @1.354s +22ms
              └─local-fs.target @1.354s
                └─boot-efi.mount @1.341s +12ms
                  └─[email protected]\x2duuid-2904\x2d7833.service @1.162
                    └─dev-disk-by\x2duuid-2904\x2d7833.device @1.161s
lines 1-15/15 (END)
#6
0
Pokaż jeszcze sudo blkid i cat /etc/fstab
#7
0
Kod:
[email protected]:~$ sudo blkid
[sudo] hasło użytkownika m:      
/dev/sda: LABEL="TOSHIBA" UUID="84d2b84e-04b6-4085-b905-82aa4caeb2e4" TYPE="ext4"
/dev/sdb: LABEL="WD Green" UUID="c58fad39-6d60-430b-89f0-0353fdd082fe" TYPE="ext4"
/dev/sdc1: UUID="2904-7833" TYPE="vfat" PARTUUID="c5abf292-0658-460f-a0b2-c11131d1f0cd"
/dev/sdc2: UUID="32f00e81-93a3-42a5-87b1-9da034eaf44c" TYPE="ext4" PARTUUID="44052379-1c72-4420-b313-768406a50bc2"
/dev/sdc3: UUID="073c0310-ef4d-4a7d-b8ff-eb3357824c2f" TYPE="ext4" PARTUUID="e5e97db9-fe9e-46d0-8657-d08a0bd1f68f"

Kod:
[email protected]:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdc2 during installation
UUID=32f00e81-93a3-42a5-87b1-9da034eaf44c /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sdc1 during installation
UUID=2904-7833  /boot/efi       vfat    umask=0077      0       1
# /home was on /dev/sdc3 during installation
UUID=073c0310-ef4d-4a7d-b8ff-eb3357824c2f /home           ext4    defaults        0       2
# swap was on /dev/sdb8 during installation
UUID=3963fc1b-f82a-4ad1-abe0-e9aac55254c9 none            swap    sw              0       0
#8
0
Problem widzę tu:
Kod:
# swap was on /dev/sdb8 during installation
UUID=3963fc1b-f82a-4ad1-abe0-e9aac55254c9 none            swap    sw              0      0
Ta partycja swap nie występuje w wyniku polecenia blkid.
Nie widzę też żadnej nowej, prawdopodobnie przeszedłeś na swap w formie pliku? Pokaż wynik cat /proc/swaps.
Zakomentuj ten wpis partycji swap w /etc/fstab
Kod:
# swap was on /dev/sdb8 during installation
#UUID=3963fc1b-f82a-4ad1-abe0-e9aac55254c9 none            swap    sw              0      0
i sprawdź czy czas uruchomienia systemu się poprawił
#9
0
Też zauważyłem, że swap był na starym dysku. Jak instalowałem nowy system na SSD to nie tworzyłem swapa, ponieważ mam 8GB ramu.

Kod:
[email protected]:~$ cat /proc/swaps
Filename                Type        Size    Used    Priority
[email protected]:~$ ^C
To może usunąć ten nieaktualny wpis?
#10
1
Better response on post RE: Długie uruchamianie Minta po zmianie dysku błąd ACPIMożesz usunąć ten nieaktualny wpis.
Obecnie nie masz ustawionego żadnego swapa.
Przy 8GB RAM to nie powinno stanowić problemu (jeśli nie korzystasz z hibernacji), ale osobiście bym ustawił sobie w pliku lub na partycji.
https://help.ubuntu.com/community/SwapFaq


Skocz do:




Użytkownicy przeglądający ten wątek: 3 gości