Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Solved Duże obciążenie procesora w stanie bezczynności
#1
0
Witam
Zainstalowałem Linux Mint 19.1 Cinnamon 64 na laptopie. Problem polega na tym, że procesor ciągle pracuje na maxa (Intel Core 2 Duo T8300) jeden rdzeń na 100% drugi na około 50%, po chwili odwrotnie. Przy czym wg. monitora systemu uruchomione procesy zużywają tylko kilka do kilanaście %. Co więc tak obciąża procesor? Jak to naprawić?[url=https://www.notebookcheck.pl/Intel-Core-2-Duo-T8300.46264.0.html][/url]
Odpowiedz
#2
0
Pokaż przede wszystkim "specyfikację" inxi -Fxz i top.
Możliwe, że okienka chodzą w trybie renderowania programowego. Nie wyświetla system takiego komunikatu po uruchomieniu komputera?
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M; LU#586742
Odpowiedz
#3
0
Cytat:System:
 Host: geric-Studio-1735 Kernel: 4.15.0-47-generic x86_64 bits: 64
 compiler: gcc v: 7.3.0 Desktop: Cinnamon 4.0.10
 Distro: Linux Mint 19.1 Tessa base: Ubuntu 18.04 bionic
Machine:
 Type: Portable System: Dell product: Studio 1735 v: N/A serial: <filter>
 Mobo: Dell model: 0H275K serial: <filter> BIOS: Dell v: A05
 date: 12/04/2008
Battery:
 ID-1: BAT0 charge: 43.0 Wh condition: 43.0/48.8 Wh (88%)
 model: SMP DELL KM9768 status: Full
CPU:
 Topology: Dual Core model: Intel Core2 Duo T8100 bits: 64 type: MCP
 arch: Penryn rev: 6 L2 cache: 3072 KiB
 flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 8378
 Speed: 2208 MHz min/max: 1200/2101 MHz Core speeds (MHz): 1: 2204 2: 2095
Graphics:
 Device-1: AMD RV635/M86 [Mobility Radeon HD 3650] vendor: Dell
 driver: radeon v: kernel bus ID: 01:00.0
 Display: x11 server: X.Org 1.19.6 driver: ati,radeon
 unloaded: fbdev,modesetting,vesa resolution: 1440x900~61Hz
 OpenGL: renderer: AMD RV635 (DRM 2.50.0 / 4.15.0-47-generic LLVM 7.0.0)
 v: 3.3 Mesa 18.2.8 direct render: Yes
Audio:
 Device-1: Intel 82801H HD Audio vendor: Dell Studio 1735
 driver: snd_hda_intel v: kernel bus ID: 00:1b.0
 Device-2: AMD RV635 HDMI Audio [Radeon HD 3650/3730/3750] vendor: Dell
 driver: snd_hda_intel v: kernel bus ID: 01:00.1
 Sound Server: ALSA v: k4.15.0-47-generic
Network:
 Device-1: Broadcom and subsidiaries NetLink BCM5784M Gigabit Ethernet PCIe
 vendor: Dell driver: tg3 v: 3.137 port: de00 bus ID: 09:00.0
 IF: enp9s0 state: down mac: <filter>
 Device-2: Broadcom and subsidiaries BCM4322 802.11a/b/g/n Wireless LAN
 vendor: Dell driver: wl v: kernel port: de00 bus ID: 0c:00.0
 IF: wlp12s0 state: up mac: <filter>
 Device-3: Dell Wireless 370 Bluetooth Mini-card type: USB driver: btusb
 bus ID: 3-1.3:5
Drives:
 Local Storage: total: 698.66 GiB used: 284.62 GiB (40.7%)
 ID-1: /dev/sda vendor: Western Digital model: WD2500BEVT-75ZCT2
 size: 232.89 GiB
 ID-2: /dev/sdb vendor: Western Digital model: WD2500BEVT-75ZCT2
 size: 232.89 GiB
 ID-3: /dev/sdc type: USB model: ADplus SuperVer size: 232.89 GiB
Partition:
 ID-1: / size: 91.17 GiB used: 23.62 GiB (25.9%) fs: ext4 dev: /dev/sda1
 ID-2: /home size: 136.56 GiB used: 566.8 MiB (0.4%) fs: ext4
 dev: /dev/sda5
Sensors:
 System Temperatures: cpu: 78.0 C mobo: N/A
 Fan Speeds (RPM): cpu: 3306
Info:
 Processes: 265 Uptime: 1h 01m Memory: 3.85 GiB used: 1.97 GiB (51.1%)
 Init: systemd runlevel: 5 Compilers: gcc: 7.3.0 Shell: bash v: 4.4.19
 inxi: 3.0.27

Cytat:top - 18:15:17 up  1:03,  2 users,  load average: 3,03, 4,33, 4,22
Zadania:razem: 263, działających:   3, śpiących: 216, zatrzymanych:   0, zom
%CPU: 59,3 uż, 14,7 sy,  0,0 ni, 19,5 be,  5,3 io,  0,0 hi,  1,2 si,  0,0 sk
KiB RAM :  4038440 razem,   329312 wolne,  2014152 użyte,  1694976 buf/cache
KiB Swap:  2097148 razem,  2097148 wolne,        0 użyte.  1715932 dost. RAM

 PID UŻYTK.   PR  NI    WIRT    REZ    WSP S  %CPU %PAM     CZAS+ KOMENDA    
 375 root      20   0  263416 219004   2384 R  96,4  5,4  57:13.22 systemd-ud+
 437 root      20   0   45888   2976   1956 S  14,5  0,1  10:57.79 systemd-ud+
7449 geric     20   0 3035100 201828  27456 S   3,6  5,0   4:24.01 cinnamon    
 343 root      19  -1  312152 108540 107616 S   3,3  2,7   2:22.41 systemd-jo+
25635 geric     20   0 1557572 145416  99996 S   2,6  3,6   0:04.30 Web Content
3811 root      20   0  588416  45228  26788 S   2,3  1,1   2:00.66 Xorg        
1292 geric     20   0  634472  36628  27676 S   2,0  0,9   0:01.62 gnome-term+
1358 syslog    20   0  263036   3440   2076 S   1,3  0,1   0:48.48 rsyslogd    
7132 colord    20   0  319380   8436   3532 S   1,3  0,2   0:58.06 colord      
26188 geric     20   0 1658340 188524 125748 S   1,3  4,7   0:12.42 Web Content
14298 grisza    20   0  928508  10504   4664 S   1,0  0,3   0:28.45 csd-media-+
6167 root      20   0  316812   4524   3272 S   0,7  0,1   0:34.18 upowerd    
7450 geric     20   0  270152   3764   3104 S   0,7  0,1   0:22.81 gvfs-mtp-v+
9356 geric     20   0   45544   3980   3268 R   0,7  0,1   0:00.09 top        
26004 geric     20   0 1544412 126340  87452 S   0,7  3,1   0:05.08 WebExtensi+
   8 root      20   0       0      0      0 I   0,3  0,0   0:07.99 rcu_sched  
  16 root      20   0       0      0      0 S   0,3  0,0   0:05.63 ksoftirqd/1
Odpowiedz
#4
0
To jest domyślne jądro? Czy dogrywałeś jakieś nowsze?
Jeśli dogrywałeś uruchom komputer na starszym. Nie wiesz jak? Pytaj.
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M; LU#586742
Odpowiedz
#5
0
Po instalacji zrobiłem aktualizacje wg wskazówek z ekranu powitalnego i aktualizacje językowe. Dopiero zaczynam przygodę z linuxem i wszystko jest dla mnie, zwłaszcza terminologia. Jak mogę uruchomić na starszym jądrze i na jakim
\
Odpowiedz
#6
0
To może inaczej (@morfik, jakbym pisał głupoty, popraw mnie proszę Smile)

Otwórz do edycji plik 69-libmtp.rules:
Kod:
pkexec xed /lib/udev/rules.d/69-libmtp.rules

znajdź linię:
# Autoprobe vendor-specific, communication and PTP devices
ENV{ID_MTP_DEVICE}!="1", ENV{MTP_NO_PROBE}!="1", ENV{COLOR_MEASUREMENT_DEVICE}!="1", ENV{libsane_matched}!="yes", ATTR{bDeviceCl ass}=="00|02|06|ef|ff", PROGRAM="/usr/lib/udev/mtp-probe /sys$env{DEVPATH} $attr{busnum} $attr{devnum}", RESULT=="1", SYMLINK+="li bmtp-%k", ENV{ID_MTP_DEVICE}="1", ENV{ID_MEDIA_PLAYER}="1"
pewnie będzie gdzieś na końcu i zakomentuj ją:

czyli wstaw # przed ENV{ID_MTP.... żeby wyglądało tak:
#ENV{ID_MTP.... zapisz zmiany i zrestartuj komputer.

Odczekaj chwilę, bo ja nie jestem pewny tego rozwiązania.
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M; LU#586742
Odpowiedz
#7
0
OK, mędrców nie ma, to spróbuj uruchomić komputer na starszym jądrze:
- uruchamiasz komputer i trzymasz Shift do czasu, aż pokaże się menu GRUB.
- wybierasz opcje zaawansowane i uruchomienie komputera na jądrze starszym, np. 4.15.20 jeśli będzie ok. pociągniemy temat.
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M; LU#586742
Odpowiedz
#8
0
Niestety, nic to nie zmienia. Próbowałem też 4.18.0-17 ale było tak samo
Odpowiedz
#9
0
W takim razie spróbuj rozwiązania, o którym pisałem tu: https://forum.linuxmint.pl/showthread.ph...32#pid1032
Jakby coś było nie halo, można to łatwo odwrócić.
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M; LU#586742
Odpowiedz
#10
0
A jest coś w logu systemowym w ogóle? Z fusów chcecie wróżyć? Big Grin
Odpowiedz


Skocz do:




Użytkownicy przeglądający ten wątek: 1 gości