Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
LibreOffice
#1
0
Pojawiła się nowa wersja pakietu biurowego LibreOffice (teraz już to wersja 6.2.3)
Można pobrać stąd https://pl.libreoffice.org/pobieranie/
Jeśli namy starszą wersję to odinstalowujemy ją poleceniem

Kod:
sudo apt-get remove --purge libreoffice*
Rozpakowałem wszystko. Wchodzę do katalogu instalatora, katalog DEB otwieram w nim terminal i wykonuję:
Kod:
sudo dpkg -i *.deb
To samo wykonuję z przetłumaczonym interfejsem użytkownika (język polski i francuski u mnie) a następnie z "pomocą".
#2
0
W LMDE w pierwszej kolejności powinno sprawdzać backporty, instalowanie nowszych wersji pakietów jest proszeniem się o kłopoty chociażby z niespełnionymi zależnościami.

Najnowsza wersja LO w backportach to 6.1.5

Kod:
apt install -t stretch-backports libreoffice
Burble, Burble, Burble ... hahaaaaaaa Big Grin

Zasady obowiązujące na forum | Stare forum Minta R-O | Użyteczne linki
#3
0
(18-04-2019, 20:35)ciastek1981 napisał(a): W LMDE w pierwszej kolejności powinno sprawdzać backporty, instalowanie nowszych wersji pakietów jest proszeniem się o kłopoty chociażby z niespełnionymi zależnościami.

Najnowsza wersja LO w backportach to 6.1.5

Kod:
apt install -t stretch-backports libreoffice

W Mint sa dwa sposoby
1. Przez menager oprogramowania - biuro
[Obrazek: BNV0VgWl.png]
2. Menager oprogramowania - Flatpak (ten u mnie zastosowany)
[Obrazek: OWn5WIKl.png]
i instalujemy LibreOffice (dostępna wersja 6.2.2) i u mnie działa OK
[Obrazek: argbPU8l.png]
#4
0
To, że twórcy LMDE mają szalone pomysły to wiadomo nie od dziś. Umieszczenie Flatpaka w MO wersji bazującej na Debianie to jeden z nich.

Flatpak to jest pomyłka jeżeli chodzi o bezpieczeństwo systemu. Nikt tego nie łata.

Jeżeli ktoś nie chce używać LMDE (czyli bazującej na Debianie) to należy sobie wyrobić pewne nawyki, a przede wszystkim nie robić Frankena tzn. nie mieszać różnych systemów paczek. Debian tego nie lubi i tyle. Jeżeli paczka ma być bezpieczna i spełniać zależności to NIE powinna być instalowana spoza repozytoriów Debiana. Pomijam paczki związane z konfiguracją LMDE dostarczone przez devów Minta.
Burble, Burble, Burble ... hahaaaaaaa Big Grin

Zasady obowiązujące na forum | Stare forum Minta R-O | Użyteczne linki
#5
0
[Obrazek: HCwbm7gl.png]
a następnie
[Obrazek: b7zufd0l.png]
i na koniec
[Obrazek: pvyoJAfl.png]

Co pewien czas powinniśmy sprawdzać, bo nie zawsze (sprawdziłem) kompletne paczki językowe.
#6
0
Na każdy temat w jednym wątku Big Grin

Jeżeli proponujesz instalację z Flatpaka w L M D E to powinieneś pokazać jak zaktualizować paczkę do najnowszej dostępnej z flagą   -t .

Dlaczego? Tu trzeba prześledzić cała historię Flatpak i zobaczyć co i jak z którą wersją paczki jest nie tak. 

Poleganie tylko na tym co dostarczają opiekunowie paczki w tym wypadku jest proszeniem się o problemy.

PS https://security-tracker.debian.org/trac...2019-10063
Burble, Burble, Burble ... hahaaaaaaa Big Grin

Zasady obowiązujące na forum | Stare forum Minta R-O | Użyteczne linki
#7
0
Ja sądzę, że lcoyote od początku chodziło o minta, tylko działy się mu pomyliły, dlatego przeniosłem wsio do offtopic do czasu wyklarowania się wizji autora Big Grin
#8
0
(20-04-2019, 07:20)ciastek1981 napisał(a): Na każdy temat w jednym wątku Big Grin
To miało być w innym wątku. Podczas "edycji" widać temat "Aktualizacja paczek językowych"
[Obrazek: rjd6LWZl.png]
Ale oprócz "edycji" nie mam możliwości tego przenieść do właściwego działu Linux Mint Debian › System jak planowałem. I tam on na początku był a teraz połączony z Libreoffice
#9
0
Tylko dlaczego chcesz to przenieść do LMDE, skoro piszesz o Mincie?
#10
0
(20-04-2019, 20:55)dedito napisał(a): Tylko dlaczego chcesz to przenieść do LMDE, skoro piszesz o Mincie?

Już zgłosiłem przeniesienie do "Wsparcie" - "System"


Skocz do:




Użytkownicy przeglądający ten wątek: 1 gości