Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Ubuntu 21.10, 20.04. Głuche wyjście brak dźwięku na głośnikach i mikrofonie
#1
0
Witam na każdym linuksie na którym próbowałem jest ten sam problem , szukam rozwiązania dla ubuntu  lub minta bo te systemy najbardziej lubię, laptop jest nowy sprawny technicznie. W informacji o karcie dźwiękowej jest informacja o głuchym wyjściu , w miejscu mikrofonu nie ma nic. Szukałem wiele sposobów, ale albo nie rozumiem jak to zrobić albo nie działa. Więcej info o laptopie itp wklejam na dole . bezprzewodowo podłączone głośniki przez bt działają i odtwarzają muzykę

Kod:
System:
Kernel: 5.13.0-25-generic x86_64 bits: 64 compiler: gcc v: 11.2.0
Desktop: GNOME 40.5 tk: GTK 3.24.30 wm: gnome-shell dm: GDM3
Distro: Ubuntu 21.10 (Impish Indri)
Machine:
Type: Laptop System: HUAWEI product: NBLB-WAX9N v: M1010 serial: <filter>
Mobo: HUAWEI model: NBLB-WAX9N-PCB-B2 v: M1010 serial: <filter>
UEFI: HUAWEI v: 1.35 date: 06/23/2021
Battery:
ID-1: BAT1 charge: 41.0 Wh (77.2%) condition: 53.1/54.9 Wh (96.7%)
volts: 8.2 min: 7.6 model: Desay HB4692Z9ECW-22T serial: <filter>
status: Discharging
CPU:
Info: Dual Core model: Intel Core i3-10110U bits: 64 type: MT MCP
arch: Kaby Lake note: check rev: C cache: L2: 4 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 20799
Speed: 900 MHz min/max: 400/4100 MHz Core speeds (MHz): 1: 900 2: 900
3: 900 4: 900
Graphics:
Device-1: Intel CometLake-U GT2 [UHD Graphics] vendor: QUANTA driver: i915
v: kernel bus-ID: 00:02.0 chip-ID: 8086:9b41
Device-2: IMC Networks HD Camera type: USB driver: uvcvideo bus-ID: 1-6:3
chip-ID: 13d3:5476
Display: wayland server: X.Org 1.21.1.2 compositor: gnome-shell driver:
loaded: i915 note: n/a (using device driver) resolution: 1920x1080~60Hz
s-dpi: 96
OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.2.2
direct render: Yes
Audio:
Device-1: Intel Comet Lake PCH-LP cAVS vendor: QUANTA
driver: sof-audio-pci-intel-cnl bus-ID: 00:1f.3 chip-ID: 8086:02c8
Sound Server-1: ALSA v: k5.13.0-25-generic running: yes
Sound Server-2: PulseAudio v: 15.0 running: yes
Sound Server-3: PipeWire v: 0.3.32 running: yes
Network:
Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi v: kernel
port: 3000 bus-ID: 00:14.3 chip-ID: 8086:02f0
IF: wlp0s20f3 state: up mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
driver: btusb v: 0.8 bus-ID: 1-10:4 chip-ID: 8087:0aaa
Report: hciconfig ID: hci0 rfk-id: 1 state: up address: <filter> bt-v: 3.0
lmp-v: 5.2 sub-v: 27a4
Drives:
Local Storage: total: 238.47 GiB used: 10.28 GiB (4.3%)
ID-1: /dev/nvme0n1 vendor: Toshiba model: N/A size: 238.47 GiB
speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 37.9 C
Partition:
ID-1: / size: 233.18 GiB used: 10.28 GiB (4.4%) fs: ext4
dev: /dev/nvme0n1p2
ID-2: /boot/efi size: 511 MiB used: 5.2 MiB (1.0%) fs: vfat
dev: /dev/nvme0n1p1
Swap:
ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) priority: -2
file: /swapfile
Sensors:
System Temperatures: cpu: 45.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 256 Uptime: 4m Memory: 7.51 GiB used: 1.51 GiB (20.0%)
Init: systemd v: 248 runlevel: 5 Compilers: gcc: N/A Packages: 1716
apt: 1708 snap: 8 Shell: Bash v: 5.1.8 running-in: gnome-terminal
inxi: 3.3.06
Odpowiedz
#2
0
Aż trzy serwery dźwięku.
Coś to może mieszać.
Cytat:Audio:
Device-1: Intel Comet Lake PCH-LP cAVS vendor: QUANTA
driver: sof-audio-pci-intel-cnl bus-ID: 00:1f.3 chip-ID: 8086:02c8
Sound Server-1: ALSA v: k5.13.0-25-generic running: yes
Sound Server-2: PulseAudio v: 15.0 running: yes
Sound Server-3: PipeWire v: 0.3.32 running: yes
Ogólnie widać w Internecie podobne zgłoszenia dla tej karty.
Wrzuć jeszcze wynik skryptu Alsa oraz dmesg | grep -i sof
Odpowiedz
#3
0
Się wetnę... sorki, ale przerabiałem to wczoraj wieczorem Smile

Kod:
systemctl --user unmask pulseaudio

systemctl --user --now enable pulseaudio.service pulseaudio.socket
i restart komputera.

Czyli przywrócenie PulseAudio zamiast Pipewire powinno załatwić sprawę.
Odpowiedz
#4
0
(13-01-2022, 12:08)dedito napisał(a): Aż trzy serwery dźwięku.
Coś to może mieszać.
Cytat:Audio:
Device-1: Intel Comet Lake PCH-LP cAVS vendor: QUANTA
driver: sof-audio-pci-intel-cnl bus-ID: 00:1f.3 chip-ID: 8086:02c8
Sound Server-1: ALSA v: k5.13.0-25-generic running: yes
Sound Server-2: PulseAudio v: 15.0 running: yes
Sound Server-3: PipeWire v: 0.3.32 running: yes
Ogólnie widać w Internecie podobne zgłoszenia dla tej karty.
Wrzuć jeszcze wynik skryptu Alsa oraz dmesg | grep -i sof
Kod:
0.761735] pps_core: Software ver. 5.3.6 - Copyright 2005-2007 Rodolfo Giometti <[email protected]>
[    0.822421] PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
[    0.822423] software IO TLB: mapped [mem 0x000000008938b000-0x000000008d38b000] (64MB)
[    2.550150] snd_hda_intel 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
[    2.656854] sof-audio-pci-intel-cnl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
[    2.656877] sof-audio-pci-intel-cnl 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
[    2.656892] sof-audio-pci-intel-cnl 0000:00:1f.3: enabling device (0000 -> 0002)
[    2.657077] sof-audio-pci-intel-cnl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if 0x040100
[    2.660420] sof-audio-pci-intel-cnl 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    2.667712] sof-audio-pci-intel-cnl 0000:00:1f.3: use msi interrupt mode
[    2.689468] sof-audio-pci-intel-cnl 0000:00:1f.3: hda codecs found, mask 4
[    2.689472] sof-audio-pci-intel-cnl 0000:00:1f.3: using HDA machine driver skl_hda_dsp_generic now
[    2.689477] sof-audio-pci-intel-cnl 0000:00:1f.3: DMICs detected in NHLT tables: 2
[    2.783214] sof-audio-pci-intel-cnl 0000:00:1f.3: Firmware info: version 1:6:0-18fab
[    2.783220] sof-audio-pci-intel-cnl 0000:00:1f.3: Firmware: ABI 3:17:0 Kernel ABI 3:18:0
[    2.790940] sof-audio-pci-intel-cnl 0000:00:1f.3: Topology: ABI 3:17:0 Kernel ABI 3:18:0
[    2.800804] sof-audio-pci-intel-cnl 0000:00:1f.3: ASoC: Parent card not yet available, widget card binding deferred
[    2.825998] input: sof-hda-dsp HDMI/DP,pcm=1 as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0/input13
[    2.826115] input: sof-hda-dsp HDMI/DP,pcm=2 as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0/input14
[    2.826357] input: sof-hda-dsp HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0/input15
[    6.228520] audit: type=1326 audit(1642083534.711:46): auid=1000 uid=1000 gid=1000 ses=2 subj=snap.snap-store.ubuntu-software pid=1189 comm="snap-store" exe="/snap/snap-store/558/usr/bin/snap-store" sig=0 arch=c000003e syscall=314 compat=0 ip=0x7f562fe3889d code=0x50000
[    7.817487] audit: type=1107 audit(1642083536.299:48): pid=588 uid=103 auid=4294967295 ses=4294967295 subj=unconfined msg='apparmor="DENIED" operation="dbus_method_call"  bus="system" path="/org/freedesktop/PolicyKit1/Authority" interface="org.freedesktop.DBus.Properties" member="GetAll" mask="send" name=":1.7" pid=1189 label="snap.snap-store.ubuntu-software" peer_pid=603 peer_label="unconfined"
[    7.818167] audit: type=1107 audit(1642083536.303:49): pid=588 uid=103 auid=4294967295 ses=4294967295 subj=unconfined msg='apparmor="DENIED" operation="dbus_method_call"  bus="system" path="/org/freedesktop/PolicyKit1/Authority" interface="org.freedesktop.PolicyKit1.Authority" member="CheckAuthorization" mask="send" name=":1.7" pid=1189 label="snap.snap-store.ubuntu-software" peer_pid=603 peer_label="unconfined"
[    7.842047] audit: type=1107 audit(1642083536.327:50): pid=588 uid=103 auid=4294967295 ses=4294967295 subj=unconfined msg='apparmor="DENIED" operation="dbus_method_call"  bus="system" path="/org/freedesktop/PolicyKit1/Authority" interface="org.freedesktop.DBus.Properties" member="GetAll" mask="send" name=":1.7" pid=1189 label="snap.snap-store.ubuntu-software" peer_pid=603 peer_label="unconfined"
[    7.842313] audit: type=1107 audit(1642083536.327:51): pid=588 uid=103 auid=4294967295 ses=4294967295 subj=unconfined msg='apparmor="DENIED" operation="dbus_method_call"  bus="system" path="/org/freedesktop/PolicyKit1/Authority" interface="org.freedesktop.PolicyKit1.Authority" member="CheckAuthorization" mask="send" name=":1.7" pid=1189 label="snap.snap-store.ubuntu-software" peer_pid=603 peer_label="unconfined"
[    8.185995] audit: type=1400 audit(1642083536.671:52): apparmor="DENIED" operation="open" profile="snap.snap-store.ubuntu-software" name="/etc/PackageKit/Vendor.conf" pid=1189 comm="snap-store" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0

Dodano po pewnym czasie:
(13-01-2022, 13:03)yahoob3 napisał(a): Się wetnę... sorki, ale przerabiałem to wczoraj wieczorem Smile

Kod:
systemctl --user unmask pulseaudio

systemctl --user --now enable pulseaudio.service pulseaudio.socket
i restart komputera.

Czyli przywrócenie PulseAudio zamiast Pipewire powinno załatwić sprawę.

niestety te komendy nic nie pomogły Sad
Odpowiedz
#5
0
Hmmm... na głuche wyjście u mnie pomaga też pulseaudio -k.
Co to za środowisko graficzne? Pytam bo widziałem obrazek na ubuntu.pl...

Jak instalowałeś Pipewire? Może trzeba odistalować, podobnie "pavucontrol"...(?)
Odpowiedz
#6
0
Wrzuć jeszcze wynik skryptu Alsa
Odpowiedz
#7
0
(13-01-2022, 19:27)dedito napisał(a): Wrzuć jeszcze wynik skryptu Alsa
Jaką konkretnie trochę się nie znam Wink

Dodano po pewnym czasie:
(13-01-2022, 19:00)yahoob3 napisał(a): Hmmm... na głuche wyjście u mnie pomaga też pulseaudio -k.
Co to za środowisko graficzne? Pytam bo widziałem obrazek na ubuntu.pl...

Jak instalowałeś Pipewire? Może trzeba odistalować,  podobnie "pavucontrol"...(?)
Pipewire nie instalowałem to goły ubuntu nic tu nie instalowałem poza chrome

Pulseaudio - k nie pomaga
Odpowiedz
#8
0
Przeczytaj zasady forum to się poznaszWink
Odpowiedz
#9
0
Odpowiedz
#10
0
W jednym z wątków, gdzie występował podsystem QUANTA, na kilka przypadłości pomogła instalacja kernela z serii 5.14. Może warto spróbować?
Odpowiedz


Skocz do:




Użytkownicy przeglądający ten wątek: 1 gości