Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Nie ma możliwości zmiany rozdzielczości ekranu
#1
0
Instalowałem system na nowo, więc pobrałem najnowszą wersję. Po instalacji nie mogę zmienić rozdzielczości ekranu. Jest tylko jedna, chyba najwyższa.
Poprzednio nie było tego problemu, ale zainstalowana była wcześniejsza wersja, potem aktualizowałem do 20.3.

Kod:
[email protected]:~$ inxi -CGM
Machine:  Type: Laptop System: Acer product: Aspire A515-56 v: V1.08 serial: <superuser/root required>
          Mobo: TGL model: Iris_TL v: V1.08 serial: <superuser/root required> UEFI: Insyde v: 1.08 date: 01/22/2021
CPU:      Topology: Quad Core model: 11th Gen Intel Core i5-1135G7 bits: 64 type: MT MCP L2 cache: 8192 KiB
          Speed: 1454 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 1469 2: 1494 3: 1438 4: 1408 5: 1473 6: 1470 7: 1484
          8: 1466
Graphics:  Device-1: Intel driver: N/A
          Display: x11 server: X.Org 1.20.13 driver: fbdev unloaded: modesetting,vesa resolution: 1920x1080~77Hz
          OpenGL: renderer: llvmpipe (LLVM 12.0.0 256 bits) v: 4.5 Mesa 21.2.6

Wygląda na to, że nie ma sterownika. Może wersja 20.2 miała ten sterownik i zachowała go podczas aktualizacji?
Najpierw zainstalowałem Cynamona i tam po starcie pojawiał się komunikat o problemach z grafiką. Teraz mam Mate. Nie ma żadnego komunikatu, ale problem ten sam. Zaraz będę próbował z Peppermintem, może się uda.

Po instalacji Peppermint rozdzielczości można było zmieniać. Instaluję teraz po kolei coraz niższe wersje Minta, a to Cynamona, a to Mate. Za chwilę będę próbował z Mate 20.1. Komputer kupowałem we wrześniu, chyba najnowsza wersja wtedy nie była niższa niż 20.1?

Dodano po pewnym czasie:
Zainstalowałem Debiana 11. Podczas instalacji pojawił się komunikat, że brakuje pliku intel/sof/sof-tgl.ri. Instalator spytał, czy chcę go zainstalować z nośnika zewnętrznego. Oczywiście go nie miałem i puściłem instalację dalej. Niemniej jednak problemu z rozdzielczościami nie ma. Nawet mi się nowy system podoba (oczywiście na razie "organoleptycznie"). Nie wiem, o co biega z Mintem. Jestem do niego przyzwyczajony, ale nie będę wałczył za wszelką cenę. Jestem tylko skromnym użytkownikiem, który chce, żeby komputer po prostu działał. Nie mam czasu na rozkminianie linuxa do szpiku kości, choć żałuję, bo jest to wszystko bardzo ciekawe i chętnie bym sobie przy tym grzebał. Problem, który zgłosiłem jest najwidoczniej nietypowy, bo nikt nie komentuje. No cóż, popracuję sobie na Debianie. Niedługo ma się pojawić wersja stabilna Minta LMDE 5, więc na pewno będę próbował. Czwórkę zainstalowałem na drugim kompie, ale wyskakiwały jakieś błędy przy aktualizacji, nawet nie chciało mi się tego rozkminiać.
#2
0
Zasadniczo, instalacja innego systemu to obejście problemu, a nie jego rozwiązanie Smile
Coś szukałem w temacie, ale nic sensownego nie znalazłem. Na razie nie zamykałbym wątku. Może "ktoś, coś...".
#3
0
W sumie Debian jest całkiem spoko, choć mam z nim ten sam problem, który dzięki temu forum opanowałem w Mincie: nie działa wifi. Rozwiązaniem okazała się instalacja jądra min. 5.15. Nie wiem tylko, czy w Debianie robi się to tak samo i czy korzysta się z tych samych jąder.
#4
0
Debian ma swoje jądra (paczki), ale zasada postępowania jest analogiczna.
#5
1
Better response on post RE: Nie ma możliwości zmiany rozdzielczości ekranuHmm nie wiem czy to pomoże bo u mnie mam tak że ten menedżer sterowników z minta wykrywa mi nie prawidłowy sterownik i muszę sam instalować inna wersję, natomiast na ubuntu dobrze mi wykrywa sterownik. Więc Zrobił bym botowalne ubuntu z pendrive i po uruchomieniu wszedł do tego menu gdzie znajduje dostępne sterowniki. I spróbował jakiś z nich zainstalować w mincie
#6
1
Better response on post RE: Nie ma możliwości zmiany rozdzielczości ekranuMiałem ten sam problem z dystrybucjami Linux blisko 10 lat temu, wtedy edytowałem ręcznie plik konfiguracyjny xorg.conf (wewnątrz Section "Screen"),
są też narzędzia które to robią automatycznie, np. nvidia-xconfig dla kart graficznych nvidia lub Xorg -configure natywnie w Xorg...

przykładowe linki
https://kodi.wiki/view/Archive:Configuri..._xorg.conf
https://forums.freebsd.org/threads/how-t...onf.55198/

zacznij od tego:
https://www.cyberciti.biz/faq/howto-linu...-xorg-x11/
#7
0
Dzięki za podpowiedzi. Niestety, mają one sens pod warunkiem, że miałbym zainstalowanego Minta. Tymczasowo jednak pracuję na Debianie. Korzystając z okazji robię porządki w plikach, co zajmie mi jeszcze trochę czasu. Będę jednak chciał powrócić do Minta, bo najbardziej mi odpowiada. Próbowałem teraz kilku dystrybucji, ale żadna mi do końca nie podpasowała. Zastanawia mnie jednak cały czas, jak to możliwe, że po kupnie kompa we wrześniu wszystko było OK, a teraz nie.
#8
1
Better response on post RE: Nie ma możliwości zmiany rozdzielczości ekranuU Ciebie wszystko rozbija się o to:
Kod:
device-1: Intel driver: N/A
Nie wiedzieć czemu, nie instaluje się sterownik (moduł w kernelu) do Intela.
Nowsze jajo? Who knows? Wink
inxi -Fxz czyli full info wskazane.
#9
0
Też na to wpadłem, wyobraź sobie Smile

Kod:
[email protected]:~$ inxi -Fxz
System:
  Kernel: 5.10.0-12-amd64 x86_64 bits: 64 compiler: gcc v: 10.2.1
  Desktop: Cinnamon 4.8.6 Distro: Debian GNU/Linux 11 (bullseye)
Machine:
  Type: Laptop System: Acer product: Aspire A515-56 v: V1.08
  serial: <filter>
  Mobo: TGL model: Iris_TL v: V1.08 serial: <filter> UEFI: Insyde v: 1.08
  date: 01/22/2021
Battery:
  ID-1: BAT1 charge: 25.7 Wh condition: 48.5/53.2 Wh (91%)
  model: COSMX AP20CBL status: Discharging
CPU:
  Info: Quad Core model: 11th Gen Intel Core i5-1135G7 bits: 64 type: MT MCP
  arch: Tiger Lake rev: 1 L2 cache: 8 MiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  bogomips: 38707
  Speed: 1282 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 1282 2: 1295
  3: 1294 4: 1297 5: 1250 6: 1297 7: 1298 8: 1219
Graphics:
  Device-1: Intel TigerLake GT2 [Iris Xe Graphics]
  vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 0000:00:02.0
  Device-2: Quanta HD User Facing type: USB driver: uvcvideo bus ID: 1-8:3
  Display: x11 server: X.Org 1.20.11 driver: loaded: modesetting
  unloaded: fbdev,vesa resolution: 1440x810~60Hz
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 20.3.5
  direct render: Yes
Audio:
  Device-1: Intel Tiger Lake-LP Smart Sound Audio
  vendor: Acer Incorporated ALI driver: sof-audio-pci bus ID: 0000:00:1f.3
  Sound Server: ALSA v: k5.10.0-12-amd64
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 3000
  bus ID: 0000:01:00.0
  IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-2: MEDIATEK vendor: Lite-On driver: N/A port: 3000
  bus ID: 0000:02:00.0
Bluetooth:
  Device-1: Lite-On Wireless_Device type: USB driver: btusb v: 0.8
  bus ID: 1-10:4
  Report: ID: hci0 state: down address: <filter>
RAID:
  Hardware-1: Intel Volume Management Device NVMe RAID Controller
  driver: vmd v: 0.6 bus ID: 0000:00:0e.0
Drives:
  Local Storage: total: 476.94 GiB used: 274.22 GiB (57.5%)
  ID-1: /dev/nvme0n1 vendor: SK Hynix model: HFM512GDJTNI-82A0A
  size: 476.94 GiB temp: 42.9 C
Partition:
  ID-1: / size: 459.43 GiB used: 274.21 GiB (59.7%) fs: ext4
  dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 3.4 MiB (1.1%) fs: vfat
  dev: /dev/nvme0n1p1
Swap:
  ID-1: swap-1 type: partition size: 8.8 GiB used: 1.2 MiB (0.0%)
  dev: /dev/nvme0n1p3
Sensors:
  System Temperatures: cpu: 27.8 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 242 Uptime: 7h 42m Memory: 7.57 GiB used: 2.21 GiB (29.1%)
  Init: systemd runlevel: 5 Compilers: gcc: 10.2.1 Packages: 2711
  Shell: Bash v: 5.1.4 inxi: 3.3.01
[email protected]:~$

Dodano po pewnym czasie:
Ściągnąłem dzisiaj LMDE5, jest już opublikowana. Wersja live startuje (4 nie startowała) i mam dostępne wszystkie rozdzielczości ekranu. Niestety, jądro jest w wersji 5.10. Żeby mieć obsługę wifi, musiałbym mieć jądro minimum 5.14. W "zwykłym" Mincie instalowałem jądra ze strony https://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D, no ale z wrodzoną sobie inteligencją domyślam się, że, chociaż paczki mają rozszerzenie .deb, pewnie nie można ich stosować w LMDE.
Podpowie ktoś, czy są nowsze jądra i jak je instalować?
#10
0
Weź z backportów lub liquorixa.

https://backports.debian.org/
https://liquorix.net/


Skocz do:




Użytkownicy przeglądający ten wątek: 2 gości