Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Utrata danych na dysku zewnętrznym
#1
0
Cześć!

Jakiś czas temu na laptopie roboczym wysypał mi się Windows, którego dotychczas używałem. Postanowiłem odzyskać pliki z dysku, więc ściągnąłem linuxa, zainstalowałem na pendrivie, odpaliłem na laptopie przez USB - calłkiem standardowo. Ucieszyłem się, że wszystko ciągle mam (obawiałem się problemu z dyskiem wewnętrznym), podłączyłem dysk zewnętrzny WD 750GB żeby przerzucić pliki.... I nic. Po jakichś 5 minutach, gdy na drugim laptopie szukałem rozwiązania problemu (dlaczego linux nie znajduje dysku) pojawił się. Tylko, że nie ma na nim absolutnie nic poza ikonką WD, i kilkoma śmieciowymi plikami (autorun, demo dysku, jakiś pdf).

Tutaj pojawia się pytanie - czy to możliwe żebym przez przypadek, podłączając dysk do laptopa sfomratował go, albo w jakiś sposób ukrył pliki? Był to pierwszy zewnętrzny sprzęt który w ogóle podłączyłem (nie sprawdzając przedtem czy cokolwiek na nim jest). Z tego co mi wiadomo była tam kopia zapasowa właściciela dysku (dokumenty, zdjęcia, wideo itd) więc boję się cokolwiek nadapisać żeby nie stracić możliwości odzyskania plików. Próbowałem to zrobić na Windowsie za pomocą Photorec i jedyne co znajduje to właśnie wymienione wyżej pliki plus około 20 innych .txt z dziwnymi znakami po odpaleniu (ewidentnie wygenerowane). Windows pokazuje, że dysk jest niemal pusty (zajęte ok. 200MB).

Dodam, że sprawdzałem i w przypadku podłączenia zwykłego pendriva nic nie zostaje usunięte (i tak chyba być powinno :p), a odzyskiwanie z niego plików na windowsie działa poprawnie. Normalnie uznałbym, że pomyliłem dyski i tak naprawdę był pusty, ale ten jest akurat podpisany. Na dodatek nie mój więc muszę być ostrożny

[EDIT] Właściciel dysku sam mi go porzyczył i ciągle utrzymuje, że nie był pusty. Nie wziąłem go bez zgody Tongue
Odpowiedz
#2
0
Cześć

To forum techniczne a nie dochodzeniówka policji. Pochodzenie dysku jest bez znaczenia, moze być kradziony - to Twoja sprawa.

Wracając do meritum sprawy, mało prawdopodobne abyś skasował dane. A nawet jeśli - to nie koniec świata.

Podłącz dysk i zrzuc kilka wyników:
To aby nam się sprawniej pracowało:
Kod:
sudo apt-get install pastebinit


Kod:
sudo fdisk -l|pastebinit
dmesg|pastebinit
lsblk|pastebinit
I wklej linki.
Odpowiedz
#3
0
Odpowiedz
#4
0
W tych wynikach widać, że └─sdd1 8:49 0 698.6G 0 part /media/mint/Elements musi być tym dyskiem 750GB.
Wrzuć jeszcze wynik df -h
Odpowiedz
#5
0
Przepraszam, ze tak dlugo ale dysk bardzo dlugo sie wykrywa. Dodam, ze po chwili znika i znow trzeba kombinowac.


Kod:
[email protected]:~$ df -h
Filesystem      Size  Used Avail Use% Mounted on
udev            1.4G    0  1.4G  0% /dev
tmpfs          289M  1.4M  288M  1% /run
/dev/sdb1      7.5G  1.9G  5.7G  25% /cdrom
/dev/loop0      1.8G  1.8G    0 100% /rofs
/cow            1.5G  407M  1.1G  29% /
tmpfs          1.5G  35M  1.4G  3% /dev/shm
tmpfs          5.0M  4.0K  5.0M  1% /run/lock
tmpfs          1.5G    0  1.5G  0% /sys/fs/cgroup
tmpfs          1.5G  580K  1.5G  1% /tmp
tmpfs          289M  52K  289M  1% /run/user/999
/dev/sda2        49G  43G  6.1G  88% /media/mint/5256255856253DDB
/dev/sda3        49G  47G  2.2G  96% /media/mint/aplikacje
/dev/sda4      201G  114G  88G  57% /media/mint/dane
/dev/sda1      100M  25M  76M  25% /media/mint/Zastrzeżone przez system
/dev/sdc1      699G  186M  699G  1% /media/mint/Elements


200GB i 50GB x 2 to sa partycje dysku wewnetrznego (cala partycja "dane" jest do skopiowania), jedna z 50tek - systemowa
Elements to WD

Używaj znaczników kodu
Odpowiedz
#6
0
Problem z długim wykrywaniem jest raczej w samym systemie, co sugeruje zaspamowany wynik dmesg
intel ips 0000:00:1f.6: ME failed to update for more than 1s, likely hung
W każdym razie dysk WD ma zajętość na poziomie 186MB, więc "coś" tam jest.
Więc bazując na znalezionym rozwiązaniu, być może to uzdrowi system
Cytat:1. add intel_ips to the blacklist
blacklist intel_ips ==> to /etc/modprobe.d/blacklist.conf
2. add i915 and intel_ips to /etc/modules
i915/nintel_ips ==> to /etc/modules
and then reboot your computer,
Odpowiedz
#7
0
Linux nawet nie jest zainstalowany na dobre, za kazdym razem odpala sie z pendrive'a i bootuje na nowo - nie moge wgrac go na dysk bo strace dane, a na WD boje sie skopiowac zeby nie nadpisac co uniemozliwi ich odzyskanie. Tylko, ze nic odzyskac sie z tego nie chce. Jesli mi sie nie uda oddam do jakiegos profesjonalnego "odzyskiwacza", ale zwykle robilem to sam wiec nie wiem czemu tym razem sie nie da. Dysk byl uzywany przez 2 lata, wiec powinienem odzyskac cokolwiek - jakies stare teksty, dokumenty, zdjecia. A nie odzyskuje sie nic wartosciowego (wyzej wspomnniane pliki), jakby zostal calkiem wyzerowany albo jakby byl calkiem nowy.

Inna sprawa, ze kopia zapasowa ktora wlasciciel tam mial zajmowala zdecydowanie wiecej niz 200MB. Nie wiem czym to 200MB jest, mozliwe ze m. in. tym, czego szukam ale powinno byc zdecydowanie wiecej.
Odpowiedz
#8
0
To możesz wywalić ten moduł na działającym systemie sudo modprobe -r intel_ips
Ewentualnie użyj jakiegoś innego systemu, np. Knoppix.
Na sda widać, że jest dużo danych.
Odpowiedz


Skocz do:




Użytkownicy przeglądający ten wątek: 2 gości