Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Solved Nvidia Prime - Setup
#1
0
Cześć, 
chciałbym prawidłowo zainstalować nvidie prime na laptopie, który ma dwie karty graficzne celem manualnego przełączania się między nimi. Jako, że jestem w temacie linuxów zupełnie zielony, chciałbym zwrócić się do Was z prośbą o pomoc w instalacji i ewentualnej konfiguracji tego programu. Pomimo wielu starań z mojej strony, nie jestem w stanie poprawnie przeprowadzić instalacji [i zazwyczaj kończy się ona reinstalacją całego systemu]. Z góry dziękuję za ewentualną pomoc. Laptok to https://www.x-kom.pl/p/483726-notebook-l...x1060.html
#2
0
Wszystko masz tutaj --> https://forum.linuxmint.pl/showthread.php?tid=183

z resztą nie widzę powodu aby zmienić gdyż GTX1060 jest lepsze i wydajniejsze od integry

zwłaszcza że w ustawieniach grafiki masz taką opcję jak zmianę karty (każda zmiana wymaga zalogowania się ponownie)
[Obrazek: NixuN.png]
#3
0
Potrzeba jest, ponieważ gtx w ogóle nie działa w obecnej konfiguracji. Nawet gdyby działał, to ze względu na baterię i tak musiałbym przełączać na intela. Podlinkowaną stronę sprawdzałem jeszcze przed założeniem tu konta -> nic co by mi pomogło tam nie znalazłem.  Docelowo szukam człowieka który opisałby proces instalacji prime'a; jak wspominałem, próbowałem wielokrotnie i kończyło się to zepsutym systemem. Obecnie mam względnie świeżego i zaktualizowanego minta, który jako-tako działa, dlatego chciałbym to wykorzystać zanim znów coś zepsuję.
#4
0
Wpisz w terminalu 
Kod:
inxi -Fxz
Wstaw cały wynik tutaj
#5
0
(30-07-2019, 03:25)Nicekovsky napisał(a): Wpisz w terminalu 
Kod:
inxi -Fxz
Wstaw cały wynik tutaj
Kod:
System:    Host: nvidiatychuju3 Kernel: 5.0.0-20-generic x86_64 bits: 64 compiler: gcc v: 7.4.0 Desktop: MATE 1.20.1
          Distro: Linux Mint 19.1 Tessa base: Ubuntu 18.04 bionic
Machine:  Type: Laptop System: LENOVO product: 81LB v: Lenovo Legion Y530-15ICH-1060 serial: <filter>
          Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <filter> UEFI: LENOVO v: 9VCN15WW date: 11/08/2018
Battery:  ID-1: BAT0 charge: 57.2 Wh condition: 57.2/57.0 Wh (100%) model: SMP L17M3PG2 status: Full
CPU:      Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake rev: A
          L2 cache: 9216 KiB
          flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 52992
          Speed: 1001 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 951 2: 958 3: 1001 4: 1000 5: 960 6: 995
          7: 993 8: 955 9: 956 10: 955 11: 962 12: 953
Graphics:  Device-1: Intel vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0
          Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] vendor: Lenovo driver: nouveau v: kernel
          bus ID: 01:00.0
          Display: x11 server: X.Org 1.19.6 driver: modesetting,nouveau unloaded: fbdev,vesa
          resolution: 1920x1080~60Hz
          OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) v: 4.5 Mesa 19.0.2
          direct render: Yes
Audio:    Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:1f.3
          Sound Server: ALSA v: k5.0.0-20-generic
Network:  Device-1: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi v: kernel port: 4000
          bus ID: 07:00.0
          IF: wlp7s0 state: up mac: <filter>
          Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169
          v: kernel port: 3000 bus ID: 08:00.0
          IF: enp8s0 state: down mac: <filter>
Drives:    Local Storage: total: 1.14 TiB used: 84.84 GiB (7.3%)
          ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN520 SDAPMUW-256G-1101 size: 238.47 GiB
          ID-2: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB temp: 27 C
Partition: ID-1: / size: 27.38 GiB used: 9.69 GiB (35.4%) fs: ext4 dev: /dev/nvme0n1p6
          ID-2: /boot size: 269.9 MiB used: 161.8 MiB (59.9%) fs: ext4 dev: /dev/nvme0n1p7
          ID-3: /home size: 83.09 GiB used: 37.48 GiB (45.1%) fs: ext4 dev: /dev/nvme0n1p8
Sensors:  System Temperatures: cpu: 34.0 C mobo: N/A gpu: nouveau temp: 33 C
          Fan Speeds (RPM): N/A
Info:      Processes: 355 Uptime: 9h 26m Memory: 15.54 GiB used: 895.1 MiB (5.6%) Init: systemd runlevel: 5
          Compilers: gcc: 7.4.0 clang: 6.0.0-1ubuntu2 Shell: bash v: 4.4.20 inxi: 3.0.27
#6
0
Poprosze o wynik:
Kod:
lspci -nn
nvidia prime powinna bez wiekszych problemów zadziałac.
#7
0
(30-07-2019, 13:59)Ulvhedin napisał(a): Poprosze o wynik:
Kod:
lspci -nn
nvidia prime powinna bez wiekszych problemów zadziałac.
Kod:
00:00.0 Host bridge [0600]: Intel Corporation 8th Gen Core Processor Host Bridge/DRAM Registers [8086:3ec4] (rev 07)
00:01.0 PCI bridge [0604]: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16) [8086:1901] (rev 07)
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:3e9b]
00:04.0 Signal processing controller [1180]: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem [8086:1903] (rev 07)
00:08.0 System peripheral [0880]: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th Gen Core Processor Gaussian Mixture Model [8086:1911]
00:12.0 Signal processing controller [1180]: Intel Corporation Cannon Lake PCH Thermal Controller [8086:a379] (rev 10)
00:14.0 USB controller [0c03]: Intel Corporation Cannon Lake PCH USB 3.1 xHCI Host Controller [8086:a36d] (rev 10)
00:14.2 RAM memory [0500]: Intel Corporation Cannon Lake PCH Shared SRAM [8086:a36f] (rev 10)
00:15.0 Serial bus controller [0c80]: Intel Corporation Device [8086:a368] (rev 10)
00:15.1 Serial bus controller [0c80]: Intel Corporation Device [8086:a369] (rev 10)
00:16.0 Communication controller [0780]: Intel Corporation Cannon Lake PCH HECI Controller [8086:a360] (rev 10)
00:17.0 SATA controller [0106]: Intel Corporation Device [8086:a353] (rev 10)
00:1d.0 PCI bridge [0604]: Intel Corporation Cannon Lake PCH PCI Express Root Port 9 [8086:a330] (rev f0)
00:1d.4 PCI bridge [0604]: Intel Corporation Device [8086:a334] (rev f0)
00:1d.5 PCI bridge [0604]: Intel Corporation Device [8086:a335] (rev f0)
00:1e.0 Communication controller [0780]: Intel Corporation Device [8086:a328] (rev 10)
00:1f.0 ISA bridge [0601]: Intel Corporation Device [8086:a30d] (rev 10)
00:1f.3 Audio device [0403]: Intel Corporation Cannon Lake PCH cAVS [8086:a348] (rev 10)
00:1f.4 SMBus [0c05]: Intel Corporation Cannon Lake PCH SMBus Controller [8086:a323] (rev 10)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH SPI Controller [8086:a324] (rev 10)
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP106M [GeForce GTX 1060 Mobile] [10de:1c20] (rev a1)
06:00.0 Non-Volatile memory controller [0108]: Sandisk Corp Device [15b7:5005] (rev 01)
07:00.0 Network controller [0280]: Intel Corporation Dual Band Wireless-AC 3165 Plus Bluetooth [8086:3166] (rev 99)
08:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)

Używaj code - https://forum.linuxmint.pl/showthread.ph...75#pid1075
#8
1
Better response on post RE: Nvidia Prime - SetupJa bym spróbował tak:
1. Zainstalować ten sterownik
2. Zainstalować nvidia-prime
Kod:
sudo apt install nvidia-prime
3. Przełączyć:
Kod:
sudo prime-select nvidia

Daj wyniki po wszystkim.
#9
0
Działa, dziękuję.
#10
0
No i fajnie, wątek zamykam.


Skocz do:




Użytkownicy przeglądający ten wątek: 1 gości