Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Solved Brak wifi linux mint 19.2 Cinnamon
#1
0
A więc internet mam tylko po podłączeniu kabla i nie wiem co zrobić 
Dodam tylko że jestem nowy w temacie linuxa
#2
0
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M; LU#586742
#3
0
A jak mam pobrać skrypt?

Dodano po pewnym czasie:
Czekaj

Dodano po pewnym czasie:
To są te dane ze skryptu

Dodano po pewnym czasie:
To ten xD


Załączone pliki
.txt   wireless-info.txt (Rozmiar: 7,89 KB / Pobrań: 22)
#4
0
Spróbuj tak (każdą z tych poniższych komend wklej - Ctrl+Shift+V -oddzielnie do terminala i wykonaj naciskając enter):
Jeśli będzie prośba o hasło, podaj je.

Kod:
sudo apt-get install linux-headers-generic build-essential git

Następnie - każda osobno, następna dopiero kiedy wykona się poprzednia:
Kod:
git clone https://github.com/benjarobin/MT7630E.git
cd MT7630E/rt2x00
make
sudo make install
sudo modprobe mt7630e

Po wszystkim uruchom komputer ponownie.
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M; LU#586742
#5
0
Nie za bardzo mam jak to zrobić ponieważ nie mam internetu
#6
0
Napisałeś że internet masz tylko po kablu, więc podłącz go na czas operacji. 2 pierwsze komendy podane powyżej wymagają internetu
#7
0
To jest to co mi wyskoczyło po pierwszej komendzie.
Kod:
[email protected]:~/Pulpit$ sudo apt-get install linux-headers-generic build-essential git
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności     
Odczyt informacji o stanie... Gotowe
git is already the newest version (1:2.17.0-1ubuntu1).
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
build-essential : Wymaga: g++ (>= 4:7.2) ale nie zostanie zainstalowany
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.
[email protected]:~/Pulpit$

Wyniki komend podawaj w znacznikach CODE wg tego poradnika: https://forum.linuxmint.pl/showthread.ph...75#pid1075


Załączone pliki
.txt   Dokument bez nazwy.txt (Rozmiar: 822 bajtów / Pobrań: 3)
#8
0
OK, zamiast pierwszej komendy spróbuj tak:
Kod:
sudo apt-get install --reinstall linux-headers-$(uname -r) build-essential dkms

a następnie jeszcze jednej:
Kod:
sudo apt install git
Po tej komendzie może wyświetlić się informacja, że
Cytat:[...] git is already the newest version [...]

czyli jest OK. Przejdź dalej...

Jeśli te wykonają się poprawnie wykonaj te:
Kod:
git clone https://github.com/benjarobin/MT7630E.git
cd MT7630E/rt2x00
make
sudo make install
sudo modprobe mt7630e
przypominam - po kolei.
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M; LU#586742
#9
0
Kod:
[email protected]:~/Pulpit$ sudo apt-get install --reinstall linux-headers-$(uname -r) build-essential dkms
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności     
Odczyt informacji o stanie... Gotowe
Ponowna instalacja pakietu linux-headers-4.15.0-54-generic nie jest możliwa, nie może on zostać pobrany.
Ponowna instalacja pakietu dkms nie jest możliwa, nie może on zostać pobrany.
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
build-essential : Wymaga: g++ (>= 4:7.2) ale nie zostanie zainstalowany
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.
[email protected]:~/Pulpit$

Dodano po pewnym czasie:
To jest wszystko co mi wyszło:
Kod:
[email protected]:~/Pulpit$ sudo apt-get install --reinstall linux-headers-$(uname -r) build-essential dkms
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności     
Odczyt informacji o stanie... Gotowe
Ponowna instalacja pakietu linux-headers-4.15.0-54-generic nie jest możliwa, nie może on zostać pobrany.
Ponowna instalacja pakietu dkms nie jest możliwa, nie może on zostać pobrany.
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
build-essential : Wymaga: g++ (>= 4:7.2) ale nie zostanie zainstalowany
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.
[email protected]:~/Pulpit$ sudo apt install git
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności     
Odczyt informacji o stanie... Gotowe
git is already the newest version (1:2.17.0-1ubuntu1).
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.
[email protected]:~/Pulpit$ git clone https://github.com/benjarobin/MT7630E.git
Cloning into 'MT7630E'...
remote: Enumerating objects: 269, done.
remote: Total 269 (delta 0), reused 0 (delta 0), pack-reused 269
Receiving objects: 100% (269/269), 608.96 KiB | 524.00 KiB/s, done.
Resolving deltas: 100% (166/166), done.
[email protected]:~/Pulpit$ cd MT7630E/rt2x00
[email protected]:~/Pulpit/MT7630E/rt2x00$ make
make -C /lib/modules/4.15.0-54-generic/build M=/home/angelsagiri/Pulpit/MT7630E/rt2x00 modules
make[1]: Entering directory '/usr/src/linux-headers-4.15.0-54-generic'
Makefile:976: "Cannot use CONFIG_STACK_VALIDATION=y, please install libelf-dev, libelf-devel or elfutils-libelf-devel"
s  CC [M]  /home/angelsagiri/Pulpit/MT7630E/rt2x00/rt2x00dev.o
sudo m/home/angelsagiri/Pulpit/MT7630E/rt2x00/rt2x00dev.c: In function ‘rt2x00lib_rxdone’:
/home/angelsagiri/Pulpit/MT7630E/rt2x00/rt2x00dev.c:792:19: error: ‘RX_FLAG_HT’ undeclared (first use in this function); did you mean ‘RX_ENC_HT’?
  rxdesc.flags |= RX_FLAG_HT;
                  ^~~~~~~~~~
                  RX_ENC_HT
/home/angelsagiri/Pulpit/MT7630E/rt2x00/rt2x00dev.c:792:19: note: each undeclared identifier is reported only once for each function it appears in
ascripts/Makefile.build:330: recipe for target '/home/angelsagiri/Pulpit/MT7630E/rt2x00/rt2x00dev.o' failed
make[2]: *** [/home/angelsagiri/Pulpit/MT7630E/rt2x00/rt2x00dev.o] Error 1
Makefile:1552: recipe for target '_module_/home/angelsagiri/Pulpit/MT7630E/rt2x00' failed
make[1]: *** [_module_/home/angelsagiri/Pulpit/MT7630E/rt2x00] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-4.15.0-54-generic'
Makefile:22: recipe for target 'all' failed
make: *** [all] Error 2
[email protected]:~/Pulpit/MT7630E/rt2x00$ sudo make install
make: *** No rule to make target 'install'.  Stop.
[email protected]:~/Pulpit/MT7630E/rt2x00$ sudo modprobe mt7630e
modprobe: FATAL: Module mt7630e not found in directory /lib/modules/4.15.0-54-generic
[email protected]:~/Pulpit/MT7630E/rt2x00$
#10
0
Pewnie otwierasz terminal PPM... jesteś w terminalu na Pulpicie.

Zamknij terminal i naciśnij klawisze Ctrl+Alt+T...
Wykonaj jeszcze raz poszczególne polecenia pojedynczo z mojego poprzedniego posta.

Wgrywałeś nowsze jądro?... Czy w aktualizacjach było nowe jądro?

Czy zaraz po zainstalowaniu systemu miałeś połączenie WiFi?


EDIT:
Gdyby sytuacja się powtórzyła wykonaj jeszcze instalację:
Kod:
sudo apt install libelf-dev libelf-devel

Oczywiście z dostępem do internetu.
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M; LU#586742


Skocz do:




Użytkownicy przeglądający ten wątek: 1 gości