Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Skalowanie mocy procesora ASUS U6Sg T8300 + Mint 19.1 Xfce
#1
0
Witam,

Kilka razy zaczynałem moją przygodę z linuxem i zawsze wpadałem we frustrację kiedy natrafiałem na jakiś problem, którego nie mogłem rozwiązać. Może jednak tym razem się uda z pomocą forumowiczów.

Zainstalowałem linuxa Mint 19.1 +Xfce na moim starym laptopie ASUS U6Sg o parametrach:
Kod:
[email protected]:~$ inxi -Fxz
System:
  Host: ASUS-U6S Kernel: 4.15.0-60-generic x86_64 bits: 64 compiler: gcc
  v: 7.4.0 Desktop: Xfce 4.12.3 Distro: Linux Mint 19.1 Tessa
  base: Ubuntu 18.04 bionic
Machine:
  Type: Laptop System: ASUSTeK product: U6Sg v: 1.0 serial: <filter>
  Mobo: ASUSTeK model: U6Sg v: 1.0 serial: <filter>
  BIOS: American Megatrends v: 305 date: 10/28/2008
Battery:
  ID-1: BAT0 charge: 22.9 Wh condition: 23.0/24.5 Wh (94%)
  model: ASUSTEK U6---24 status: Unknown
CPU:
  Topology: Dual Core model: Intel Core2 Duo T8300 bits: 64 type: MCP
  arch: Penryn rev: 6 L2 cache: 3072 KiB
  flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 9576
  Speed: 798 MHz max: 800 MHz Core speeds (MHz): 1: 798 2: 798
Graphics:
  Device-1: NVIDIA G86M [GeForce 9300M G] vendor: ASUSTeK driver: nouveau
  v: kernel bus ID: 01:00.0
  Display: x11 server: X.Org 1.19.6 driver: nouveau
  unloaded: fbdev,modesetting,vesa resolution: 1280x800~60Hz
  OpenGL: renderer: NV86 v: 3.3 Mesa 19.0.8 direct render: Yes
Audio:
  Device-1: Intel 82801H HD Audio vendor: ASUSTeK driver: snd_hda_intel
  v: kernel bus ID: 00:1b.0
  Sound Server: ALSA v: k4.15.0-60-generic
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: ASUSTeK driver: r8169 v: 2.3LK-NAPI port: c800 bus ID: 05:00.0
  IF: ens34 state: down mac: <filter>
  Device-2: Intel PRO/Wireless 4965 AG or AGN [Kedron] Network
  driver: iwl4965 v: in-tree: port: c800 bus ID: 06:00.0
  IF: wls35 state: up mac: <filter>
Drives:
  Local Storage: total: 111.79 GiB used: 7.43 GiB (6.6%)
  ID-1: /dev/sda vendor: OCZ model: AGILITY3 size: 111.79 GiB
Partition:
  ID-1: / size: 18.21 GiB used: 6.96 GiB (38.2%) fs: ext4 dev: /dev/sda5
  ID-2: /home size: 31.31 GiB used: 476.0 MiB (1.5%) fs: ext4 dev: /dev/sda7
  ID-3: swap-1 size: 5.59 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda6
Sensors:
  System Temperatures: cpu: 53.0 C mobo: N/A gpu: nouveau temp: 62 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 186 Uptime: 34m Memory: 2.93 GiB used: 870.9 MiB (29.0%)
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20
  inxi: 3.0.27
i pojawił się problem ze skalowaniem częstotliwości procesora. W trybie pracy z sieci AC częstotliwość procesora jest stała i wynosi 800 MHz, natomiast w trybie pracy z baterii częstotliwość ta oscyluje w granicach 400 MHz. Biorąc pod uwagę, iż jest to dużo poniżej maksymalnej częstotliwości procesora wynoszącej 2400MHz praca na laptopie jest mało komfortowa, a w trybie pracy z baterii to już tragedia.
Przeszukując internet doszedłem do wniosku, iż jest to dość popularny problem, ale niestety nie znalazłem żadnego sensownego rozwiązania - może moja wiedza na temat linuxa jest niewystarczająca. W związku z powyższym mam wielką prośbę o pomoc w rozwiązaniu tego problemu krok po kroku.

Pozdrawiam,
Odpowiedz
#2
0
Wrzuć jeszcze gdzieś (np. pastebin) wynik dmesg tuż po rozruchu.
Odpowiedz
#3
0
(09-09-2019, 19:11)dedito napisał(a): Wrzuć jeszcze gdzieś (np. pastebin) wynik dmesg tuż po rozruchu.
https://pastebin.com/sxUKTAAq
Odpowiedz
#4
0
Jesteś pewien, że problem dotyczy Minta?
Sprawdzałeś inne systemy?
Aktualizowałeś Bios?
Czy wentylator pracuje normalnie, czy może ma maksymalną prędkość?
Odpowiedz
#5
0
(10-09-2019, 10:24)dedito napisał(a): Jesteś pewien, że problem dotyczy Minta?
Sprawdzałeś inne systemy?
Aktualizowałeś Bios?
Czy wentylator pracuje normalnie, czy może ma maksymalną prędkość?
Witam,

Na tym samym dysku mam Windows 7 64bit i tam nie ma problemu procesor osiąga 2400MHz.
Bios mam 305 - najnowszy jaki udało mi się znaleźć na stronie producenta.
Wentylator pracuje normalnie - dość cicho, natomiast w windowsie jak obciążę procesor rozkręca się do maksymalnych obrotów.
Także wnioskuję, że to problem systemu.

Pozdrawiam,
Krzysztof
Odpowiedz
#6
0
To raczej jednoznacznie wskazuje na problem z Mintem.
Sprawdź czy uruchomienie systemu z intel_pstate=disable pomoże.
https://forum.linuxmint.pl/showthread.php?tid=145
Odpowiedz
#7
0
(10-09-2019, 11:56)dedito napisał(a): To raczej jednoznacznie wskazuje na problem z Mintem.
Sprawdź czy uruchomienie systemu z intel_pstate=disable pomoże.
https://forum.linuxmint.pl/showthread.php?tid=145
Ok spróbuję jak wrócę na chatę z pracy i dam znać.
Dzięki za pomoc.

Dodano po pewnym czasie:
(10-09-2019, 11:56)dedito napisał(a): To raczej jednoznacznie wskazuje na problem z Mintem.
Sprawdź czy uruchomienie systemu z intel_pstate=disable pomoże.
https://forum.linuxmint.pl/showthread.php?tid=145
Ok, uruchomiłem komputer z podanym parametrem, ale nadal jest to samo.
Wykonałem jeszcze poniższą komendę z takim efektem:
Kod:
[email protected]:~$ sudo cpupower frequency-info
[sudo] password for tofi:         
analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us
  hardware limits: 800 MHz - 2.40 GHz
  available frequency steps:  2.40 GHz, 2.40 GHz, 2.00 GHz, 1.60 GHz, 1.20 GHz, 800 MHz
  available cpufreq governors: conservative ondemand userspace powersave performance schedutil
  current policy: frequency should be within 800 MHz and 800 MHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency: 800 MHz (asserted by call to hardware)
  boost state support:
    Supported: yes
    Active: yes
zastanawiające jest: "current policy: frequency should be within 800 MHz and 800 MHz" - komputer podłączony do zasilania z sieci.
Odpowiedz
#8
0
Kolejny strzał z parametrem startowym to: processor.ignore_ppc=1, poprzedniego jeszcze nie wyrzucaj.
Odpowiedz
#9
0
(10-09-2019, 18:28)dedito napisał(a): Kolejny strzał z parametrem startowym to: processor.ignore_ppc=1, poprzedniego jeszcze nie wyrzucaj.
Mam tylko pytanie czy konfiguracja GRUB ma wyglądać tak?

Kod:
GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nocrs"
GRUB_CMDLINE_LINUX="intel_pstate=disable"
GRUB_CMDLINE_LINUX="processor.ignore_ppc=1"
Jeżeli tak to po ponownym uruchomieniu bez zmian.
Odpowiedz
#10
1
Better response on post RE: Skalowanie mocy procesora ASUS U6Sg T8300 + Mint 19.1 XfceWystarczyło wybrać opcję tymczasowego dopisania parametrów na etapie rozruchu.

Skoro wybrałeś opcję pernamentną to korekta linijki: GRUB_CMDLINE_LINUX="intel_pstate=disable processor.ignore_ppc=1" bo nie mam pewności, czy można to rozbijać na dwie.
I potem obowiązkowy update gruba.
Odpowiedz


Skocz do:




Użytkownicy przeglądający ten wątek: 1 gości