Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
pakiety AUR
#1
0
Na linux mint jest ładny graficzny menadżer pakietów oraz drugi program do instalowania. Wszystko pieknie ale co z AUR? najlepszym rozwiazaniem byłaby instalacja menadżera pakietów yay, a to już trudna bajka bez pacmana z archa, więc macie jakieś rady?
Odpowiedz
#2
0
To jest system paczek dla dystrybucji Arch i innych na nich bazujących.
Osobiście nie słyszałem o możliwości użycia tych paczek w Mincie.
Wujek wyszukiwarka znalazł pacapt, który wydaje się spełniać wymagania

https://www.ostechnix.com/use-archlinuxs...-like-oss/
Cytat:Pacapt is actually a wrapper script for different package managers such as YUM, DNF, APT, and Zypper etc. Using Pacapt, you can use the pacman commands as the way you use it under Arch Linux to install, update, upgrade, remove packages in other Unix-like operating systems. That said, you don’t need to remember various commands/options of different OSs. Pacapt brings most-commonly used Pacman commands to many other Unix-like operating systems. Please be mindful that not all options of the native package manager are ported. Pacapt tool only provides a very basic interface to search, install, remove packages, and/or update the system.

Pacapt currently supports the following package managers:

pacman by Arch Linux, ArchBang, Manjaro, etc.
dpkg/apt-get by Debian, Ubuntu, etc.
homebrew by Mac OS X
macports by Mac OS X
yum/rpm by Redhat, CentOS, Fedora, etc.
portage by Gentoo
zypper by OpenSUSE
pkgng by FreeBSD
cave by Exherbo Linux
pkg_tools by OpenBSD
sun_tools by Solaris(SunOS)
apk by Alpine Linux
tazpkg by SliTaz Linux
swupd by Clear Linux
tlmgr by TeX Live
conda by Conda

Z tego co widzę paczka jest w repozytoriach.
http://manpages.ubuntu.com/manpages/bion...apt.1.html
Odpowiedz
#3
0
wszystko pieknie ale...
Kod:
[email protected]:~$ pacapt -SS caprine
E: Nie udało się otworzyć pliku blokady /var/lib/dpkg/lock-frontend - open (13: Brak dostępu)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?
oco chodzi?... on chce roota?
Odpowiedz
#4
0
Dokładnie, w tym przypadku system wymaga konta root.
Przykładowo: użyj przed komendą sudo czyli sudo pacapt -SS caprine
W przypadku caprine są chyba też paczki deb i uniwersalne formaty paczek.
Po co się ładujesz w ten arch?
Odpowiedz
#5
0
chce messengera a caprine jest ładny... ale chyba da sie to normalnie zaonstalować lecz nw który wybrać plik na Githubie
zielony jestem
Odpowiedz
#6
0
Caprine masz w menedżerze oprogramowania. Więc nie bardzo rozumiem, co chcesz ugrać takimi kombinacjami...
[Obrazek: 0DPXXV3l.png]

Działa bardzo dobrze - sam z niego korzystam.
Odpowiedz
#7
0
nie ma, grzebałem w ustawieniach nic to nie dało


Załączone pliki Miniatury
   
Odpowiedz
#8
0
Kod:
wget https://github.com/sindresorhus/caprine/releases/download/v2.39.0/caprine_2.39.0_amd64.deb
sudo dpkg -i caprine_2.39.0_amd64.deb
Odpowiedz
#9
0
Kod:
[email protected]:~$ sudo dpkg -i caprine_2.39.0_amd64.deb
[sudo] hasło użytkownika oliwer:       
Wybieranie wcześniej niewybranego pakietu caprine.
(Odczytywanie bazy danych ... 294705 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu caprine_2.39.0_amd64.deb ...
Rozpakowywanie pakietu caprine (2.39.0-1630) ...
dpkg-deb (podproces): nie można skopiować członu archiwum z "caprine_2.39.0_amd64.deb" do potoku dekompresyjnego: niespodziewany koniec pliku lub strumienia
dpkg-deb (podproces): dekompresowanie członu archiwum: błąd lzma: niespodziewany koniec wejścia
dpkg-deb: błąd: podproces <dekompresja> zwrócił kod błędu 2
dpkg: błąd przetwarzania archiwum caprine_2.39.0_amd64.deb (--install):
nie można skopiować wypakowanych danych "./opt/Caprine/caprine" do "/opt/Caprine/caprine.dpkg-new": niespodziewany koniec pliku lub strumienia
Przetwarzanie wyzwalaczy pakietu hicolor-icon-theme (0.17-2)...
Przetwarzanie wyzwalaczy pakietu gnome-menus (3.13.3-11ubuntu1.1)...
Przetwarzanie wyzwalaczy pakietu desktop-file-utils (0.23+linuxmint6)...
Przetwarzanie wyzwalaczy pakietu mime-support (3.60ubuntu1)...
Wystąpiły błędy podczas przetwarzania:
caprine_2.39.0_amd64.deb
byłoby zbyt pieknie gdyby działało, czemu amd?
Odpowiedz
#10
1
Better response on post RE: pakiety AURTo jest oznaczenie architektury CPU (na intelu też będzie działać).
Spróbuj jeszcze raz ściągnąć.
U mnie poszło bez problemów:
Kod:
wget https://github.com/sindresorhus/caprine/releases/download/v2.39.0/caprine_2.39.0_amd64.deb
--2019-10-20 12:44:41--  https://github.com/sindresorhus/caprine/releases/download/v2.39.0/caprine_2.39.0_amd64.deb
Translacja github.com (github.com)... 140.82.118.4
Łączenie się z github.com (github.com)|140.82.118.4|:443... połączono.
Żądanie HTTP wysłano, oczekiwanie na odpowiedź... 302 Found
Lokalizacja: https://github-production-release-asset-2e65be.s3.amazonaws.com/42574339/8ea38180-ea0f-11e9-8edb-25d3cda1030e?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20191020%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20191020T104442Z&X-Amz-Expires=300&X-Amz-Signature=1a07447bae57c0ee5e5ceea1317381ec0659089a4eac553057817e33b73a694c&X-Amz-SignedHeaders=host&actor_id=0&response-content-disposition=attachment%3B%20filename%3Dcaprine_2.39.0_amd64.deb&response-content-type=application%2Foctet-stream [podążanie]
--2019-10-20 12:44:42--  https://github-production-release-asset-2e65be.s3.amazonaws.com/42574339/8ea38180-ea0f-11e9-8edb-25d3cda1030e?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20191020%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20191020T104442Z&X-Amz-Expires=300&X-Amz-Signature=1a07447bae57c0ee5e5ceea1317381ec0659089a4eac553057817e33b73a694c&X-Amz-SignedHeaders=host&actor_id=0&response-content-disposition=attachment%3B%20filename%3Dcaprine_2.39.0_amd64.deb&response-content-type=application%2Foctet-stream
Translacja github-production-release-asset-2e65be.s3.amazonaws.com (github-production-release-asset-2e65be.s3.amazonaws.com)... 52.217.8.4
Łączenie się z github-production-release-asset-2e65be.s3.amazonaws.com (github-production-release-asset-2e65be.s3.amazonaws.com)|52.217.8.4|:443... połączono.
Żądanie HTTP wysłano, oczekiwanie na odpowiedź... 200 OK
Długość: 47448004 (45M) [application/octet-stream]
Zapis do: `caprine_2.39.0_amd64.deb'

caprine_2.39.0_amd64.deb            100%[=======================================================================>]  45,25M   885KB/s     w 40s    

2019-10-20 12:45:22 (1,13 MB/s) - zapisano `caprine_2.39.0_amd64.deb' [47448004/47448004]
Kod:
sudo dpkg -i caprine_2.39.0_amd64.deb
Wybieranie wcześniej niewybranego pakietu caprine.
(Odczytywanie bazy danych ... 822383 pliki i katalogi obecnie zainstalowane.)
Przygotowywanie do rozpakowania pakietu caprine_2.39.0_amd64.deb ...
Rozpakowywanie pakietu caprine (2.39.0-1630) ...
Konfigurowanie pakietu caprine (2.39.0-1630) ...
Przetwarzanie wyzwalaczy pakietu hicolor-icon-theme (0.17-2)...
Przetwarzanie wyzwalaczy pakietu mime-support (3.64)...
Przetwarzanie wyzwalaczy pakietu desktop-file-utils (0.24-1)...
Przetwarzanie wyzwalaczy pakietu gnome-menus (3.32.0-1)...
Przetwarzanie wyzwalaczy pakietu bamfdaemon (0.5.4-1)...
Rebuilding /usr/share/applications/bamf-2.index...
Odpowiedz


Skocz do:




Użytkownicy przeglądający ten wątek: 3 gości