Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
HWE w LM 19.3
#1
3
Better response on post HWE w LM 19.3Jądra Linuksa przygotowywane przez firmę Canonical dla Ubuntu i Linux Mint dzielone są na dwa rodzaje; z długim (LTS) i krótkim (HWE) wsparciem.
Linux Mint w wersjach 19-19.2 był wydawany z jądrem serii 4.15 LTS wspieranym przez pięć lat. Wersja 19.3 spodziewana przed nowym rokiem i następne będą wydawane z jądrem HWE ze znacznie krótszym wsparciem. Dla 19.3 będzie to 5.0.

Powodem tej decyzji jest konieczność nadążania za tempem zmian w sprzęcie komputerowym, ponieważ jądra Linuksa są odpowiedzialne za sterowniki czyli współpracę sprzętu z systemem operacyjnym.

Jądro 5.0 w 19.3 otrzymamy w nowej instalacji systemu, w przypadku kiedy zrobimy tylko upgrade to zachowamy 4.15.

Po nowej instalacji systemu możemy powrócić do serii 4.15 jeśli chcemy długie wsparcie.

Użycie HWE będzie wiązało się z koniecznością instalowania nowych serii jąder w znacznie krótszych odstępach czasu, jeśli ktoś chce mieć wszystkie aktualizacje bezpieczeństwa.

Będzie większy wybór jąder lepiej dostosowanych do Minta, dobra wiadomość dla tych co mają problemy ze sterownikami.
Odpowiedz
#2
0
Nie wiem jak u innych ale u mnie Mint działa lepiej na jądrze wersji 5.x aniżeli 4.15. Ja bym zaproponował dodanie dwóch obrazów - z starszym jądrem i nowym, nie zabawa z nimi w systemie, gdyż laik może zepsuć i się zrazić do dystrybucji
Odpowiedz
#3
0
W Ubuntu 18.04.03 już dają jądro serii 5, ale jest to kwestia wyboru w trakcie instalacji (tak przynajmniej piszą) pomiędzy starym jądrem LTS a nowym HWE.
Odpowiedz
#4
0
A nie powinno to 5.xx być LTS? w końcu jest późniejsze i na pewno wejdzie (kiedyś).
-------------
MSi GV72-8RE | Mint 19.1 | 4.15.0-47-generic x86_64 | Mate 1.20.1 | Nvidia GeForce GTX 1060
Odpowiedz
#5
0
To czy jądro jest LTS decydują twórcy kernela, obecnie w planach jest 5.4 jako LTS
[Obrazek: aavSmRt.png]
Żródło: https://www.kernel.org/category/releases.html

Chociaż mogą być wyjątki od tej reguły, co opisuje powyższa strona:
Cytat:Distribution kernels
Many Linux distributions provide their own "longterm maintenance" kernels that may or may not be based on those maintained by kernel developers. These kernel releases are not hosted at kernel.org and kernel developers can provide no support for them.
It is easy to tell if you are running a distribution kernel. Unless you downloaded, compiled and installed your own version of kernel from kernel.org, you are running a distribution kernel. To find out the version of your kernel, run uname -r:
# uname -r
3.7.5-201.fc18.x86_64

If you see anything at all after the dash, you are running a distribution kernel. Please use the support channels offered by your distribution vendor to obtain kernel support.
Odpowiedz
#6
0
Jak porównamy tą tabelę z jądrami LTS w Ubuntu (3.13, 4.4, 4.15) to wygląda na to że Canonical samo decyduje co jest LTS.
Odpowiedz
#7
0
Jak widać Ubuntu jest jednym z tych wyjątków.
Odpowiedz
#8
1
To może mint też powinien sam decydować na których jajkach distro chodzi lepiej i które dłużej wspierać. Nie koniecznie muszą to być te same co w ubu. No nie ma w tym sensu? Dostajemy, siłą rzeczy, kernele później więc ludzie mają więcej czasu żeby je obadać dokładnie i zdecydować.
-------------
MSi GV72-8RE | Mint 19.1 | 4.15.0-47-generic x86_64 | Mate 1.20.1 | Nvidia GeForce GTX 1060
Odpowiedz
#9
0
Wątpię żeby załoga Minta była w stanie samodzielnie wspierać jądra. Raczej polegają na specjalnym zespole od tych spraw w firmie Canonical.
Odpowiedz


Skocz do:




Użytkownicy przeglądający ten wątek: 1 gości