Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Rozwiązane Problem z wybudzeniem laptopa HP Elitebook 2540p
#11
0
Kod:
[email protected]:~$ ls /sys/bus/usb/devices
1-0:1.0  1-1:1.0  1-1.3:1.0  1-1.5:1.0  2-0:1.0  2-1.1    2-1.1:1.0  usb2
1-1      1-1.3    1-1.5      1-1.5:1.1  2-1      2-1:1.0  usb1
[email protected]:~$
#12
0
No i teraz trzeba wyczaić, która to klawiatura i/lub mysz/touchpad Smile
Zobacz do zwrócą komendy:
Kod:
cat /sys/bus/usb/devices/1-1/power/wakeup
i
cat /sys/bus/usb/devices/2-1/power/wakeup
#13
0
Kod:
[email protected]:~$ ls /sys/bus/usb/devices
1-0:1.0  1-1:1.0  1-1.3:1.0  1-1.5:1.0  2-0:1.0  2-1.1    2-1.1:1.0  usb2
1-1      1-1.3    1-1.5      1-1.5:1.1  2-1      2-1:1.0  usb1
[email protected]:~$ cat /sys/bus/usb/devices/1-1/power/wakeup
disabled
[email protected]:~$ cat /sys/bus/usb/devices/2-1/power/wakeup
disabled
[email protected]:~$
#14
0
No to spróbuj  tak:
wykonaj: echo enabled | sudo tee /sys/bus/usb/devices/1-1/power/wakeup potem: sudo pm-suspend to uśpi kompa i spróbuj pacnąć jakiś klawisz i/lub pomerdać touchpadem.

To samo dla "2-1".

EDIT:
Nie grzebałeś przypadkiem w kompie na podstawie tego wątku: https://forum.linuxmint.pl/showthread.php?tid=323
#15
0
Przy pierwszym uśpiło kompa . Zrobił się czarny ekran. Po merdnięciu zapalił się ekran ale nic nie można było zrobić.Żaden klawisz nie działał.Tylko wyłączenie na sztywno. Przy drugiej próbie też czarny ekran. Ale nie reagował na touchpada ani na klawisze. Przy kliknięciu na wyłącznik ekran podświetlił się ale dalej nic nie można było zrobić. Żaden klawisz nie działał.Tylko wyłączenie na sztywno.
Nie grzebałem. Parę lat chodziło dobrze . Tygodniami nie wyłączałem kompa tylko zamykałem pokrywę, i na drugi dzień działało. Po jakiejś aktualizacji przestało.
#16
0
No to z innej beczki:
pokaż cat /proc/acpi/wakeup...
a właśnie zobacz, czy w BIOSie masz włączone ACPI, a może dopisywałeś coś do /etc/default/grub?
Kod:
cat /etc/default/grub
#17
0
Kod:
[email protected]:~$ cat /proc/acpi/wakeup
Device    S-state      Status   Sysfs node
LANC      S5    *enabled   pci:0000:00:19.0
HDEF      S3    *disabled  pci:0000:00:1b.0
EHC1      S3    *enabled   pci:0000:00:1d.0
EHC2      S3    *enabled   pci:0000:00:1a.0
PCIB      S5    *disabled  pci:0000:00:1e.0
RP02      S4    *disabled  pci:0000:00:1c.1
ECF0      S4    *disabled
RP03      S4    *disabled
RP04      S5    *disabled  pci:0000:00:1c.3
WNIC      S5    *disabled  pci:0000:43:00.0
RP06      S5    *disabled
NIC      S5    *disabled
RP07      S4    *disabled
RP08      S4    *disabled
PEG3      S4    *disabled
PEG4      S4    *disabled
PEG5      S4    *disabled
PEG6      S4    *disabled
HST1      S5    *disabled  platform:PNP0C32:00
[email protected]:~$ cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_sleep=nonvs intel_pstate=disable"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
[email protected]:~$

Dodano po pewnym czasie:
Odpaliłem na poprzednim jądrze i zaczął się wybudzać po zamknięciu pokrywy. Spróbuje wyłączyć kilka razy może się naprawiło.
#18
0
A, ok. Czyli przywróć /etc/default/grub do poprzedniego stanu - GRUB_CMDLINE_LINUX_DEFAULT="quiet splash". Chyba, że to było konieczne do starszego, to nie ruszaj.
Jeśli działa na starszym kernelu, to ok - nie ma co kombinować z nowszym. W menedżerze aktualizacji wywal to nowsze jądro.
Nowsze ma sens, jeśli coś nie działa jak trzeba. Ja nadal mam 4.10 Smile
Powodzenia.

EDIT:
Żeby wyłączyć aktualizacje jądra wpisz w: Menu > Menedżer aktualizacji > Edycja > Właściwości > Czarna lista takie pozycje:
linux
linux-*
zgodnie z tym, co pisał magnus tu: https://forum.linuxmint.pl/showthread.php?tid=444
#19
0
Działa. Ale tylko na 4.15.0-76-generic na 4.15.0-88-generic nie wybudza się. Jak zrobić by laptop startował ze starszego jądra automatycznie?
#20
0
Menedżer aktualizacji, widok, jądra - usuń to najnowsze. Uruchom ponownie komputer i zablokuj aktualizacje jak pisałem wyżej.


Skocz do:




Użytkownicy przeglądający ten wątek: 3 gości