Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Rozwiązane Mint 20.3 - nie działa BT
#1
0
Hej. Zaczynam przygodę z Linuxem od Minta.
Sporo poczytałem o obsłudze, ustawieniach i ogólnym uzytkowaniu z punktu widzenia dotychczasowego użytkownika Win. Jestem bardzo zadowolony z tego co Mint oferuje. Niestey w kwestii obsługi oprogramowania jest u mnie krucho.
Miałem problem z "niedziałajacym WIFI" - ale dzięki forum udało mi się znaleźć rozwiązanie - przełączenie UEFI w Biosie.

Z Bluetooth mam większy problem.
Nie widzi żadnych urządzeń. Zainstalowałem Bluemana - nie pomogło.

Kod:
lsusb
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 5986:0543 Acer, Inc
Bus 001 Device 005: ID 0489:e062 Foxconn / Hon Hai
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


rfkill list
0: sony-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: sony-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
3: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
4: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
5: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

Wyrzuca mi taki raport awarii:

Kod:
===================================================================
Info                                                             
===================================================================
           PID: 2312 (bt-adapter)
           UID: 1000 (mariusz)
           GID: 1000 (mariusz)
        Signal: 6 (ABRT)
     Timestamp: Mon 2022-04-11 21:50:04 CEST (21h ago)
  Command Line: bt-adapter -i
    Executable: /usr/bin/bt-adapter
Control Group: /user.slice/user-1000.slice/session-c2.scope
          Unit: session-c2.scope
         Slice: user-1000.slice
       Session: c2
     Owner UID: 1000 (mariusz)
       Boot ID: 1c17ed771eb04dbcb2b4287689a5a1c8
    Machine ID: b76cc7b1bbdc489e93909d2043031de8
      Hostname: mariusz-SonyVAIO
       Storage: /var/lib/systemd/coredump/core.bt-adapter.1000.1c17ed771eb04dbcb2b4287689a5a1c8.2312.1649706604000000000000.lz4
       Message: Process 2312 (bt-adapter) of user 1000 dumped core.
               
                Stack trace of thread 2312:
                #0  0x00007f999569103b __GI_raise (libc.so.6 + 0x4303b)
                #1  0x00007f9995670859 __GI_abort (libc.so.6 + 0x22859)
                #2  0x00007f9995a9eb43 n/a (libglib-2.0.so.0 + 0x1db43)
                #3  0x00007f9995afbcef g_assertion_message_expr (libglib-2.0.so.0 + 0x7acef)
                #4  0x0000556a0333e7b1 n/a (bt-adapter + 0x97b1)
                #5  0x0000556a03339d69 n/a (bt-adapter + 0x4d69)
                #6  0x00007f99956720b3 __libc_start_main (libc.so.6 + 0x240b3)
                #7  0x0000556a0333a35a n/a (bt-adapter + 0x535a)
               
                Stack trace of thread 2313:
                #0  0x00007f99957609cf __GI___poll (libc.so.6 + 0x1129cf)
                #1  0x00007f9995ad336e n/a (libglib-2.0.so.0 + 0x5236e)
                #2  0x00007f9995ad34a3 g_main_context_iteration (libglib-2.0.so.0 + 0x524a3)
                #3  0x00007f9995ad34f1 n/a (libglib-2.0.so.0 + 0x524f1)
                #4  0x00007f9995afcad1 n/a (libglib-2.0.so.0 + 0x7bad1)
                #5  0x00007f99955c0609 start_thread (libpthread.so.0 + 0x8609)
                #6  0x00007f999576d163 __clone (libc.so.6 + 0x11f163)
               
                Stack trace of thread 2314:
                #0  0x00007f99957609cf __GI___poll (libc.so.6 + 0x1129cf)
                #1  0x00007f9995ad336e n/a (libglib-2.0.so.0 + 0x5236e)
                #2  0x00007f9995ad36f3 g_main_loop_run (libglib-2.0.so.0 + 0x526f3)
                #3  0x00007f99959bef8a n/a (libgio-2.0.so.0 + 0x11ef8a)
                #4  0x00007f9995afcad1 n/a (libglib-2.0.so.0 + 0x7bad1)
                #5  0x00007f99955c0609 start_thread (libpthread.so.0 + 0x8609)
                #6  0x00007f999576d163 __clone (libc.so.6 + 0x11f163)
===================================================================
GDB Log                                                          
===================================================================
[New LWP 2312]
[New LWP 2313]
[New LWP 2314]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Core was generated by `bt-adapter -i'.
Program terminated with signal SIGABRT, Aborted.
#0  __GI_raise ([email protected]=6) at ../sysdeps/unix/sysv/linux/raise.c:50
50    ../sysdeps/unix/sysv/linux/raise.c: No such file or directory.
[Current thread is 1 (Thread 0x7f99953ed840 (LWP 2312))]

===================================================================
GDB Backtrace                                                    
===================================================================
[New LWP 2312]
[New LWP 2313]
[New LWP 2314]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Core was generated by `bt-adapter -i'.
Program terminated with signal SIGABRT, Aborted.
#0  __GI_raise ([email protected]=6) at ../sysdeps/unix/sysv/linux/raise.c:50
50    ../sysdeps/unix/sysv/linux/raise.c: No such file or directory.
[Current thread is 1 (Thread 0x7f99953ed840 (LWP 2312))]
#0  __GI_raise ([email protected]=6) at ../sysdeps/unix/sysv/linux/raise.c:50
#1  0x00007f9995670859 in __GI_abort () at abort.c:79
#2  0x00007f9995a9eb43 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9995afbcef in g_assertion_message_expr () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x0000556a0333e7b1 in ?? ()
#5  0x0000556a03339d69 in ?? ()
#6  0x00007f99956720b3 in __libc_start_main (main=0x556a03339770, argc=2, argv=0x7ffd13108cf8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffd13108ce8) at ../csu/libc-start.c:308
#7  0x0000556a0333a35a in ?? ()

===================================================================
GDB Backtrace (all threads)                                      
===================================================================
[New LWP 2312]
[New LWP 2313]
[New LWP 2314]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Core was generated by `bt-adapter -i'.
Program terminated with signal SIGABRT, Aborted.
#0  __GI_raise ([email protected]=6) at ../sysdeps/unix/sysv/linux/raise.c:50
50    ../sysdeps/unix/sysv/linux/raise.c: No such file or directory.
[Current thread is 1 (Thread 0x7f99953ed840 (LWP 2312))]

Thread 3 (Thread 0x7f998ffff700 (LWP 2314)):
#0  0x00007f99957609cf in __GI___poll (fds=0x556a04fd3b70, nfds=2, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
        resultvar = 18446744073709551100
        sc_cancel_oldtype = 0
        sc_ret = <optimized out>
#1  0x00007f9995ad336e in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
No symbol table info available.
#2  0x00007f9995ad36f3 in g_main_loop_run () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
No symbol table info available.
#3  0x00007f99959bef8a in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
No symbol table info available.
#4  0x00007f9995afcad1 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
No symbol table info available.
#5  0x00007f99955c0609 in start_thread (arg=<optimized out>) at pthread_create.c:477
        ret = <optimized out>
        pd = <optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {140297522640640, -1500266415008820145, 140724923304334, 140724923304335, 140724923304480, 140297522638528, 1449847210307179599, 1449826052469773391}, mask_was_saved = 0}}, priv = {pad = {0x0, 0x0, 0x0, 0x0}, data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}
        not_first_call = 0
#6  0x00007f999576d163 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95
No locals.

Thread 2 (Thread 0x7f9994c03700 (LWP 2313)):
#0  0x00007f99957609cf in __GI___poll (fds=0x556a04fb99f0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
        resultvar = 18446744073709551100
        sc_cancel_oldtype = 0
        sc_ret = <optimized out>
#1  0x00007f9995ad336e in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
No symbol table info available.
#2  0x00007f9995ad34a3 in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
No symbol table info available.
#3  0x00007f9995ad34f1 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
No symbol table info available.
#4  0x00007f9995afcad1 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
No symbol table info available.
#5  0x00007f99955c0609 in start_thread (arg=<optimized out>) at pthread_create.c:477
        ret = <optimized out>
        pd = <optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {140297602348800, -1500266415008820145, 140724923303902, 140724923303903, 140724923304048, 140297602346688, 1449827185022161999, 1449826052469773391}, mask_was_saved = 0}}, priv = {pad = {0x0, 0x0, 0x0, 0x0}, data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}
        not_first_call = 0
#6  0x00007f999576d163 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95
No locals.

Thread 1 (Thread 0x7f99953ed840 (LWP 2312)):
#0  __GI_raise ([email protected]=6) at ../sysdeps/unix/sysv/linux/raise.c:50
        set = {__val = {0, 93913838632816, 3432, 140297613732225, 140297615141024, 140297615160992, 140297615144096, 93913808724800, 1, 140297388453296, 0, 140297613722792, 140297615144096, 18198402202490820864, 0, 140297615161224}}
        pid = <optimized out>
        tid = <optimized out>
        ret = <optimized out>
#1  0x00007f9995670859 in __GI_abort () at abort.c:79
        save_stage = 1
        act = {__sigaction_handler = {sa_handler = 0x0, sa_sigaction = 0x0}, sa_mask = {__val = {140297618036227, 140295106723888, 140724603453440, 0, 96, 140297388453296, 140297618462366, 140297618264351, 93915768160256, 140297388453296, 0, 0, 18198402202490820864, 93913808724800, 140297618755040, 140297388453296}}, sa_flags = 97, sa_restorer = 0x7ffd13108b10}
        sigs = {__val = {32, 0 <repeats 15 times>}}
#2  0x00007f9995a9eb43 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
No symbol table info available.
#3  0x00007f9995afbcef in g_assertion_message_expr () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
No symbol table info available.
#4  0x0000556a0333e7b1 in ?? ()
No symbol table info available.
#5  0x0000556a03339d69 in ?? ()
No symbol table info available.
#6  0x00007f99956720b3 in __libc_start_main (main=0x556a03339770, argc=2, argv=0x7ffd13108cf8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffd13108ce8) at ../csu/libc-start.c:308
        self = <optimized out>
        result = <optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {93913808713600, -1500266415008820145, 93913808610096, 140724923305200, 0, 0, 1501912567957902415, 1449826386213426255}, mask_was_saved = 0}}, priv = {pad = {0x0, 0x0, 0x2, 0x7ffd13108cf8}, data = {prev = 0x0, cleanup = 0x0, canceltype = 2}}}
        not_first_call = <optimized out>
#7  0x0000556a0333a35a in ?? ()
No symbol table info available.
#0  __GI_raise ([email protected]=6) at ../sysdeps/unix/sysv/linux/raise.c:50
#1  0x00007f9995670859 in __GI_abort () at abort.c:79
#2  0x00007f9995a9eb43 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9995afbcef in g_assertion_message_expr () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x0000556a0333e7b1 in ?? ()
#5  0x0000556a03339d69 in ?? ()
#6  0x00007f99956720b3 in __libc_start_main (main=0x556a03339770, argc=2, argv=0x7ffd13108cf8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffd13108ce8) at ../csu/libc-start.c:308
#7  0x0000556a0333a35a in ?? ()
#2
0
Proszę podać informacje o konfiguracji sprzętowej/programowej w postaci wyniku polecenia inxi -Fxz (więcej szczegółów uzyskasz klikając w link)

Podając wyniki komend bądź logi proszę używać znaczników - CODE (więcej szczegółów uzyskasz klikając w link)

Więcej zasad, które należy stosować znajdziesz w Zasadach forum

Stosując zasady pomagasz Sobie i Nam bo:
- My nie musimy zajmować się redagowaniem postów, przypominaniem o przestrzeganiu zasad, zbieraniem wystarczającej ilości informacji do udzielenia merytorycznej pomocy.
- Ty masz większe szanse na szybkie otrzymanie merytorycznej odpowiedzi.
#3
0
Kod:
inxi -Fxz
System:
  Kernel: 5.4.0-107-generic x86_64 bits: 64 compiler: gcc v: 9.4.0
  Desktop: Cinnamon 5.2.7 Distro: Linux Mint 20.3 Una
  base: Ubuntu 20.04 focal
Machine:
  Type: Laptop System: Sony product: SVF1521H1EW v: C10HL9TY
  serial: <filter>
  Mobo: Sony model: VAIO serial: <filter> UEFI: Insyde v: R0200DA
  date: 03/26/2013
Battery:
  ID-1: BAT1 charge: 30.8 Wh condition: 31.3/42.3 Wh (74%)
  model: SONY Corp. VGP-BPS35A status: Charging
CPU:
  Topology: Dual Core model: Intel Core i3-3227U bits: 64 type: MT MCP
  arch: Ivy Bridge rev: 9 L2 cache: 3072 KiB
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 15165
  Speed: 1131 MHz min/max: 800/1900 MHz Core speeds (MHz): 1: 1397 2: 1384
  3: 1434 4: 1390
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Sony driver: i915
  v: kernel bus ID: 00:02.0
  Device-2: NVIDIA GK208M [GeForce GT 740M] vendor: Sony driver: nvidia
  v: 470.103.01 bus ID: 01:00.0
  Display: x11 server: X.Org 1.20.13 driver: modesetting,nvidia
  unloaded: fbdev,nouveau,vesa resolution: 1366x768~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2)
  v: 4.2 Mesa 21.2.6 direct render: Yes
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Sony
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0
  Sound Server: ALSA v: k5.4.0-107-generic
Network:
  Device-1: Broadcom and subsidiaries BCM43142 802.11b/g/n vendor: Foxconn
  driver: wl v: kernel port: 3000 bus ID: 07:00.0
  IF: wlp7s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169 v: kernel port: 2000 bus ID: 0e:00.0
  IF: enp14s0 state: down mac: <filter>
Drives:
  Local Storage: total: 447.13 GiB used: 29.39 GiB (6.6%)
  ID-1: /dev/sda vendor: Patriot model: Burst size: 447.13 GiB
Partition:
  ID-1: / size: 438.62 GiB used: 29.38 GiB (6.7%) fs: ext4 dev: /dev/sda2
Sensors:
  System Temperatures: cpu: 51.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 256 Uptime: 30m Memory: 7.65 GiB used: 1.83 GiB (23.9%)
  Init: systemd runlevel: 5 Compilers: gcc: 9.4.0 Shell: bash v: 5.0.17
  inxi: 3.0.38
#4
0
Spróbuj wykonać to, o czym pisałem tu: https://forum.linuxmint.pl/showthread.ph...96#pid8296
Jeśli nie "pójdzie", daj znać.
#5
0
(13-04-2022, 17:07)yahoob3 napisał(a): Spróbuj wykonać to, o czym pisałem tu: https://forum.linuxmint.pl/showthread.ph...96#pid8296
Jeśli nie "pójdzie", daj znać.

Zanim napisałem posta z prśbą o pomoc, próbowałem już tego rozwiązania - bezskutecznie.
Dla pewności zrobiłem to teraz jeszcze raz.
Bez zmian niestety.
#6
0
Hmm... na szybko przychodzi mi do głowy jeszcze włączony w BIOS secure boot - potrafi nabruździć Smile A do życia niezbędny nie jest.

Sprawdziłbym jeszcze czy w systemie uruchomionym z pena w trybie Live BT działa.

Można jeszcze spróbować podgrać nowsze jądro. Menedżer aktualizacji, Widok, Jądra Linuksa. Jeśli masz dostępne z serii 5.13 - zainstaluj ostatnie wspierane. Gdyby to nic nie dało, usunąć to jądro można po uruchomieniu komputera na starszym - wybierasz w GRUB opcje zaawansowane i dalej uruchomienie na poprzednim jądrze. Po uruchomieniu, jak dodałeś nowy kernel, tak go odinstalowujesz... jakby coś.

Gdyby standardowo GRUB nie był widoczny przy starcie, można wcisnąć tuż po uruchomieniu i przytrzymać Shift (czasem Esc), żeby menu się wyświetliło.
#7
0
(13-04-2022, 20:50)yahoob3 napisał(a): Hmm... na szybko przychodzi mi do głowy jeszcze włączony w BIOS secure boot - potrafi nabruździć Smile A do życia niezbędny nie jest.

Sprawdziłbym jeszcze czy w systemie uruchomionym z pena w trybie Live BT działa.

Można jeszcze spróbować podgrać nowsze jądro. Menedżer aktualizacji, Widok, Jądra Linuksa. Jeśli masz dostępne z serii 5.13 - zainstaluj ostatnie wspierane. Gdyby to nic nie dało, usunąć to jądro można po uruchomieniu komputera na starszym - wybierasz w GRUB opcje zaawansowane i dalej uruchomienie na poprzednim jądrze. Po uruchomieniu, jak dodałeś nowy kernel, tak go odinstalowujesz... jakby coś.

Gdyby standardowo GRUB nie był widoczny przy starcie, można wcisnąć tuż po uruchomieniu i przytrzymać Shift (czasem Esc), żeby menu się wyświetliło.

W BIOSie przestawiałem te ustawienia przy problemie z wifi:
[Obrazek: 75dGXCcl.jpg]

Podmieniłem jądro na nowsze:
Kod:
inxi -Fxz
System:
  Kernel: 5.13.0-39-generic x86_64 bits: 64 compiler: N/A
  Desktop: Cinnamon 5.2.7 Distro: Linux Mint 20.3 Una
  base: Ubuntu 20.04 focal
Machine:
  Type: Laptop System: Sony product: SVF1521H1EW v: C10HL9TY
  serial: <filter>
  Mobo: Sony model: VAIO serial: <filter> UEFI: Insyde v: R0200DA
  date: 03/26/2013
Battery:
  ID-1: BAT1 charge: 30.7 Wh condition: 31.3/42.3 Wh (74%)
  model: SONY Corp. VGP-BPS35A status: Charging
CPU:
  Topology: Dual Core model: Intel Core i3-3227U bits: 64 type: MT MCP
  arch: Ivy Bridge rev: 9 L2 cache: 3072 KiB
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 15165
  Speed: 1007 MHz min/max: 800/1900 MHz Core speeds (MHz): 1: 944 2: 1090
  3: 1006 4: 939
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Sony driver: i915
  v: kernel bus ID: 00:02.0
  Device-2: NVIDIA GK208M [GeForce GT 740M] vendor: Sony driver: nvidia
  v: 470.103.01 bus ID: 01:00.0
  Display: x11 server: X.Org 1.20.13 driver: modesetting,nvidia
  unloaded: fbdev,nouveau,vesa resolution: 1366x768~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2)
  v: 4.2 Mesa 21.2.6 direct render: Yes
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Sony
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0
  Sound Server: ALSA v: k5.13.0-39-generic
Network:
  Device-1: Broadcom and subsidiaries BCM43142 802.11b/g/n vendor: Foxconn
  driver: wl v: kernel port: 3000 bus ID: 07:00.0
  IF: wlp7s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169 v: kernel port: 2000 bus ID: 0e:00.0
  IF: enp14s0 state: down mac: <filter>
Drives:
  Local Storage: total: 447.13 GiB used: 40.45 GiB (9.0%)
  ID-1: /dev/sda vendor: Patriot model: Burst size: 447.13 GiB
Partition:
  ID-1: / size: 438.62 GiB used: 40.45 GiB (9.2%) fs: ext4 dev: /dev/sda2
Sensors:
  System Temperatures: cpu: 53.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 249 Uptime: 15m Memory: 7.65 GiB used: 1.69 GiB (22.1%)
  Init: systemd runlevel: 5 Compilers: gcc: 9.4.0 Shell: bash v: 5.0.17
  inxi: 3.0.38

Nie wiem czy robię coś nie tak, ale nadal BT mieli i wyszukuje w nieskończoność. Więc nie widzę specjalnie poprawy.

EDIT: Jednak coś nie działa poprawnie, wiec wracam do poprzedniego jądra.
#8
0
Za https://forums.linuxmint.com/viewtopic.p...8#p1843238
JeremyB to Mintowy spec od kart bezprzewodowych... może ta wersja pomoże?

Kod:
cd /lib/firmware/brcm
sudo wget https://github.com/winterheart/broadcom-bt-firmware/raw/master/brcm/BCM43142A0-0930-0225.hcd

Co do secure boot mode... poza tym "Standard" jest jeszcze coś do wyboru?

Można jeszcze sprawdzić ten sterownik:
Kod:
cd /lib/firmware/brcm
wget https://github.com/winterheart/broadcom-bt-firmware/raw/master/brcm/BCM43142A0-0a5c-216d.hcd

Oczywiście restart komputera.

Rzuć okiem jeszcze na ten stary wątek: https://forum.linuxmint.pl/archive/index...ad-73.html
#9
0
(14-04-2022, 19:57)yahoob3 napisał(a): Za https://forums.linuxmint.com/viewtopic.p...8#p1843238
JeremyB to Mintowy spec od kart bezprzewodowych... może ta wersja pomoże?

Kod:
cd /lib/firmware/brcm
sudo wget https://github.com/winterheart/broadcom-bt-firmware/raw/master/brcm/BCM43142A0-0930-0225.hcd


Przede wszystkim ogromne dzięki za zainteresowanie i pomoc w szukaniu roziwązania.



Co do zaproponowanej wersji, to u mnie wyświetliło się to (i niestety bez zmian):

Kod:
--2022-04-14 22:47:41--  https://github.com/winterheart/broadcom-bt-firmware/raw/master/brcm/BCM43142A0-0930-0225.hcd
Translacja github.com (github.com)... 140.82.121.4
Łączenie się z github.com (github.com)|140.82.121.4|:443... połączono.
Żądanie HTTP wysłano, oczekiwanie na odpowiedź... 302 Found
Lokalizacja: https://raw.githubusercontent.com/winterheart/broadcom-bt-firmware/master/brcm/BCM43142A0-0930-0225.hcd [podążanie]
--2022-04-14 22:47:41--  https://raw.githubusercontent.com/winterheart/broadcom-bt-firmware/master/brcm/BCM43142A0-0930-0225.hcd
Translacja raw.githubusercontent.com (raw.githubusercontent.com)... 185.199.109.133, 185.199.110.133, 185.199.111.133, ...
Łączenie się z raw.githubusercontent.com (raw.githubusercontent.com)|185.199.109.133|:443... połączono.
Żądanie HTTP wysłano, oczekiwanie na odpowiedź... 200 OK
Długość: 29605 (29K) [application/octet-stream]
Zapis do: `BCM43142A0-0930-0225.hcd.1'

BCM43142A0-0930-022 100%[===================>]  28,91K  --.-KB/s    w 0,004s  

2022-04-14 22:47:42 (7,67 MB/s) - zapisano `BCM43142A0-0930-0225.hcd.1' [29605/29605]


(14-04-2022, 19:57)yahoob3 napisał(a): Można jeszcze sprawdzić ten sterownik:
Kod:
cd /lib/firmware/brcm
wget https://github.com/winterheart/broadcom-bt-firmware/raw/master/brcm/BCM43142A0-0a5c-216d.hcd

Oczywiście restart komputera.


Przy tej próbie wyrzuciło to (także bez naprawy):

Kod:
--2022-04-14 22:51:12--  https://github.com/winterheart/broadcom-bt-firmware/raw/master/brcm/BCM43142A0-0a5c-216d.hcd
Translacja github.com (github.com)... 140.82.121.3
Łączenie się z github.com (github.com)|140.82.121.3|:443... połączono.
Żądanie HTTP wysłano, oczekiwanie na odpowiedź... 302 Found
Lokalizacja: https://raw.githubusercontent.com/winterheart/broadcom-bt-firmware/master/brcm/BCM43142A0-0a5c-216d.hcd [podążanie]
--2022-04-14 22:51:13--  https://raw.githubusercontent.com/winterheart/broadcom-bt-firmware/master/brcm/BCM43142A0-0a5c-216d.hcd
Translacja raw.githubusercontent.com (raw.githubusercontent.com)... 185.199.111.133, 185.199.108.133, 185.199.109.133, ...
Łączenie się z raw.githubusercontent.com (raw.githubusercontent.com)|185.199.111.133|:443... połączono.
Żądanie HTTP wysłano, oczekiwanie na odpowiedź... 200 OK
Długość: 29618 (29K) [application/octet-stream]
BCM43142A0-0a5c-216d.hcd: Brak dostępu

Nie można zapisać do `BCM43142A0-0a5c-216d.hcd' (Sukces).






(14-04-2022, 19:57)yahoob3 napisał(a): Co do secure boot mode... poza tym "Standard" jest jeszcze coś do wyboru?


Rzuć okiem jeszcze na ten stary wątek: https://forum.linuxmint.pl/archive/index...ad-73.html


Jeśli zmienię na ENABLED, wtedy mam możliwość wyboru opcji CUSTOM


Co do tego starego wątku.. Mogę prosić o pomoc? Bo wyciągnąłem kod tak jak tam było napisane, ale mój różni sie nieco od tego w powyższym poście (nie znajduję u mnie  linii z "Bluetooth module")
Kod:
lspci -nnk | grep -iA3 net; lsusb; dmesg | egrep -i 'blue|firm'
07:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM43142 802.11b/g/n [14e4:4365] (rev 01)
    Subsystem: Foxconn International, Inc. BCM43142 802.11b/g/n [105b:e071]
    Kernel driver in use: wl
    Kernel modules: wl
--
0e:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c)
    Subsystem: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:0123]
    Kernel driver in use: r8169
    Kernel modules: r8169
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 5986:0543 Acer, Inc
Bus 001 Device 003: ID 0489:e062 Foxconn / Hon Hai
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[    0.132485] Spectre V2 : Enabling Restricted Speculation for firmware calls
[    1.458423] ACPI: video: [Firmware Bug]: ACPI(PEGP) defines _DOD but not _DOS
[    8.039575] Bluetooth: Core ver 2.22
[    8.039614] Bluetooth: HCI device and connection manager initialized
[    8.039621] Bluetooth: HCI socket layer initialized
[    8.039625] Bluetooth: L2CAP socket layer initialized
[    8.039632] Bluetooth: SCO socket layer initialized
[    8.446716] Bluetooth: hci0: BCM: chip id 70
[    8.448416] Bluetooth: hci0: BCM: features 0x06
[    8.464370] Bluetooth: hci0: mariusz-SonyVAIO
[    8.464378] Bluetooth: hci0: BCM43142A0 (001.001.011) build 0000
[    8.466233] Bluetooth: hci0: BCM: firmware Patch file not found, tried:
[    8.466241] Bluetooth: hci0: BCM: 'brcm/BCM43142A0-0489-e062.hcd'
[    8.466245] Bluetooth: hci0: BCM: 'brcm/BCM-0489-e062.hcd'
[    9.564705] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    9.564712] Bluetooth: BNEP filters: protocol multicast
[    9.564718] Bluetooth: BNEP socket layer initialized
[   10.472004] Bluetooth: hci0: command 0x1003 tx timeout
[   10.473402] Bluetooth: hci0: unexpected event for opcode 0x1003
[   14.318901] Bluetooth: RFCOMM TTY layer initialized
[   14.318914] Bluetooth: RFCOMM socket layer initialized
[   14.318925] Bluetooth: RFCOMM ver 1.11
#10
0
Pomysły mi się kończą...

Spróbowałbym jeszcze z katalogu /lib/firmware/brcm jako administrator (czyli klikasz katalog brcm PPM i wybierasz "Otwórz jako administrator") usunąć wszystkie pliki "BCMxxxxx.hcd" i wykonać to (mój błąd zabrakło sudo):
Kod:
cd /lib/firmware/brcm

sudo wget https://github.com/winterheart/broadcom-bt-firmware/raw/master/brcm/BCM43142A0-0a5c-216d.hcd

W /lib/firmware/brcm powinno być kilka plików *.hcd, które wgrywałeś... któryś powinien zadziałać. Możesz ręcznie je ściągnąć i sprawdzić po kolei. Tylko trzeba pamiętać, że katalog brcm otwierasz jako administrator:

[Obrazek: nhhyCZu.png]

I możesz "okienkowo" sobie sprawdzać. Sterownika do tej karty jest kilka wersji. Kwestia zapewne znalezienia odpowiedniej.


Skocz do:




Użytkownicy przeglądający ten wątek: 1 gości