Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Asus - klawisze funkcyjne
#1
Photo 
0
Nowy lap i potrzeba pewnie zainstalować sterowniki dla klawiszy funkcyjnych. Np FN+F7 powinno zmniejszyć jasność ale nic się nie dzieje. Przydałoby się też móc wyłączyć podświetlenie klawiatury. Fajne jest ale nie przez cały czas działania :-) Na Windows z tego co pamiętam to się nazywało "ATK Package".

Chodzi o ten model. Może pomoże :-)

https://www.x-kom.pl/p/499626-notebook-l...b-512.html
Odpowiedz
#2
0
Jesteś już na forum dłuższy czas. Wydaje mi się, że powinieneś już zdawać sobie sprawę z tego, że najważniejsze w takich przypadkach jest określenie, jakie dokładnie komponenty ma ten komputer.
Wynik polecenia inxi -Fxz będzie tu odpowiedni.
Odpowiedz
#3
0
(16-01-2020, 18:51)yahoob3 napisał(a): Jesteś już na forum dłuższy czas. Wydaje mi się, że powinieneś już zdawać sobie sprawę z tego, że najważniejsze w takich przypadkach jest określenie, jakie dokładnie komponenty ma ten komputer.
Wynik polecenia inxi -Fxz będzie tu odpowiedni.
Kod:
System:
  Host: Asusik-ROG Kernel: 4.15.0-74-generic x86_64 bits: 64 compiler: gcc
  v: 7.4.0 Desktop: Cinnamon 4.0.10 Distro: Linux Mint 19.1 Tessa
  base: Ubuntu 18.04 bionic
Machine:
  Type: Laptop System: ASUSTeK product: ROG Strix G731GT_G731GT v: 1.0
  serial: <filter>
  Mobo: ASUSTeK model: G731GT v: 1.0 serial: <filter>
  UEFI: American Megatrends v: G731GT.303 date: 06/05/2019
Battery:
  ID-1: BAT0 charge: 52.9 Wh condition: 52.9/50.5 Wh (105%)
  model: ASUSTeK ASUS Battery status: Not charging
  Device-1: hidpp_battery_0 model: Logitech Performance MX charge: 0%
  status: Discharging
CPU:
  Topology: Quad Core model: Intel Core i5-9300H bits: 64 type: MT MCP
  arch: Kaby Lake rev: D L2 cache: 8192 KiB
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 38400
  Speed: 900 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 860 2: 876
  3: 895 4: 875 5: 802 6: 899 7: 894 8: 896
Graphics:
  Device-1: Intel vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0
  Device-2: NVIDIA vendor: ASUSTeK driver: nvidia v: 435.21 bus ID: 01:00.0
  Display: x11 server: X.Org 1.19.6 driver: modesetting,nvidia
  unloaded: fbdev,nouveau,vesa resolution: 1920x1080~60Hz
  OpenGL: renderer: GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA 435.21
  direct render: Yes
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel
  v: kernel bus ID: 00:1f.3
  Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel
  bus ID: 01:00.1
  Sound Server: ALSA v: k4.15.0-74-generic
Network:
  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi
  v: kernel port: 5000 bus ID: 00:14.3
  IF: wlo1 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: ASUSTeK driver: r8169 v: 2.3LK-NAPI port: 3000 bus ID: 03:00.0
  IF: eno2 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 44.17 GiB (9.3%)
  ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW512G8 size: 476.94 GiB
Partition:
  ID-1: / size: 467.96 GiB used: 44.16 GiB (9.4%) fs: ext4
  dev: /dev/nvme0n1p2
Sensors:
  System Temperatures: cpu: 57.0 C mobo: N/A gpu: nvidia temp: 37 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 282 Uptime: 3m Memory: 7.65 GiB used: 1.46 GiB (19.0%)
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20
  inxi: 3.0.27

Dodano po pewnym czasie:
Miałem nadzieję, że wystarczy wpisać do repozytorium zapytanie o sterowniki do klawiatury :-)

Dodano po pewnym czasie:
Coś nie do końca mi ten Kod chyba wyszedł... sorki :-)

Dodano po pewnym czasie:
Na wcześniejszym Asusie moim klawisze funkcyjne działały normalnie od razu. A teraz co?????

Dodano po pewnym czasie:
Koniec końców nie wiem w ogóle jak móc zmieniać jasność ekranu...

Dodano po pewnym czasie:
Szukając na forach w necie trafiłem na parę rad by pogrzebać w kernelu....
Odpowiedz
#4
0
Możesz spróbować zainstalować przez menedżer aktualizacji nowsze jądro, np. z serii 5 (ostatnie dostępne), lub spróbować wykonać to, co napisane jest w 2 poście - odpowiedzi na podobny do Twojego problem: https://unix.stackexchange.com/questions...sus-n551vw.
Odpowiedz
#5
0
Tam też szukałem ale podane działania są dla mnie dość za bardzo zaawansowane i jak próbowałem wpisywać w terminalu to system tego nie rozumiał.
Hurra.. właśnie odkryłem, że jasność mogę regulować klikając na ikonkę baterii na pasku na dole po prawej.  Ciekawe to miejsce na sterowanie jasnością eh :-P

Dodano po pewnym czasie:
A może da coś zainstalowanie Łinołoswych sterowników np za pośrednictwem PlayOnLinux, Lutrisa czy innych Wine? :-) Sprawdzę to :-)

Dodano po pewnym czasie:
No nic... może będę zmuszony wrócić do "Gejtsówy" no nie mogę swobodnie operować nawet klawiaturą.... Wrrrrrrrrrrrrrrrrrrr....
Odpowiedz
#6
0
Tym poleceniem (jesli nie działa) włączysz najprawdopodobniej podświetlanie klawiatury:
Kod:
sudo /etc/acpi/asus-keyboard-backlight.sh

Co do klawiszy funkcyjnych i "zabawy z kernelem" do powinno dać się je uruchomić dodając parametr do /etc/default/grub
Spróbuj edytować ww. plik i zmienić liniję: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
na taką: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
Edycję pliku wykonasz poleceniem:
Kod:
xed admin:///etc/default/grub
W biosie ACPI musi być oczywiście włączone.

Gdyby to nie dało rezultatu zamiast acpi_backlight=vendor w ww. linijce możesz spróbować takiego parametru: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor intel_pstate=enable", po zmianie treści i zapisaniu zmian w pliku trzeba wykonać sudo update-grub i zrestartować komputer, np. poleceniem sudo reboot.


EDIT:
Jeszcze jedna możliwość - edytujesz polik /etc/X11/xorg.conf.d/20-nvidia.conf
Kod:
xed admin:////etc/X11/xorg.conf.d/20-nvidia.conf
i wklejasz do niego taką treść:
Kod:
Section "Device"
   Identifier     "Device0"
   Driver         "nvidia"
   VendorName     "NVIDIA Corporation"
   Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection
Zapisujesz plik i restartujesz komputer.
Odpowiedz
#7
0
Kod:
[email protected]:~$ xed admin:///etc/default/grub

** (xed:2373): WARNING **: 16:32:22.538: Podane położenie nie jest zamontowane

(xed:2373): Gdk-CRITICAL **: 16:32:22.541: gdk_window_get_window_type: assertion 'GDK_IS_WINDOW (window)' failed

(xed:2373): Gtk-CRITICAL **: 16:33:15.666: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:2373): Gtk-CRITICAL **: 16:33:15.667: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:2373): Gtk-CRITICAL **: 16:33:15.667: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:2373): Gtk-CRITICAL **: 16:33:15.667: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:2373): Gtk-CRITICAL **: 16:33:15.670: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:2373): Gtk-CRITICAL **: 16:33:15.673: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:2373): Gtk-CRITICAL **: 16:33:20.343: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:2373): Gtk-CRITICAL **: 16:33:20.343: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:2373): Gtk-CRITICAL **: 16:33:20.343: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:2373): Gtk-CRITICAL **: 16:33:20.343: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:2373): Gtk-CRITICAL **: 16:33:20.343: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed
 

Dodano po pewnym czasie:
Ta masa błędów trochę martwi...

Dodano po pewnym czasie:
W biosie gdzie mam sprawdzić czy ACPI jest włączone... przeglądałem wszystkie zakładki i nie znalazłem tam nic gdzie byłaby choćby wzmianka o ACPI :-)

Dodano po pewnym czasie:
"Nie można odnaleźć pliku admin:////etc/X11/xorg.conf.d/20-nvidia.conf."

Dodano po pewnym czasie:
Kod:
[email protected]:~$ sudo /etc/acpi/asus-keyboard-backlight.sh
[sudo] hasło użytkownika mateo:         
[email protected]:~$

W moim przpadku tylko to się pojawiło czyli... nic.

Dodano po pewnym czasie:
Kuba... bardzo jestem Ci wdzięczny bo naprawdę poświęcasz czas by pomóc ale nic to nie daje... tyle dobrze, że jasność mogę regulować apletem. Przypomniałem sobie, że są ta aplety "-)

Dodano po pewnym czasie:
Ci ludzie już wszystko co nowe to robią tylko pod ŁINDOŁSA i nie dają innych opcji... Wku.... mnie to ale tak może być.
Odpowiedz
#8
0
(Wczoraj, 17:34)InfiniteLove napisał(a):
Kod:
[email protected]:~$ xed admin:///etc/default/grub

** (xed:2373): WARNING **: 16:32:22.538: Podane położenie nie jest zamontowane

(xed:2373): Gdk-CRITICAL **: 16:32:22.541: gdk_window_get_window_type: assertion 'GDK_IS_WINDOW (window)' failed
[...]
 
Ta masa błędów trochę martwi...
To można olać... tak się dzieje, gdy odpalasz okienkowy program z poziomu terminala. Smile
Podałeś hasło dwa razy? Tego ten nowy "gksu" wymaga...

Cytat:W biosie gdzie mam sprawdzić czy ACPI jest włączone... przeglądałem wszystkie zakładki i nie znalazłem tam nic gdzie byłaby choćby wzmianka o ACPI :-)


Dodano po pewnym czasie:
"Nie można odnaleźć pliku admin:////etc/X11/xorg.conf.d/20-nvidia.conf."
Dobra, na razie zostaw to.
Cytat:
Kod:
[code][email protected]:~$ sudo /etc/acpi/asus-keyboard-backlight.sh
[sudo] hasło użytkownika mateo:         
[email protected]:~$

W moim przpadku tylko to się pojawiło czyli... nic.
To akurat dobrze.

Spróbuj na razie poprawnie wykonać zmianę w "etc/.../grub", z sudo update-grub i sudo reboot na końcu.
Odpowiedz
#9
0
Bez zmian. Co to właściwie ma znaczyć "poprawnie"? Ja kopiuje i wklejam to co napisałeś :-)

Serio... na moim starszym Asusie klawisze skrótowe działały od razu po instalacji. Pisałem już co myślę o "nowościach"? Więcej z nimi problemów zdecydowanie...
Odpowiedz
#10
0
Poprawnie to znaczy, że powinno wyświetlić się coś podobnego:
Kod:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
W tym pliku dokonać zmian, o których pisałem wcześniej.

Nowsze jądro też może pomóc...
Odpowiedz


Skocz do:




Użytkownicy przeglądający ten wątek: 1 gości